Bug 7093 - Unpluggin USB with DVB stream hangs
Unpluggin USB with DVB stream hangs
Status: REJECTED WILL_NOT_FIX
Product: Drivers
Classification: Unclassified
Component: USB
i386 Linux
: P2 normal
Assigned To: Greg Kroah-Hartman
:
: 7094 (view as bug list)
Depends on:
Blocks: USB
  Show dependency treegraph
 
Reported: 2006-08-31 13:30 UTC by Mark
Modified: 2006-08-31 13:55 UTC (History)
0 users

See Also:
Kernel Version: 2.6.17 and earlier
Tree: Mainline
Regression: ---


Attachments

Description Mark 2006-08-31 13:30:13 UTC
Most recent kernel where this bug did not occur:
This bug has always been there AFAIK

Distribution: FC5
Hardware Environment: laptop with USB2 and Hauppage WinTV-NOVA-T usb2 DVB 
device.

Software Environment:
The following DVB related modules are loaded
dvb_usb_nova_t_usb2   dvb_usb_dibusb_common  dib3000mc dvb_usb   dvb_core    
dvb_pll    

Problem Description:
Plug in USB with DVB device,
Play a stream (using kaffeine)
Unplug the USB while stream is playing.
-> THe computer hangs and needs a reset.

There are no messages, so it is trciky to debug for me.


It basically means that a user can scrash the computer. Given the commonplace 
of USB dvb cards nowadyas, this bug is becoming more relevant.


Steps to reproduce:
Comment 1 Greg Kroah-Hartman 2006-08-31 13:52:45 UTC
*** Bug 7094 has been marked as a duplicate of this bug. ***
Comment 2 Greg Kroah-Hartman 2006-08-31 13:55:04 UTC
That's a dvb specific issue.  and those developers don't seem to use this
bugzilla for this kind of thing.  Care to contact them at linux-dvb@linuxtv.org
to let them know this issue?

There's not much I can do here, sorry.

Note You need to log in before you can comment on or make changes to this bug.