Bug 7089 - ACPI: Looking for DSDT ... not found! - ASUS M2NPV-VM
ACPI: Looking for DSDT ... not found! - ASUS M2NPV-VM
Status: REJECTED INVALID
Product: ACPI
Classification: Unclassified
Component: Config-Tables
i386 Linux
: P2 normal
Assigned To: acpi_other
:
: 7090 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-31 10:59 UTC by Gerald Britton
Modified: 2006-08-31 13:36 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.15.26
Tree: Mainline
Regression: ---


Attachments
output of command dmeseg -64000 (26.61 KB, text/plain)
2006-08-31 11:14 UTC, Gerald Britton
Details
acpidump output (149.83 KB, text/plain)
2006-08-31 11:45 UTC, Gerald Britton
Details
kernel config (61.42 KB, text/plain)
2006-08-31 11:59 UTC, Gerald Britton
Details

Description Gerald Britton 2006-08-31 10:59:31 UTC
Most recent kernel where this bug did not occur: unknown
Distribution: ubuntu lts 6.06
Hardware Environment: ASUS M2NPV-VM mainboard with AMD-64 X2 CPU
Software Environment: ubuntu
Problem Description: during startup, this message appears:

ACPI: Looking for DSDT ... not found!


Steps to reproduce: boot the system, watch the kernel messages
Comment 1 Len Brown 2006-08-31 11:08:45 UTC
This is reported against 2.6.15.stable.  
Is it possible to test someting more recent, 
such as 2.6.17.stable, or ideally 2.6.18? 
  
please attach the complete output from dmesg -s64000  
please attach the .config used to build the kernel.  
please attach the output from acpidump, a utility  
that is available in the latest pmtools here:  
http://ftp.kernel.org/pub/linux/kernel/people/lenb/acpi/utils/  
Comment 2 Gerald Britton 2006-08-31 11:14:37 UTC
Created attachment 8922 [details]
output of command dmeseg -64000
Comment 3 Gerald Britton 2006-08-31 11:17:45 UTC
*** Bug 7090 has been marked as a duplicate of this bug. ***
Comment 4 Gerald Britton 2006-08-31 11:45:18 UTC
Created attachment 8923 [details]
acpidump output
Comment 5 Gerald Britton 2006-08-31 11:59:18 UTC
Created attachment 8924 [details]
kernel config
Comment 6 Len Brown 2006-08-31 12:28:52 UTC
> ACPI: Looking for DSDT ... not found! 
 
This message is not in the kernel.org kernel source tree, either 
as of 2.6.15, or as of 2.6.18.  While your system seems to have 
plenty of other problems, ACPI did find the DSDT and it is running 
normally. 
 
I expect this message comes from the "initrd DSDT override patch" 
that some distributions, such as SuSE and Ubuntu tend to add to 
the kernel as their "value add" -- complain to them. 
 
 
Comment 7 Robert Moore 2006-08-31 12:33:07 UTC
I could not find this message either.

A very odd (and invalid) FACS on this machine, however:

FACS @ 0x3def0000
  0000: 46 41 43 53 40 00 00 00 00 00 00 00 00 00 00 00  FACS@...........
  0010: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00  ................
  0020: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00  ................
  0030: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00  ................

No global lock, no firmware waking vector. This may cause ACPICA problems. 
Again, the issue of "how much validation do we perform on the tables" arises.

Comment 8 Robert Moore 2006-08-31 13:36:12 UTC
Looks like the FACS is OK after all. Global Lock is in fact optional. Other 
fields are OK at zero.

Note You need to log in before you can comment on or make changes to this bug.