Bug 7048 - Cannot repeatedly dock and undock with Dell M90 and M65
Cannot repeatedly dock and undock with Dell M90 and M65
Status: CLOSED PATCH_ALREADY_AVAILABLE
Product: ACPI
Classification: Unclassified
Component: Config-Hotplug
i386 Linux
: P2 normal
Assigned To: Kristen
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-23 17:14 UTC by Kristen
Modified: 2007-11-27 09:58 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.18-rc4-git1
Tree: Mainline
Regression: ---


Attachments
kernel.log after power on to slot (6.66 KB, text/plain)
2006-11-18 14:59 UTC, Pavel Kysilka
Details
full acpi debug from docking (37.78 KB, application/x-bzip2)
2006-12-26 14:13 UTC, Pavel Kysilka
Details

Description Kristen 2006-08-23 17:14:51 UTC
Most recent kernel where this bug did not occur: n/a

Distribution:
SLED10 with kernel.org kernel

Hardware Environment:
Dell Precision M90 laptop
Dell D/Dock Expansion Station

Problem Description:
When repeatedly docking and undocking the Dell M90 from the dock station,
the hardware dock eject button will no longer cause the dock to be
released cleanly from the dock station.  The led remains green and does not
indicate that it is safe to dock.  This can happen after an indeterminate
number of dock/undocks - it is variable.

Steps to reproduce:
1.  Important - this problem seems to only occur if you boot the laptop
inside the dock station, then begin to undock/dock repeatedly.
Boot with laptop in dock station.
2.  Load dock drivers:  
  modprobe dock; modprobe acpiphp
3.  undock and dock repeatedly until failure occurs. This will take a 
variable number of tries.
Comment 1 Kristen 2006-08-24 11:33:14 UTC
I also tested the M65 which has the same problem, however, I was able to
duplicate this issue without booting in the dock station first.  I expect that I
just wasn't patient enough to find it with the M90.  I will investigate further
to see if I can tell if this is a dsdt problem, or a driver issue.
Comment 2 Gregor Schaffrath 2006-10-25 17:43:06 UTC
I beleave I've got a similiar problem with the IBM R52 and the Dock II:
After booting in the docking station, everything works, but undocking the
machine leaves the docking bridge as
0000:0b:03.0 ffff: Texas Instruments PCI2032 PCI Docking Bridge (rev ff)
in lspci.
After this, the station refuses to initialize upon docking and the laptop
refuses to go into suspend until rebooted properly.

After booting outside the docking station, docking works but pressing the eject
button won't release the notebook (the docking station stays in powered up mode
but the extension slots are removed) until it has been powered down.

It may be of interest that the frequency of this happening seems to vary from
docking station to docking station - mine shows this behaviour everytime I use
it, 2 other stations show it in a seemingly nondeterministic fashion (after a
varying number of docking/undocking operations)
Comment 3 Kristen 2006-10-26 13:45:36 UTC
Gregor,
Thanks for the report!  Can you tell me if you are loading the acpiphp (ACPI 
based PCI hotplug) module in addition to the dock driver?  On the Dock II, due
to the PCI slots on the station you do need to have both drivers loaded in 
order to get the PCI bridge/devices inserted and removed properly.
Comment 4 Gregor Schaffrath 2006-10-27 05:48:32 UTC
Hi Kristen. thx for the quick response.

acpiphp is compiled into the kernel. See:
http://graphics.cs.uni-sb.de/~grsch/dock/dot.config
http://graphics.cs.uni-sb.de/~grsch/dock/lsmod
http://graphics.cs.uni-sb.de/~grsch/dock/kernel.params
[State: booted outside the dock, undocked ;) , kernel 2.6.18]

Regards,
         Gregor.
Comment 5 Pavel Kysilka 2006-11-10 19:55:44 UTC
I have similar problem with this bugreport in my ThinkPad A21m.
acpiphp module with parameter debug=1 loaded.

booting with dock:

-[0000:00]-+-00.0  Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host bridge
           +-01.0-[0000:01]----00.0  ATI Technologies Inc Rage Mobility P/M AGP 2x
           +-02.0  Texas Instruments PCI1450
           +-02.1  Texas Instruments PCI1450
           +-03.0  Intel Corporation 82557/8/9 [Ethernet Pro 100]
           +-03.1  Xircom Mini-PCI V.90 56k Modem
           +-04.0-[0000:08-0e]--+-01.0  Silicon Image, Inc. PCI0648
           |                    +-02.0  Texas Instruments PCI1420
           |                    \-02.1  Texas Instruments PCI1420
           +-05.0  Cirrus Logic CS 4614/22/24 [CrystalClear SoundFusion Audio
Accelerator]
           +-07.0  Intel Corporation 82371AB/EB/MB PIIX4 ISA
           +-07.1  Intel Corporation 82371AB/EB/MB PIIX4 IDE
           +-07.2  Intel Corporation 82371AB/EB/MB PIIX4 USB
           \-07.3  Intel Corporation 82371AB/EB/MB PIIX4 ACPI


booting without dock and __after docking__ .

-[0000:00]-+-00.0  Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host bridge
           +-01.0-[0000:01]----00.0  ATI Technologies Inc Rage Mobility P/M AGP 2x
           +-02.0  Texas Instruments PCI1450
           +-02.1  Texas Instruments PCI1450
           +-03.0  Intel Corporation 82557/8/9 [Ethernet Pro 100]
           +-03.1  Xircom Mini-PCI V.90 56k Modem
           +-05.0  Cirrus Logic CS 4614/22/24 [CrystalClear SoundFusion Audio
Accelerator]
           +-07.0  Intel Corporation 82371AB/EB/MB PIIX4 ISA
           +-07.1  Intel Corporation 82371AB/EB/MB PIIX4 IDE
           +-07.2  Intel Corporation 82371AB/EB/MB PIIX4 USB
           \-07.3  Intel Corporation 82371AB/EB/MB PIIX4 ACPI

Comment 6 Gregor Schaffrath 2006-11-16 12:32:20 UTC
Hi - can I provide you with any more details to help resolving the issue?

Regards,
         Gregor.
Comment 7 Pavel Kysilka 2006-11-18 14:59:40 UTC
Created attachment 9562 [details]
kernel.log after power on to slot

Hi,

i am playing with hotplug and docking. There is new expirience.
If I docking, no new devices shown with lspci output.
After
echo 1 > /sys/bus/pci/slots/1/power 

PCI devices on the dock are shown and lspci output is OK.
But there is many error. lsusb dot not show usb controler on slot. Look at the
attachment.
Tested with todays linux-git kernel.
Comment 8 Kristen 2006-11-28 10:22:34 UTC
On Sat, 18 Nov 2006 15:01:13 -0800
bugme-daemon@bugzilla.kernel.org wrote:

> http://bugzilla.kernel.org/show_bug.cgi?id=7048
> 
> 
> 
> 
> 
> ------- Additional Comments From goldenfish@bsys.cz  2006-11-18 14:59 -------
> Created an attachment (id=9562)
>  --> (http://bugzilla.kernel.org/attachment.cgi?id=9562&action=view)
> kernel.log after power on to slot
> 
> Hi,
> 
> i am playing with hotplug and docking. There is new expirience.
> If I docking, no new devices shown with lspci output.
> After
> echo 1 > /sys/bus/pci/slots/1/power 


you can't dock/undock using the sysfs pci slot entries.  Use the physical
buttons on your dock station.  Please post additional questions to the
linux-acpi mailing list, as this does not have anything to do with this
bugzilla entry.

Thanks,
Kristen

> 
> PCI devices on the dock are shown and lspci output is OK.
> But there is many error. lsusb dot not show usb controler on slot. Look at the
> attachment.
> Tested with todays linux-git kernel.
> 
> ------- You are receiving this mail because: -------
> You are the assignee for the bug, or are watching the assignee.
> You reported the bug, or are watching the reporter.
> 

Comment 9 Kristen 2006-11-28 10:24:59 UTC
On Thu, 16 Nov 2006 12:33:41 -0800
bugme-daemon@bugzilla.kernel.org wrote:

> http://bugzilla.kernel.org/show_bug.cgi?id=7048
> 
> 
> 
> 
> 
> ------- Additional Comments From grsch-kernel@ran-dom.org  2006-11-16 12:32 -------
> Hi - can I provide you with any more details to help resolving the issue?
> 
> Regards,
>          Gregor.

Gregor,
Can you please open a separate bugzilla entry for this?  I don't believe
it is the same problem.  go ahead and put bug 7048 as a dependency though
so we can see if they are related.  

Sorry for the delay, I was on vacation.

Kristen


> 
> ------- You are receiving this mail because: -------
> You are the assignee for the bug, or are watching the assignee.
> You reported the bug, or are watching the reporter.
> 

Comment 10 Gregor Schaffrath 2006-11-30 04:08:49 UTC
hi kristen.
np - but there was an interesting development yesterday when I realized that
there was another way for hotswapping ultrabay devices than lt_hotswap and threw
it out of my setup: This evening, I couldn't undock even a single time anymore
until the next morning... after cutting the power to the dock and rebooting once
in the docking station, the problem's (almost) gone (now it seems as if only the
pc-card slots were not reinitialized upon reinsertion of the laptop into the dock).
So it seems you're right: there seems to have been a problem using lt_hotswap
together with acpiphp+dock...

thx for the effort and (though I'm still a bit sceptical about the current peace
;) ) maybe some other folks with thinkpads share the same cause for undocking
problems...

Regards,
         Gregor.
Comment 11 Kristen 2006-11-30 09:08:49 UTC
Oh yes - you absolutely CANNOT use lt_hotswap with the new dock driver,
because it tries to do the same thing that dock.ko does - and as you saw 
from your experience, it does not do it correctly.  you don't need it anyway.

Kristen

On Thu, 30 Nov 2006 04:11:29 -0800
bugme-daemon@bugzilla.kernel.org wrote:

> http://bugzilla.kernel.org/show_bug.cgi?id=7048
> 
> 
> 
> 
> 
> ------- Additional Comments From grsch-kernel@ran-dom.org  2006-11-30 04:08 -------
> hi kristen.
> np - but there was an interesting development yesterday when I realized that
> there was another way for hotswapping ultrabay devices than lt_hotswap and threw
> it out of my setup: This evening, I couldn't undock even a single time anymore
> until the next morning... after cutting the power to the dock and rebooting once
> in the docking station, the problem's (almost) gone (now it seems as if only the
> pc-card slots were not reinitialized upon reinsertion of the laptop into the dock).
> So it seems you're right: there seems to have been a problem using lt_hotswap
> together with acpiphp+dock...
> 
> thx for the effort and (though I'm still a bit sceptical about the current peace
> ;) ) maybe some other folks with thinkpads share the same cause for undocking
> problems...
> 
> Regards,
>          Gregor.
> 
> 
> ------- You are receiving this mail because: -------
> You are the assignee for the bug, or are watching the assignee.
> You reported the bug, or are watching the reporter.
> 

Comment 12 Pavel Kysilka 2006-12-26 14:13:18 UTC
Created attachment 9953 [details]
full acpi debug from docking

TP A21m. 
size - 8MB uncompressed
Comment 13 Kristen 2007-03-14 11:07:19 UTC
Confirmed this problem still exists in 2.6.21-rc3.  Also, I will get an OOPs in
acpid if the laptop is redocked prior to the completion of the _DCK method,
which seems to take an extremely long time on the Dell laptops (in the order of
10s of seconds).  Am checking to see if an updated BIOS is available - but it
would be nice if acpid did not oops.
Comment 14 Kristen 2007-11-27 09:58:54 UTC
BIOS update for M65 fixes the issue with the exception of led flashing.  

Note You need to log in before you can comment on or make changes to this bug.