Bug 70421 - ACPI ambient light sensor
Summary: ACPI ambient light sensor
Status: CLOSED PATCH_ALREADY_AVAILABLE
Alias: None
Product: ACPI
Classification: Unclassified
Component: Other (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Zhang Rui
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-12 09:30 UTC by Oleksij Rempel
Modified: 2014-06-23 01:16 UTC (History)
5 users (show)

See Also:
Kernel Version: 3.14
Tree: Mainline
Regression: No


Attachments

Description Oleksij Rempel 2014-02-12 09:30:37 UTC
If i see it correctly  driver for ambient light sensor was some there in the wild since 2009, but never included.
Now, almost every laptop with Windows 8 support, has one sensor. Will it be possible to include it to the kernel?
http://lkml.iu.edu//hypermail/linux/kernel/0909.2/02581.html
https://github.com/seidler2547/linux-acpi-als/commits/master

If you need testing i have access to Asus UX302 and UX31A, both with ALS on board.
Comment 1 Lan Tianyu 2014-02-14 01:49:15 UTC
Assign to Rui since he is these patches owner.
Comment 2 Aaron Lu 2014-03-14 03:07:51 UTC
Rui,

What's the status of the patches?
Comment 3 Zhang Rui 2014-06-03 06:23:56 UTC
Marek Vasut has rewrite the driver and now is submitting it to IIO subsystem.
Comment 5 xerofoify 2014-06-22 02:57:51 UTC
This seems to be fixed guys.It would be great if you closes 
this fixed bug.
Thanks a fellow developer,
Nick

Note You need to log in before you can comment on or make changes to this bug.