Bug 70401 - No battery or AC information on Venue 8 Pro (Bay Trail tablet device)
Summary: No battery or AC information on Venue 8 Pro (Bay Trail tablet device)
Status: CLOSED DUPLICATE of bug 69011
Alias: None
Product: ACPI
Classification: Unclassified
Component: Power-Battery (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Lan Tianyu
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-11 18:45 UTC by Adam Williamson
Modified: 2014-02-17 01:12 UTC (History)
1 user (show)

See Also:
Kernel Version: 3.14rc2
Tree: Fedora
Regression: No


Attachments

Description Adam Williamson 2014-02-11 18:45:20 UTC
On the Dell Venue 8 Pro, an Intel Bay Trail-based tablet device, with all kernels tested so far (3.11 through 3.14rc2), there is no kind of power status information - no battery stats, no indication of whether the device is on AC or battery. upower doesn't have any kind of info at all, it doesn't know there is a battery - it's pretty clear the kernel layer isn't providing any information.

I'm using Fedora Rawhide kernels with appropriate patches to actually boot on these devices, but I believe everyone using one of these Bay Trail tablets with whatever distro / kernel - the V8P, Lenovo Miix2, Asus T100 etc - has seen the same.

I'll attach boot logs and acpidump from the V8P in a few hours (building a new kernel ATM).
Comment 1 Lan Tianyu 2014-02-12 02:05:57 UTC
I think this bug is as same as bug 69011. Please have a check.
Comment 2 Adam Williamson 2014-02-12 02:19:58 UTC
ah, yup, looks like it. others on the Secret Baytrail Cabal CC list didn't know of that bug, it seems. Thanks.

Jan-Michael Brummer is working on this, so you may want to co-ordinate with him - "We can already talk to the battery and receive some status information, but again this will need a proper patch."
Comment 3 Adam Williamson 2014-02-12 02:20:07 UTC

*** This bug has been marked as a duplicate of bug 69011 ***

Note You need to log in before you can comment on or make changes to this bug.