Bug 7037 - swsusp hangs on headless resume-from-ram
swsusp hangs on headless resume-from-ram
Status: CLOSED WILL_NOT_FIX
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
i386 Linux
: P2 low
Assigned To: Rafael J. Wysocki
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2006-08-21 20:35 UTC by Al Boldi
Modified: 2007-10-12 13:04 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.16+
Tree: Mainline
Regression: ---


Attachments
kill debugging junk that touches console from early wakeup (5.32 KB, application/octet-stream)
2007-08-16 02:29 UTC, Pavel Machek
Details

Description Al Boldi 2006-08-21 20:35:00 UTC
On Wed 2006-08-02 16:46:11, Al Boldi wrote: 
> Pavel Machek wrote: 
> > On Wed 26-07-06 22:06:48, Al Boldi wrote: 
> > > swsusp is really great, most of the time. 
Comment 1 Pavel Machek 2006-08-24 01:20:12 UTC
Okay, when I pushed you into bugzilla, I expected you to provide some more info.

a) What kind of system is it?

b) So it always hangs with display card removed, but sometimes works with card
present?

c) What kind of graphics card is it? Do you use vgafb? vesafb?

d) Does compiling kernel without graphics card support help?

e) What is the most recent version of kernel you tested it with?
Comment 2 Al Boldi 2006-08-26 11:56:26 UTC
bugme-daemon@bugzilla.kernel.org wrote:
> http://bugzilla.kernel.org/show_bug.cgi?id=7037
> ------- Additional Comments From pavel@suse.cz  2006-08-24 01:20 -------
> Okay, when I pushed you into bugzilla, I expected you to provide some more
> info.
>
> a) What kind of system is it?

see attached.

> b) So it always hangs with display card removed, but sometimes works with
> card present?

Yes.

> c) What kind of graphics card is it?

Normal vga card. (S3virge)

> Do you use vgafb? vesafb?

No.

> d) Does compiling kernel without graphics card support help?

No.

> e) What is the most recent version of kernel you tested it with?

2.6.17

BTW, are you able to reproduce the problem on your machine?


Thanks!

--
Al




Comment 3 Anonymous Emailer 2006-08-26 16:26:14 UTC
Reply-To: pavel@ucw.cz


> BTW, are you able to reproduce the problem on your machine?

Not easily. Removing graphics card from x60 is not easy, and would
probably involve hammer :-(.

Comment 4 Rafael J. Wysocki 2007-05-30 11:11:10 UTC
Any status change?
Comment 5 Al Boldi 2007-05-30 15:05:30 UTC
bugme-daemon@bugzilla.kernel.org wrote:
> http://bugzilla.kernel.org/show_bug.cgi?id=7037
> ------- Additional Comments From rjwysocki@sisk.pl  2007-05-30 11:11
> ------- Any status change?

Don't know.

Last I checked 2.6.20, which regressed with isa-vga cards, and 2.6.21 was a 
big regression even on i810 boards.

I could probably test 2.6.22 once it gets released.

Do you have a specific patch against 2.6.21 you want me to test?


Thanks!

Comment 6 Rafael J. Wysocki 2007-05-31 09:49:25 UTC
No, I have no patches.

I'd like to make some progress here, but I have no access to any headless machines.
Comment 7 Al Boldi 2007-05-31 15:05:35 UTC
bugme-daemon@bugzilla.kernel.org wrote:
> http://bugzilla.kernel.org/show_bug.cgi?id=7037
> ------- Additional Comments From rjwysocki@sisk.pl  2007-05-31 09:49
> ------- No, I have no patches.
>
> I'd like to make some progress here, but I have no access to any headless
> machines.

Ok great!  I think the reason why it is important to make headless STR work 
is to reduce the number of fault points to a bare minimum.

So I have an i440bx board that can STR with a pci-vga card, and up to 2.6.19 
with an isa-vga card.  But it does not STR with a headless configuration, 
which probably points to a display adapter dependency that should not be 
there.

This may also explain why STR sometimes works and sometimes hangs on various 
headed configs, as the display adapter may possibly not initialize at the 
correct time STR expects it to.


Thanks!

--
Al

Comment 8 Rafael J. Wysocki 2007-06-01 09:33:09 UTC
Have you tried to use PM_TRACE to find where it hangs?
Comment 9 Al Boldi 2007-06-01 13:05:32 UTC
bugme-daemon@bugzilla.kernel.org wrote:
> http://bugzilla.kernel.org/show_bug.cgi?id=7037
> ------- Additional Comments From rjwysocki@sisk.pl  2007-06-01 09:33
> ------- Have you tried to use PM_TRACE to find where it hangs?

Yes, but it didn't show any problem.

It looks like it hangs really early on, before PM_TRACE comes into action.


Thanks!

--
Al

Comment 10 Pavel Machek 2007-08-16 02:29:53 UTC
Created attachment 12400 [details]
kill debugging junk that touches console from early wakeup

...please tell me if it helps.
Comment 11 Al Boldi 2007-08-16 21:56:20 UTC
bugme-daemon@bugzilla.kernel.org wrote:
> ------- Comment #10 from pavel@suse.cz  2007-08-16 02:29 -------
> Created an attachment (id=12400)
>  --> (http://bugzilla.kernel.org/attachment.cgi?id=12400&action=view)
> kill debugging junk that touches console from early wakeup
>
> ...please tell me if it helps.

Didn't help.

I also tried the BEEP on wakeup, but it doesn't beep without VGA card.

IIRC, the ACPIv3.0 spec said something about needing a wakeup vector to be 
set prior to suspending?


Thanks!

--
Al

Comment 12 Rafael J. Wysocki 2007-08-17 13:54:11 UTC
Can you please check if this patch:
http://www.sisk.pl/kernel/hibernation_and_suspend/2.6.23-rc3/patches/26-s2ram-kill-old-debugging-junk.patch
helps?
Comment 13 Anonymous Emailer 2007-08-17 15:11:35 UTC
Reply-To: pavel@ucw.cz


> > kill debugging junk that touches console from early wakeup
> >
> > ...please tell me if it helps.
> 
> Didn't help.
> 
> I also tried the BEEP on wakeup, but it doesn't beep without VGA card.

Ok, that's bad. It means it dies somewhere in the BIOS, AFAICT.

Comment 14 Rafael J. Wysocki 2007-08-20 10:25:36 UTC
(In reply to comment #13)

That also is my impression.

I don't think there's anything more we can do about it.
Comment 15 Al Boldi 2007-12-28 09:30:23 UTC
bugme-daemon@bugzilla.kernel.org wrote:
> http://bugzilla.kernel.org/show_bug.cgi?id=7037
> ------- Comment #11 from a1426z@gawab.com  2007-08-16 21:56 -------
> IIRC, the ACPIv3.0 spec said something about needing a wakeup vector to be
> set prior to suspending?

Rafael, I just saw your patch "[RFC][PATCH 0/7] Fix the ACPI 1.0 vs ACPI 2.0 
suspend ordering issue", and if you think this may make a difference in this 
case, then can you send me a combo-patch against .23?


Thanks!

--
Al

Comment 16 Rafael J. Wysocki 2007-12-28 12:26:33 UTC
On Friday, 28 of December 2007, bugme-daemon@bugzilla.kernel.org wrote:
> http://bugzilla.kernel.org/show_bug.cgi?id=7037
> 
> 
> 
> 
> 
> ------- Comment #15 from a1426z@gawab.com  2007-12-28 09:30 -------
> bugme-daemon@bugzilla.kernel.org wrote:
> > http://bugzilla.kernel.org/show_bug.cgi?id=7037
> > ------- Comment #11 from a1426z@gawab.com  2007-08-16 21:56 -------
> > IIRC, the ACPIv3.0 spec said something about needing a wakeup vector to be
> > set prior to suspending?
> 
> Rafael, I just saw your patch "[RFC][PATCH 0/7] Fix the ACPI 1.0 vs ACPI 2.0 
> suspend ordering issue", and if you think this may make a difference in this 
> case, then can you send me a combo-patch against .23?

It probably won't make any difference, but to verify that you can test
2.6.24-rc6 with the patches from
http://www.sisk.pl/kernel/hibernation_and_suspend/2.6.24-rc6/patches/
applied.

[The patchset is against 2.6.24-rc6 and it'd take quite a bit of work to
prepare the patch against vanilla 2.6.23.]


Note You need to log in before you can comment on or make changes to this bug.