Bug 7034 - hdb lost interupt - regression between 2.6.16.x and 2.6.17.y
hdb lost interupt - regression between 2.6.16.x and 2.6.17.y
Status: CLOSED INVALID
Product: ACPI
Classification: Unclassified
Component: Config-Interrupts
i386 Linux
: P2 blocking
Assigned To: Len Brown
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-21 05:12 UTC by Patrick Matthäi
Modified: 2007-06-19 17:20 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.17.11
Tree: Mainline
Regression: ---


Attachments
informations.txt (111.43 KB, application/octet-stream)
2006-08-30 23:02 UTC, Patrick Matthäi
Details

Description Patrick Matthäi 2006-08-21 05:12:09 UTC
Most recent kernel where this bug did not occur: 2.6.16.x
Distribution: Debian Sid
Hardware Environment: AMD Athlon XP 2600+, 2 x 512 MB DDR PC3200 Ram, MSI
K7N2-Delta mainboard ( with the actual 5.9 biosrevision ), Terratec 5.1 Aureon
Fun, harddisks: (see below)
Software Environment: Debian Sid packages only (sid kernel: linux-image-2.6.17-2-k7)

Harddisk infos:
me@the-me:~$ dmesg|grep hda
Kernel command line: root=/dev/hda1 ro nolapic
    ide0: BM-DMA at 0xf000-0xf007, BIOS settings: hda:DMA, hdb:DMA
hda: Maxtor 6E040L0, ATA DISK drive
hda: max request size: 128KiB
hda: 80293248 sectors (41110 MB) w/2048KiB Cache, CHS=65535/16/63, UDMA(133)
hda: cache flushes supported
 hda: hda1 hda2 < hda5 >
Adding 1662688k swap on /dev/hda5.  Priority:-1 extents:1 across:1662688k
EXT3 FS on hda1, internal journal
me@the-me:~$ dmesg|grep hdb
    ide0: BM-DMA at 0xf000-0xf007, BIOS settings: hda:DMA, hdb:DMA
hdb: Maxtor 6L250R0, ATA DISK drive
hdb: max request size: 512KiB
hdb: 490234752 sectors (251000 MB) w/16384KiB Cache, CHS=30515/255/63, UDMA(133)
hdb: cache flushes supported
 hdb: unknown partition table
EXT3 FS on hdb, internal journal

Problem Description:
Since 2.6.17, my second harddisk (hdb) losts his interupt very often at booting.
The DMA recovering for the interupt didn't work, too. I have to activate
'nolapic' to boot (but sometimes it's working without nolapic).
Comment 1 Len Brown 2006-08-21 14:58:24 UTC
not clear this is directly related to ACPI -- as there were precious few  
changes in ACPI between the working 2.6.16.stable and 2.6.17.stable.  
  
In any case, please attach the complete output from dmesg -s64000  
and paste the /proc/interrupts for the successful .16 success  
case and the failing .17 case.  Also attach the output from lspci  
from any case.  If it is an ACPI issue, then we'll also need the  
output from acpidump, available in the latest pmtools here:  
http://ftp.kernel.org/pub/linux/kernel/people/lenb/acpi/utils/  
  
Comment 2 Patrick Matthäi 2006-08-21 15:31:25 UTC
If I get this problem, the pc can't boot successful, I can only get in the
busybox, but I will try to give you as many informations as I can take.
Comment 3 Steve Fosdick 2006-08-23 16:25:34 UTC
I am experiencing something similar with my laptop with the VIA Rhine LAN
adapter.  On 2.6.16 this was completely reliable whereas on 2.6.17 sometimes the
hardware is configured for one interrupt while the driver is listening for a
different one.  The result is the LAN adapter does not work but the interrupt
the hardware is actually using is reported as having occurred spuriously.
Comment 4 Patrick Matthäi 2006-08-23 23:57:26 UTC
www.linux-development.org/problem.jpg
Today, I get this serveral times again, I can't give you any of the requested
informations, because he stops to boot there.
I hope you can see something on the picture, bad quality.
Comment 5 Patrick Matthäi 2006-08-28 05:56:25 UTC
It still exists in 2.6.17.11 with the newest udev build ( 0.098 ).

Here are my interrupts:
me@the-me:~$ cat /proc/interrupts
           CPU0
  0:    3265196    IO-APIC-edge  timer
  1:      32296    IO-APIC-edge  i8042
  8:          4    IO-APIC-edge  rtc
  9:          0   IO-APIC-level  acpi
 14:      48015    IO-APIC-edge  ide0
 15:        107    IO-APIC-edge  ide1
177:     465948   IO-APIC-level  ohci1394, CMI8738-MC6
185:          2   IO-APIC-level  ehci_hcd:usb1
193:          0   IO-APIC-level  ohci_hcd:usb2
201:     311843   IO-APIC-level  ohci_hcd:usb3
209:     267500   IO-APIC-level  eth0
217:     977727   IO-APIC-level  fglrx
NMI:          0
LOC:    3265165
ERR:          0
MIS:          0

One thing, it only happens, after the ehci HID driver ( or was it ohci? )
loaded, not at any other position.
Comment 6 Len Brown 2006-08-30 20:47:13 UTC
For the successful 2.6.16.stable case...
 please attach the complete output from dmesg -s64000  
 and paste the /proc/interrupts
 attach the output from lspci -vv
 attch the output from acpidump, available in the latest pmtools here:  
http://ftp.kernel.org/pub/linux/kernel/people/lenb/acpi/utils/  

also, if fglrx is the binary ATI driver, please reproduce
the problem without that driver loaded.
Comment 7 Patrick Matthäi 2006-08-30 23:01:38 UTC
Here are the informations.
Comment 8 Patrick Matthäi 2006-08-30 23:02:45 UTC
Created attachment 8915 [details]
informations.txt
Comment 9 Adrian Bunk 2006-10-24 19:48:44 UTC
Please reopen this bug if it is still present:
- in kernel 2.6.18 and
- without the fglrx ever loaded since booting.
Comment 10 Patrick Matthäi 2007-06-19 17:20:16 UTC
Ah sorry.

It was fixed for my old mainboard in 2.6.19.

Note You need to log in before you can comment on or make changes to this bug.