Bug 70301 - nvidia proprietor drivers doesn't compile : acpi_os_wait_events_complete symbol not found
nvidia proprietor drivers doesn't compile : acpi_os_wait_events_complete symb...
Status: CLOSED INVALID
Product: ACPI
Classification: Unclassified
Component: Other
x86-64 Linux
: P1 high
Assigned To: acpi_other
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-02-08 14:37 UTC by dams
Modified: 2014-06-16 16:56 UTC (History)
2 users (show)

See Also:
Kernel Version: 3.13.2
Tree: Mainline
Regression: No


Attachments
nvidia installer log (233.75 KB, text/x-log)
2014-02-08 14:37 UTC, dams
Details

Description dams 2014-02-08 14:37:35 UTC
Created attachment 125311 [details]
nvidia installer log

The nvidia proprietor driver, from nvidia, doesn't compile anymore, because it doesn't find the symbol acpi_os_wait_events_complete which is no more exported in linux kernel 3.13.2.

As explain in the following link : https://devtalk.nvidia.com/default/topic/644906/331-20-on-3-13-rc1-kernel/
this symbol seems to be previously exported in drivers/acpi/osl.c, but now it doesn't, so users needs to do some unsafe modifications to compile their nvidia property drivers (also, I've try the "nouveau" kernel driver, but it doesn't seems to works with GT640 cards, but it is an other problem).

As you can see in the log, there is also many, many, signed-unsigned warnings. It doesn't make proper, clean works, for an international operating system, all theses signed-unsigned warnings. Theses warnings can be a major problem on some critical projects... can you fix them too ? 

As it block the nvidia property driver compilation, these issue could become *a lot* recurrent. 

Regards,

Kernel : linux 3.13.2 (stable version)
Processor : amd athlon xp 3 
Graphic card : nvidia GT640
Nvidia driver : NVIDIA-Linux-x86_64-331.38.run
Bug resume : acpi_os_wait_events_complete symbol not exported, lots of signed/unsigned warnings
Comment 1 dams 2014-02-08 14:41:17 UTC
gcc version : 4.8
Comment 2 Alan 2014-02-08 17:59:06 UTC
Nvidia bugs should be filed with Nvidia.

Note You need to log in before you can comment on or make changes to this bug.