Bug 70201 - Touchpad status LED on HP Folio 13-2000 doesn't work
Summary: Touchpad status LED on HP Folio 13-2000 doesn't work
Status: NEW
Alias: None
Product: Drivers
Classification: Unclassified
Component: Platform_x86 (show other bugs)
Hardware: x86-64 Linux
: P1 low
Assignee: drivers_platform_x86@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-06 22:35 UTC by Stefan Nagy
Modified: 2014-03-09 19:34 UTC (History)
4 users (show)

See Also:
Kernel Version: 3.12.9
Tree: Mainline
Regression: No


Attachments
dmesg output (51.63 KB, text/plain)
2014-02-06 22:35 UTC, Stefan Nagy
Details
fwts wmi output "Extract and analyse Windows Management Instrumentation (WMI)" (3.50 KB, text/plain)
2014-02-15 13:06 UTC, Stefan Nagy
Details
full fwts log for HP Folio 13-2000 (311.87 KB, text/plain)
2014-02-15 13:12 UTC, Stefan Nagy
Details

Description Stefan Nagy 2014-02-06 22:35:03 UTC
Created attachment 124941 [details]
dmesg output

On the HP Folio 13-2000 Notebook the LED indicating the touchpad status (on/off) isn't part of the touchpad itself but is located between touchpad and keyboard and is part of the system board.

The expected behavior is ON when the touchpad is deactivated and OFF when the touchpad is active. Right now the LED is never on.

I'm glad to provide more information/logs but since I couldn't find any related reports I don't know what could be useful…
Comment 1 Alan 2014-02-07 11:33:53 UTC
Moving to input but I suspect the LED is magically managed by some Windows driver.
Comment 2 Dmitry Torokhov 2014-02-07 17:30:09 UTC
These kinds of LEDs normally require platform drivers I believe.
Comment 3 Matthew Garrett 2014-02-08 03:07:50 UTC
How are you deactivating the touchpad?
Comment 4 Stefan Nagy 2014-02-08 13:40:08 UTC
I tried to

1. deactivate the touchpad in gnome mouse settings,
2. deactivate the touchpad with xinput ('xinput set-prop 10 "Device Enabled" 0'),
1. deactivate the touchpad by removing the psmouse kernel module with 'modprobe -r psmouse'.

No matter which of those alternatives I chose, the touchpad will be deactived (as expected) but the status LED won't work (will stay off). After several months I have never seen the LED working on GNU/Linux operating systems, only on the preinstalled OS (Windows 7).
Comment 5 Matthew Garrett 2014-02-08 14:02:54 UTC
Yeah, none of those actually communicate with the hardware so there's no way that they'd do anything to an LED.
Comment 6 Stefan Nagy 2014-02-08 15:49:53 UTC
There is no hardware toggle button for the touchpad, instead there's a toggle area in the upper left corner. In Windows you would tap two times in this area to deactivate the touchpad. The missing support of this toggle area is another (xorg synaptics driver) bug.

What would you suggest to deactivate the touchpad?
Comment 7 Matthew Garrett 2014-02-08 16:01:24 UTC
If the LED is under platform driver control then there'll be an HP-specific method to control it. There's a decent chance that it'll be exposed via WMI. Alternatively, it's possible that the pad manufacturer has some method for controlling the LED.
Comment 8 Stefan Nagy 2014-02-15 13:06:14 UTC
Created attachment 126241 [details]
fwts wmi output "Extract and analyse Windows Management Instrumentation (WMI)"

Since I'm not that experienced the only thing I could think of was to make use of the Ubuntu Firmware Test Suite Live to extract and analyse Windows Management Instrumentation (WMI).
Comment 9 Stefan Nagy 2014-02-15 13:12:22 UTC
Created attachment 126251 [details]
full fwts log for HP Folio 13-2000

Since I get some ACPI warnings in my kernel log maybe it's a good idea to add the full Firmware Test Suite Live log.
Comment 10 Stefan Nagy 2014-02-15 13:20:56 UTC
As you can see in the fwts wmi log in fact there is an unknown WMI GUID:

Found WMI Event, Notifier ID: 0xa0, GUID: 2B814318-4BE8-4707-9D84-A190A859B5D0, Instance 0x01
FAILED [MEDIUM] WMIUnknownGUID: Test 1, GUID 2B814318-4BE8-4707-9D84-A190A859B5D0 is unknown to the kernel, a driver may need to be implemented for this GUID.

How can I tell if this has anything to do with this bug?
Comment 11 Stefan Nagy 2014-02-20 09:51:41 UTC
Matthew Garrett wrote: 
> Alternatively, it's possible that the pad manufacturer has some method for
> controlling the LED.

To investigate this possibility I patched the synaptics driver to add LED support, see [1] and [2] (the patch never made it upstream). Indeed I get promising kernel messages:

[   12.802242] psmouse serio1: synaptics: Touchpad model: 1, fw: 8.1, id: 0x1e2b1, caps: 0xd00123/0x840300/0x126c00, board id: 2031, fw id: 988796
[   12.802247] synaptics: led: checking for led
[   12.802248] synaptics: led: your product ID is 84
[   12.802250] synaptics: led: looks like you have one
[   12.802251] synaptics: support LED control

However, when I set '/sys/devices/virtual/leds/psmouse::synaptics/brightness' from 0 to 255 (=max_brightness) nothing happens…


[1] https://github.com/perusio/xorg-synaptics-led-support
[2] https://aur.archlinux.org/packages/synaptics-led/
Comment 12 Morse 2014-03-09 14:21:43 UTC
CC in here.

I have HP elitebook 8760w and my touchpad looks like this:

Touchpad model: 1, fw: 7.5, id: 0x1c0b1, caps: 0xd40033/0x640000/0xa0400, board id: 1651, fw id: 708038

I used to apply the aforementioned patches manually, and my touchpad worked with it: switching on and off on double-tap in the corner. Now I moved to fedora and became too lazy for it.

I don't know why this patches didn't work in case of HP Folio, but I sure hope that the code would be mainlined at some point, because it does work at least in some cases. Can it be persuaded?

https://lkml.org/lkml/2013/12/31/36
Comment 13 Stefan Nagy 2014-03-09 18:23:30 UTC
@ Morse: This report is not about the missing support for the toggle hot-area in the upper left corner of the touchpad (for this see xorg bug 39055 [1]). This report is only about the missing support for my touchpad's status LED.

I guess in your case the LED is located in the upper left corner (the toggle area) of the touchpad itself and that it probably is controlled by the touchpad driver. In my case the LED is not part of the touchpad and it seams to be unclear how it is controlled.

If you have a similar problem (missing touchpad status LED support) but on different hardware you should open another kernel bug. If you want support for the toggle area please have a look at [1]: the maintainer closed the bug two days ago and commented "we currently have no plans of fixing this".

[1] https://bugs.freedesktop.org/show_bug.cgi?id=39055
Comment 14 Morse 2014-03-09 19:34:59 UTC
Soryy if I wasn't clear: yes, I'm talking about the LED here, and yes, it's locataed in the toggle corner of the touchpad. I thought that the issue might be the same.

The support for on/off toggle is another issue, although I wonder if it should also be implemented inside the kernel. The oncoming wayland stack doesn't have place for yet another driver other then the kernel.

Note You need to log in before you can comment on or make changes to this bug.