Bug 7015 - S3 resume black console on T60p
S3 resume black console on T60p
Status: REJECTED DUPLICATE of bug 7225
Product: Drivers
Classification: Unclassified
Component: Video(Other)
i386 Linux
: P2 normal
Assigned To: Rafael J. Wysocki
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-16 12:46 UTC by Jerry Quinn
Modified: 2007-04-28 12:49 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.17.8
Tree: Mainline
Regression: ---


Attachments

Description Jerry Quinn 2006-08-16 12:46:00 UTC
Most recent kernel where this bug did not occur:
Distribution: Debian testing
Hardware Environment: IBM T60p
Software Environment: SATA set to Compatibility in BIOS (ata-piix)
Problem Description:

If I echo mem > /sys/power/state, the machine suspends fine.  If I suspend in a
console, there is no display.  If X was also running, switching to F7 brings up
X and I can then switch back to one of the virtual terminal consoles.

After doing this, consoles 1-4 are white, but can be cleared, and otherwise
operate normally again.

Steps to reproduce:
Suspend to mem while in a virtual terminal console, then resume.
Comment 1 Len Brown 2006-08-16 18:49:32 UTC
S3 video restore is not an ACPI feature, it is a BIOS and video
driver feature.

Verify that you've got the latest BIOS for the box,
and then check that you've got the latest ATI drivers
in Linux and in X.
Comment 2 Jerry Quinn 2006-08-17 06:57:49 UTC
I have the latest BIOS (1.09) and the latest ATI fglrx (8.27.10)

I don't think fglrx has anything to do with this, though.  I made sure I tested
without the ATI kernel driver to avoid taint issues and the console is still
black, except I can't recover since X isn't running.

I'm also a bit confused.  I thought with ACPI that suspend modes were handled by
the kernel, not the BIOS.
Comment 3 Rafael J. Wysocki 2006-09-29 09:55:31 UTC

*** This bug has been marked as a duplicate of 7225 ***

Note You need to log in before you can comment on or make changes to this bug.