Bug 69921 - [ 0.158586] [Firmware Bug]: ACPI: BIOS _OSI(Linux) query ignored
Summary: [ 0.158586] [Firmware Bug]: ACPI: BIOS _OSI(Linux) query ignored
Status: CLOSED INVALID
Alias: None
Product: ACPI
Classification: Unclassified
Component: BIOS (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: acpi_bios
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-04 00:31 UTC by Cristian Aravena Romero
Modified: 2014-02-07 01:36 UTC (History)
2 users (show)

See Also:
Kernel Version: 3.13
Tree: Mainline
Regression: No


Attachments

Description Cristian Aravena Romero 2014-02-04 00:31:36 UTC
dmesg:

[    0.155142] ACPI: Executed 1 blocks of module-level executable AML code
[    0.158586] [Firmware Bug]: ACPI: BIOS _OSI(Linux) query ignored

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1275985
Comment 1 Alan 2014-02-04 10:59:01 UTC
I am confused why you filed a bug for this

[Firmware Bug] - so this is Linux warning of apparent misbehaviour by the BIOS/firmware of the system not a Linux bug
Comment 2 Lan Tianyu 2014-02-07 01:36:00 UTC
Hi Cristian:
         Linux ACPI always tells Bios it's windows without "acpi_osi=linux" kernel parameter. The log is just a warning that Bios queried OS was Linux or not and Linux didn't acknowledge it as "Linux". So this is not a bug.

Note You need to log in before you can comment on or make changes to this bug.