Bug 6988 - intel agp doesn't detect e7221 chipset
Summary: intel agp doesn't detect e7221 chipset
Status: CLOSED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(AGP) (show other bugs)
Hardware: i386 Linux
: P2 normal
Assignee: Dave Airlie
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-08-11 07:38 UTC by John Lewis
Modified: 2008-03-26 23:25 UTC (History)
6 users (show)

See Also:
Kernel Version: 2.6.18-rc4
Tree: Mainline
Regression: ---


Attachments
Possible fix. (1.11 KB, patch)
2007-03-19 13:38 UTC, Dave Jones
Details | Diff
Patch to enable i915 recognition in 2.6.23 (1.35 KB, patch)
2007-11-16 08:04 UTC, David Greaves
Details | Diff

Description John Lewis 2006-08-11 07:38:03 UTC
Most recent kernel where this bug did not occur: NA
Distribution: Gentoo
Hardware Environment: Dell Poweredge SC420 BIOS ver A02
Software Environment: NA
Problem Description: intel-agp doesn't detect e7221 chipset.This means DRM
doesn't detect the integrated i915 graphics controller. agpgart, intel-agp, drm
and i915 all load without complaint though dmesg just shows:-

Linux agpgart interface v0.101 (c) Dave Jones
[drm] Initialized drm 1.0.1 20051102 

Steps to reproduce:

Get a machine with a e7221 chipset. Install latest main line kernel with
agpgart, intel-agp, drm and i915 support enabled.
Comment 1 Dave Jones 2006-08-11 10:45:14 UTC
attach lspci -n output please.
Comment 2 John Lewis 2006-08-13 10:27:11 UTC
There you go:-

00:00.0 0600: 8086:2588 (rev 04)
00:01.0 0604: 8086:2589 (rev 04)
00:02.0 0300: 8086:258a (rev 04)
00:1c.0 0604: 8086:2660 (rev 03)
00:1c.1 0604: 8086:2662 (rev 03)
00:1d.0 0c03: 8086:2658 (rev 03)
00:1d.1 0c03: 8086:2659 (rev 03)
00:1d.2 0c03: 8086:265a (rev 03)
00:1d.3 0c03: 8086:265b (rev 03)
00:1d.7 0c03: 8086:265c (rev 03)
00:1e.0 0604: 8086:244e (rev d3)
00:1f.0 0601: 8086:2640 (rev 03)
00:1f.1 0101: 8086:266f (rev 03)
00:1f.2 0101: 8086:2652 (rev 03)
00:1f.3 0c05: 8086:266a (rev 03)
02:00.0 0200: 14e4:1677 (rev 01)
04:00.0 0100: 9004:5078 (rev 03)
04:01.0 0280: 1133:e005 (rev 01)
04:02.0 0401: 1274:1371 (rev 09)
Comment 3 Andrew Morton 2007-01-30 23:50:43 UTC
Has this been fixed in 2.6.20-rc7 yet?
Comment 4 Dave Jones 2007-03-19 13:38:44 UTC
Created attachment 10846 [details]
Possible fix.

Please try this diff, and let me know if that works.
If possible, also include a run of testgart
(http://www.codemonkey.org.uk/projects/agp/testgart.c)
Comment 5 Natalie Protasevich 2007-06-15 14:58:03 UTC
John,
Did you get chance to test the fix in #4?
Thanks.
Comment 6 John Lewis 2007-06-16 04:53:28 UTC
No not yet, could you remind me how to apply the patch to the kernel and I will do it today?
Comment 7 John Lewis 2007-06-16 07:21:44 UTC
Ok I took a healthy dose of RTFM and dmesg now says:-

Linux agpgart interface v0.102 (c) Dave Jones
agpgart: Detected an Intel E7221 Chipset.
agpgart: AGP aperture is 256M @ 0x0
[drm] Initialized drm 1.1.0 20060810

Which is definitely a step in the right direction. I will try X and come back, but bear in mind this machine doesn't have X already, is remote from me and is Gentoo so it will take some time to compile and I will only be able to see if X starts.

Thanks.
Comment 8 Natalie Protasevich 2007-06-16 09:17:19 UTC
Thank you very much, for debugging and taking time to test this.
Will be waiting on your results running with X.
Regards -
--Natalie.
Comment 9 John Lewis 2007-06-16 13:43:20 UTC
Not a bother.

Here is the relevant output from Xorg.0.log, it doesn't seem to be recognising the gart memory that was enabled by the patch and therefore DRI is disabled:-

(II) I810(0): initializing int10
(WW) I810(0): Bad V_BIOS checksum
(II) I810(0): Primary V_BIOS segment is: 0xc000
(II) I810(0): VESA BIOS detected
(II) I810(0): VESA VBE Version 3.0
(II) I810(0): VESA VBE Total Mem: 7872 kB
(II) I810(0): VESA VBE OEM: Intel(r)CopperRiver Graphics Chip Accelerated VGA BIOS
(II) I810(0): VESA VBE OEM Software Rev: 1.0
(II) I810(0): VESA VBE OEM Vendor: Intel Corporation
(II) I810(0): VESA VBE OEM Product: Intel(r)CopperRiver Graphics Controller 
(II) I810(0): VESA VBE OEM Product Rev: Hardware Version 0.0
(II) I810(0): Allocated 128 kB for the ring buffer at 0x0
(II) I810(0): Allocating at least 512 scanlines for pixmap cache
(II) I810(0): Initial framebuffer allocation size: 4608 kByte
(WW) I810(0): xf86AllocateGARTMemory: allocation of 1 pages failed
        (Cannot allocate memory)
(EE) I810(0): Failed to allocate HW cursor space.
(WW) I810(0): xf86AllocateGARTMemory: allocation of 4 pages failed
        (Cannot allocate memory)
(EE) I810(0): Failed to allocate HW (ARGB) cursor space.
(WW) I810(0): xf86AllocateGARTMemory: allocation of 1 pages failed
        (Cannot allocate memory)
(EE) I810(0): Failed to allocate Overlay register space.
(II) I810(0): Allocated 64 kB for the scratch buffer at 0x5ff0000
(WW) I810(0): Disabling HW cursor because the cursor memory allocation failed.
(WW) I810(0): Disabling Xv because the overlay register buffer allocation failed.
Comment 10 David Greaves 2007-11-16 08:04:54 UTC
Created attachment 13579 [details]
Patch to enable i915 recognition in 2.6.23

adapted from patch above.

My test machine is a Dell SC420.

This still seems to have problems - in particular the aperture is reported starting at 0 and being 256M.
  agpgart: Detected an Intel E7221 Chipset.
  agpgart: AGP aperture is 256M @ 0x0

X now starts using the intel/i810 driver Debian v2:2.1.1-4 ) but there are problems using dri (and xv)

some excerpts:
(II) Primary Device is: PCI 00:02:0
(--) Chipset E7221 (i915) found
...
(II) intel(0): Kernel reported 617728 total, 0 used
(II) intel(0): I830CheckAvailableMemory: 2470912 kB available
(==) intel(0): VideoRam: 131072 KB
...

drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
...
(EE) [drm] drmOpen failed.
(EE) intel(0): [dri] DRIScreenInit failed. Disabling DRI.
Comment 11 Dave Airlie 2007-11-19 17:02:41 UTC
are you sure this chipset has integrated graphics?
Comment 12 David Greaves 2007-11-22 01:48:47 UTC
(In reply to comment #11)
> are you sure this chipset has integrated graphics?

No, I'm not 100% sure. It may be disabled in the BIOS etc. It does seem to be there though.

This is a Dell SC420. It's a cheap server. It has an onboard VGA connector and runs the xorg vesa driver fine. When this patch is applied the xorg intel driver will then run:

(II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
        i810-dc100, i810e, i815, i830M, 845G, 852GM/855GM, 865G, 915G,
        E7221 (i915), 915GM, 945G, 945GM, 945GME, 965G, 965G, 965Q, 946GZ,
        965GM, 965GME/GLE, G33, Q35, Q33
(II) Primary Device is: PCI 00:02:0
(--) Chipset E7221 (i915) found

If there are any other tests or anything else you need, please ask.
Comment 13 Ryoji Kamei 2008-01-17 21:55:59 UTC
Hi,

I'm also trying to invest video problem in E7221, because RHEL5.1 can't start X on SC420 or other hardwares with E7221. I confirmed that RHEL5.0 can run X without agpgart.

I found a blog that run DRI on SC420.
http://d.hatena.ne.jp/dayflower/20070619/1182231887
Script is Japanese, however we can read patches there. Hope it will help you...

Now I meet a problem that running video graphics on E7221 with agpgart become noisy like a picture at bottom of the blog or more. It will become clear when I add Option "NoAccel" "true" into xorg.conf, but it will become slow, of course.

If you have any comments, please describe it for me/us.
Comment 14 Brian Davis 2008-01-29 06:50:09 UTC
Has there been any recent developments on this bug? I see multiple patches, but they don't seem to fully fix the problem.
Comment 15 Natalie Protasevich 2008-03-26 23:17:25 UTC
Can someone summarize what is the current behavior of the chipset with latest kernel please.
Comment 16 Dave Airlie 2008-03-26 23:25:12 UTC
should all be upstream in kernel at this point...

Note You need to log in before you can comment on or make changes to this bug.