Bug 6978 - No fan after S3 - 2.6.18 regression - HP/Compaq nc6120
No fan after S3 - 2.6.18 regression - HP/Compaq nc6120
Status: REJECTED DUPLICATE of bug 7122
Product: ACPI
Classification: Unclassified
Component: Power-Fan
i386 Linux
: P2 high
Assigned To: Konstantin Karasyov
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-09 02:25 UTC by Bas Zoetekouw
Modified: 2006-10-20 10:02 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.18-rc2
Tree: Mainline
Regression: ---


Attachments
output of dmesg -s40000 (15.37 KB, text/plain)
2006-08-09 02:27 UTC, Bas Zoetekouw
Details
dmidecode output (6.69 KB, text/plain)
2006-08-09 02:28 UTC, Bas Zoetekouw
Details
lspci -vv (14.08 KB, text/plain)
2006-08-09 02:28 UTC, Bas Zoetekouw
Details
/proc/interrupts (781 bytes, text/plain)
2006-08-09 02:29 UTC, Bas Zoetekouw
Details
acpidump output (145.99 KB, text/plain)
2006-08-09 02:29 UTC, Bas Zoetekouw
Details

Description Bas Zoetekouw 2006-08-09 02:25:33 UTC
Most recent kernel where this bug did not occur: 2.6.17.1
Distribution: Ubuntu Edgy
Hardware Environment: HP/Compaq nc6120
Software Environment: X/gnome
Problem Description:

In recent kernels, the fans don't work after a suspend/resume cycle, causing my
laptop to shutdown when the cpu gets too hot.

Steps to reproduce:

suspend-to-ram, resume, do anything cpu-intensive.
Comment 1 Bas Zoetekouw 2006-08-09 02:27:26 UTC
Created attachment 8733 [details]
output of dmesg -s40000
Comment 2 Bas Zoetekouw 2006-08-09 02:28:02 UTC
Created attachment 8734 [details]
dmidecode output
Comment 3 Bas Zoetekouw 2006-08-09 02:28:36 UTC
Created attachment 8735 [details]
lspci -vv
Comment 4 Bas Zoetekouw 2006-08-09 02:29:17 UTC
Created attachment 8736 [details]
/proc/interrupts
Comment 5 Bas Zoetekouw 2006-08-09 02:29:49 UTC
Created attachment 8737 [details]
acpidump output
Comment 6 Konstantin Karasyov 2006-09-13 06:22:22 UTC
Please, try the fix patch from Bug #7122 
Comment 7 Bas Zoetekouw 2006-09-13 08:44:47 UTC
I've tried the patch
http://bugzilla.kernel.org/attachment.cgi?id=9011&action=view of bug #7122 with
2.6.18-rc7 and suspend2 2.2.7.5, and it seems fix this problem indeed.  After
hibernate/resume and suspend/resume, the fan keeps functioning correctly.
Comment 8 Konstantin Karasyov 2006-10-16 06:03:28 UTC
Bas,
Could you also try patches from comments ## 37, 38 
http://bugzilla.kernel.org/show_bug.cgi?id=7122
These patches are against 2.6.18-rc6.
Comment 9 Konstantin Karasyov 2006-10-20 10:02:37 UTC

*** This bug has been marked as a duplicate of 7122 ***

Note You need to log in before you can comment on or make changes to this bug.