Bug 6973 - S3: no wakeup - Hasee Laptop A180S, KM400chipset,AMD1800+ mobile
S3: no wakeup - Hasee Laptop A180S, KM400chipset,AMD1800+ mobile
Status: CLOSED UNREPRODUCIBLE
Product: ACPI
Classification: Unclassified
Component: Power-Sleep-Wake
i386 Linux
: P2 high
Assigned To: Rafael J. Wysocki
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2006-08-08 05:47 UTC by Zhangfan
Modified: 2008-01-07 09:01 UTC (History)
4 users (show)

See Also:
Kernel Version: kernel-2.6.17.8
Tree: Mainline
Regression: ---


Attachments

Description Zhangfan 2006-08-08 05:47:43 UTC
Distribution: Magic Linux 2.0

Hardware Environment: 
  Hasee Laptop A180S
  KM400chipset,AMD1800+ mobile,
  S3 IGP VIDEO DRIVER ON BOARD

Software Environment: kernel-2.6.17.8

Problem Description: 
where I user suspend to ram function,My Laptop can't wake up correctly.
when I push any key or pw btn, it will restart,or waked with LCD Panel closed

Log of SUSPEND TO RAM:
========we are going to sleep, preparing.========
== checking runlevel ==
  no shutdown/reboot in progress, good.
Stopping services: ('slmodemd irda upsd apcupsd' configured)
stopping irda:
##  Shutting down IrDA: [FAILED]^M

------------------------------------------------------------------------------
Unloading modules: ('usb_storage sbp2 ohci_hcd uhci_hcd stir4200 ohci1394 
ipw2200 rt2500 prism54 ath_pci r8169 lt_modem Intel536 Intel537 ndiswrapper' 
configured)
checking usb_storage
checking sbp2
checking ohci_hcd
checking uhci_hcd
checking stir4200
checking ohci1394
checking ipw2200
checking rt2500
checking prism54
checking ath_pci
checking r8169
checking lt_modem
checking Intel536
checking Intel537
checking ndiswrapper
# trying to unload: ndiswrapper
unloaded: ndiswrapper
------------------------------------------------------------------------------
prepare_sleep finished for suspend2ram
------------------------------------------------------------------------------
/usr/sbin/s2ram not found, falling back to echo.

Steps to reproduce:
#pm-suspend
(waked,publish any key it restart)
Comment 1 Len Brown 2006-08-09 22:52:49 UTC
Did this work properly with any previous kernels
and this is a regression, or as far as you know it never worked?

Is there an indication that the system suspended?
Ie. is there an a suspend LED that is blinking or illuminated
when it normally isn't after a regular shutdown?

> /usr/sbin/s2ram not found, falling back to echo.
I don't know what this is about, but would be interested to know
if you simply use this, what happens:

# echo mem >/sys/power/state
Comment 2 Zhangfan 2006-08-10 06:10:26 UTC
It doesnt work under any old kernel。
when using kernel-2.6.15.3 or kernel-2.6-15.6 which realsed by Magic Linux.
Suspend 2 mem donest work,the LCD Panel was blank,but Suspend led on my Laptop
illuminated,never blinking.....
It never worked

when using kernel-2.6.17.8 realeased by kernel.org,
Supsend 2 mem done,but screen is still black when wakeup!

when normally shutdown,the suspend led will off
when normally suspend to memeory suspend led wll blinking

> /usr/sbin/s2ram not found, falling back to echo.
This is a command ,bin, with suspend-script package realeased by SUSE

# echo mem >/sys/power/state
I simply use this,suspend to memory is done,suspend led is blinking
but when I push any key to wake it up,my computer restart 

Comment 3 Zhangfan 2006-09-19 18:39:32 UTC
Oh,when after suspend to ram ,
I push power button of my laptop,
It still restarted,no wakeup!
not only power button,when user windows xp,I can press any key to wakeup from
acpi s3,
waiting for solution
Thx ^_^
Comment 4 Len Brown 2007-09-06 15:18:35 UTC
Is this still a problem in linux-2.6.22.stable or later?
Comment 5 Zhangfan 2007-09-12 19:04:56 UTC
This is still a problem in linux-2.6.22 or later
Comment 6 Rafael J. Wysocki 2007-09-19 16:46:09 UTC
Can you please try s2ram (http://en.opensuse.org/s2ram)?
Comment 7 Natalie Protasevich 2007-10-22 23:34:54 UTC
Zhang Fan, did you get chance to test with latest kernel (2.6.23+)? and how about #6?
Thanks.
Comment 8 Rafael J. Wysocki 2007-12-12 16:58:19 UTC
Zhangfan, please test the current mainline kernel and report back, thanks.

[I'm going to close this bug if there's no response in two weeks from now.]

Note You need to log in before you can comment on or make changes to this bug.