Bug 69421 - AMD-Vi: Event logged IO_PAGE_FAULT
Summary: AMD-Vi: Event logged IO_PAGE_FAULT
Status: RESOLVED DOCUMENTED
Alias: None
Product: Platform Specific/Hardware
Classification: Unclassified
Component: x86-64 (show other bugs)
Hardware: x86-64 Linux
: P1 high
Assignee: platform_x86_64@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-25 12:34 UTC by Adrian Ban
Modified: 2014-01-26 10:52 UTC (History)
0 users

See Also:
Kernel Version: 3.12.6-2
Tree: Mainline
Regression: No


Attachments
Hardware description (33.58 KB, text/plain)
2014-01-25 12:34 UTC, Adrian Ban
Details

Description Adrian Ban 2014-01-25 12:34:24 UTC
Created attachment 123311 [details]
Hardware description

With kernel 3.2.46 this message appears 8 times and after that the system is booting up without problems.

But after this version of kernel, starting from 3.3 up to 3.12 this error is looping and the system is hanging up and it doesn't starts.

Here is error:

Jan 25 13:23:27 VM-Hosting kernel: [    5.417560] AMD-Vi: Event logged [IO_PAGE_FAULT device=00:14.4 domain=0x000f address=0x0000000000000000 flags=0x0000]
Jan 25 13:23:27 VM-Hosting kernel: [    5.417570] AMD-Vi: Event logged [IO_PAGE_FAULT device=00:14.4 domain=0x000f address=0x0000000000000040 flags=0x0000]
Jan 25 13:23:27 VM-Hosting kernel: [    5.417577] AMD-Vi: Event logged [IO_PAGE_FAULT device=00:14.4 domain=0x000f address=0x0000000000000080 flags=0x0000]
Jan 25 13:23:27 VM-Hosting kernel: [    5.417583] AMD-Vi: Event logged [IO_PAGE_FAULT device=00:14.4 domain=0x000f address=0x00000000000000c0 flags=0x0000]
Jan 25 13:23:27 VM-Hosting kernel: [    5.417589] AMD-Vi: Event logged [IO_PAGE_FAULT device=00:14.4 domain=0x000f address=0x0000000000000100 flags=0x0000]
Jan 25 13:23:27 VM-Hosting kernel: [    5.417595] AMD-Vi: Event logged [IO_PAGE_FAULT device=00:14.4 domain=0x000f address=0x0000000000000140 flags=0x0000]
Jan 25 13:23:27 VM-Hosting kernel: [    5.417601] AMD-Vi: Event logged [IO_PAGE_FAULT device=00:14.4 domain=0x000f address=0x0000000000000180 flags=0x0000]
Jan 25 13:23:27 VM-Hosting kernel: [    5.417608] AMD-Vi: Event logged [IO_PAGE_FAULT device=00:14.4 domain=0x000f address=0x00000000000001c0 flags=0x0000]

I will restart the system with amd_iommu_dump, but I couldn't find the option in BIOS to disable the IOMMU.

I will try also to upgrade the BIOS, but until then I don't have access to the server.
Comment 1 Adrian Ban 2014-01-26 10:52:38 UTC
Hi,

I success to upgrade the BIOS remote with flashrom. After upgrading BIOS from 1208 to 1708 the problem was fixed.

So for others who has same problems with IOMMU try to upgrade the BIOS that may fix this problem.

Best regards.

Note You need to log in before you can comment on or make changes to this bug.