Bug 6879 - no power-off if PCIe Radeon x1300 installed in Intel Desktop Board D945GCZ
Summary: no power-off if PCIe Radeon x1300 installed in Intel Desktop Board D945GCZ
Status: CLOSED DOCUMENTED
Alias: None
Product: ACPI
Classification: Unclassified
Component: BIOS (show other bugs)
Hardware: i386 Linux
: P2 normal
Assignee: acpi_power-off
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-07-20 13:48 UTC by Frans Pop
Modified: 2007-09-05 18:33 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.17.6
Tree: Mainline
Regression: ---


Attachments
Kernel configuration (16.10 KB, application/x-gzip)
2006-07-20 13:52 UTC, Frans Pop
Details
Horrorstory describing attempts to boot 2.6.18 with initramfs initrd (1.62 KB, text/plain)
2006-08-03 14:56 UTC, Frans Pop
Details

Description Frans Pop 2006-07-20 13:48:50 UTC
Most recent kernel where this bug did not occur: 
  Unknown (new machine); issue also seen with 2.6.16 though 
Distribution: 
  Debian (unstable) 
Hardware Environment:     
  Intel Desktop Board D945GCZ with EM64T 3.2Ghz (Pentium D) processor   
  BIOS updated to most recent version (3943)   
Software Environment:     
 gcc: 4.1  
  
Problem Description:     
 When I shut down the system, it does not power off, but stays turned on but 
unresponsive after the messages:    
Will now halt.   
Synchronizing SCSI cache for disk sda:   
ACPI: PCI interrupt for device 0000:01:00.0 disabled   
Power down.    
acpi_power_off called    
    
After enabling acpi debugging in the kernel, I see one additional message   
after those listed above:    
hwsleep-0283 [02] enter_sleep_state    : Entering sleep state [S5]    
    
Steps to reproduce:     
 Shut down the system, does not matter how or from what type of session    
(single user, console, X).
Comment 1 Frans Pop 2006-07-20 13:52:51 UTC
Created attachment 8593 [details]
Kernel configuration

Kernel configuration; same issue happens with a non-smp kernel
Comment 2 Frans Pop 2006-07-22 01:27:25 UTC
I have now also installed a Beta of Windows Vista and the box has the same 
issue with that, so it may be a BIOS issue. Will contact Intel about it. 
Comment 3 Luming Yu 2006-08-01 08:56:53 UTC
Vista is still in Beta, Please also try Windows XP which is in production.
Please also try linux with acpi=off with latest base kernel say 2.6.18-rc3
Comment 4 Frans Pop 2006-08-03 14:53:26 UTC
OK. This looks like it is going to get complex...          
  
WINDOWS 2000          
============          
I'm afraid I don't have a Windows XP installation CD available (maybe I can          
get the "rescue CD" for my laptop to work, but I'm reluctant to try).          
However, I have tried Windows 2000. After updating the .inf files and          
installing the correct video and net drivers, shutting down the system shows          
the same problem: it does not power off.          
          
Update/drivers I installed:          
INF_ALLOS_7.2.2.1007_PV.exe          
GFX_XP_MCE_2K_14.19.50.4497_PV.ZIP          
LAN_11.0_ALLOS_PV.EXE          
          
      
LINUX upstream 2.6.17-7 (Current Debian package: 2.6.17-5)    
================================================    
- em64t-smp variant      
- Boots fine with ACPI enabled      
- Does not power off on shutdown     
  last messsages: Power down. \ acpi_power_off called    
- Boots fine with acpi=off      
- Does not power off on shutdown    
  last message: System halted.    
    
LINUX upstream 2.6.18-rc3 (self compiled)  
=========================================  
- compiled using 'make oldconfig' from 2.6.17 Debian config with most defaults    
accepted; built with 'make; make install; make modules_install'    
- initrd created with 'update-initramfs -c -k 2.6.18-rc3'    
- all kinds of horrible errors during boot both with and without acpi;   
  for one thing, the USB-keyboard does not work    
   
After a lot of problems with the initramfs initrd, I decided to give up and   
compile the main driver modules I need into the kernel. After that the system  
booted normally.   
I will create an attachment with the initrd boot experiences, but they are  
really a separate issue and may well be udev or initramfs-tools related more  
than kernel issues.   
   
There is absolutely no difference in poweroff behavior between 2.6.17 Debian  
kernel and the 2.6.18-rc3 kernel. Same behavior, same messages. 
  
Comment 5 Frans Pop 2006-08-03 14:56:48 UTC
Created attachment 8695 [details]
Horrorstory describing attempts to boot 2.6.18 with initramfs initrd
Comment 6 Frans Pop 2007-08-09 00:59:25 UTC
Some new information on my power off problem that could help to pin it down.

With 2.6.23-RC2 I now see the following message on shutdown:
Will now halt.
ACPI handler has no context!
Power down.

Could the ACPI handler message explain why the box does not power off? Or does that happen later (after "Power down")?

Or is it more likely to be related to something else I noticed very recently.
smartctl reports that the "Power-Off_Retract_Count" is quite a bit higher than the "Power_Cycle_Count", while I understand from Googling that really it should not be increasing at all if disks are parked cleanly during shutdown.
 12 Power_Cycle_Count       0x0032   100   100   000    Old_age  Always       -       337
192 Power-Off_Retract_Count 0x0032   100   100   050    Old_age  Always       -       465
Comment 7 Frans Pop 2007-08-14 23:14:31 UTC
I've finally managed to get this system to shut down by pulling the PCIe Radeon x1300 video card from the system...
This also got rid of the "ACPI handler has no context!" message.

I have no idea if this is a hardware or BIOS issue, but as there's no real Linux driver for that card anyway and the internal Intel video controller works fine for me, I'll probably just leave it at this.
Comment 8 Frans Pop 2007-08-14 23:15:59 UTC
> I've finally managed to get this system to shut down by pulling the
> PCIe Radeon x1300 video card from the system...

s/shut down/power off by itself/
Comment 9 Len Brown 2007-09-05 18:33:21 UTC
Good hunting.

Knowing that Windows fails the same way certainly suggests
a firmware issue rather than a Linux issue.

My only advice is to load the latest motherboard BIOS,
and load the latest video-card firmware -- if such a concept exists.

Note You need to log in before you can comment on or make changes to this bug.