Bug 68751 - Aspire V5-431: backlight acpi_video0 not working
Summary: Aspire V5-431: backlight acpi_video0 not working
Status: CLOSED DUPLICATE of bug 51231
Alias: None
Product: ACPI
Classification: Unclassified
Component: Power-Video (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: acpi_power-video
URL: http://www.spinics.net/lists/linux-ac...
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-15 16:15 UTC by Thomas Christensen
Modified: 2014-09-22 14:14 UTC (History)
4 users (show)

See Also:
Kernel Version: 3.13-rc8
Tree: Mainline
Regression: No


Attachments
acpidump (254.12 KB, text/plain)
2014-01-15 16:15 UTC, Thomas Christensen
Details
dmidecode (9.35 KB, text/plain)
2014-01-17 08:37 UTC, Thomas Christensen
Details

Description Thomas Christensen 2014-01-15 16:15:21 UTC
Created attachment 122191 [details]
acpidump

My laptop (Aspire V5-431) gets an acpi_video0 entry in /sys/class/backlight/
that is not working, alongside an intel_backlight entry that *is* working.

I see the following entry in the kernel log:

[   19.515016] acer_wmi: Brightness must be controlled by acpi video driver

By using 'acpi_backlight=vendor' acpi_video0 disappears.
Comment 1 Thomas Christensen 2014-01-16 06:01:23 UTC
See the bug report on the linux-acpi mailing list:

http://www.spinics.net/lists/linux-acpi/msg48469.html
Comment 2 Aaron Lu 2014-01-17 05:43:04 UTC
The backlight control provided by ACPI is through EC, while for this laptop model it's obvious the backlight control circuit is not routed to EC, so the ACPI interface is not usable.

Please attach your DMI info:
# dmidecode > dmi.txt
Comment 3 Thomas Christensen 2014-01-17 08:37:56 UTC
Created attachment 122381 [details]
dmidecode

As per requested
Comment 4 Aaron Lu 2014-01-27 07:36:40 UTC
Does add video.use_native_backlight=1 to kernel cmdline help? Please test this kernel cmdline on a v3.13 kernel.
Comment 5 Thomas Christensen 2014-01-27 10:59:35 UTC
Yes :-)

$ dmesg | grep  backlight
[    0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz-3.13.0-031300-generic root=UUID=4cfdb2ed-677a-4fd0-aa7d-5b118700bd35 ro quiet splash video.use_native_backlight=1 vt.handoff=7
[    0.000000] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.13.0-031300-generic root=UUID=4cfdb2ed-677a-4fd0-aa7d-5b118700bd35 ro quiet splash video.use_native_backlight=1 vt.handoff=7

$ uname -a
Linux thomasc-Aspire-V5-431 3.13.0-031300-generic #201401192235 SMP Mon Jan 20 03:36:48 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
Comment 6 Aaron Lu 2014-01-28 00:39:45 UTC
OK, so this is another Win8 firmware compatible problem.

*** This bug has been marked as a duplicate of bug 51231 ***

Note You need to log in before you can comment on or make changes to this bug.