Bug 6833 - Syslog flooded with "hci_scodata_packet: hci0 SCO packet for unknown connection handle 0" messages
Syslog flooded with "hci_scodata_packet: hci0 SCO packet for unknown connecti...
Status: RESOLVED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: USB
i386 Linux
: P2 high
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks: USB
  Show dependency treegraph
 
Reported: 2006-07-14 07:46 UTC by Uwe Menges
Modified: 2009-06-13 15:33 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.15-26-686
Tree: Mainline
Regression: ---


Attachments

Description Uwe Menges 2006-07-14 07:46:14 UTC
Most recent kernel where this bug did not occur: unknown
Distribution: Kubuntu 6.06 (Dapper), SUSE 10.0 (liveCD), SUSE 10.1 (liveCD)
Hardware Environment: Notebook nx7000, Thinkpad R40
Software Environment: Standard installation

Problem Description:

As soon as a Vivanco bluetooth usb dongle is plugged in, the syslog is flooded
with "hci_scodata_packet: hci0 SCO packet for unknown connection handle 0"
messages. The flood rate is ~5000 entries/second.

This Bug was originally filed in
https://launchpad.net/distros/ubuntu/+source/linux-source-2.6.15/+bug/39414
but as it also occurs with the SUSE liveCDs, I think this is an upstream bug.
Comment 1 Andrew Morton 2006-07-18 09:41:00 UTC
On Tue, 18 Jul 2006 18:32:25 +0200
Marcel Holtmann <marcel@holtmann.org> wrote:

> Hi Andrew,
> 
> > Date: Fri, 14 Jul 2006 07:49:19 -0700
> > From: bugme-daemon@bugzilla.kernel.org
> > To: bugme-new@lists.osdl.org
> > Subject: [Bugme-new] [Bug 6833] New: Syslog flooded with "hci_scodata_packet: hci0 SCO packet for unknown connection handle 0" messages
> > 
> > 
> > http://bugzilla.kernel.org/show_bug.cgi?id=6833
> > 
> >            Summary: Syslog flooded with "hci_scodata_packet: hci0 SCO packet
> >                     for unknown connection handle 0" messages
> >     Kernel Version: 2.6.15-26-686
> >             Status: NEW
> >           Severity: high
> >              Owner: greg@kroah.com
> >          Submitter: uwe.menges@web.de
> > 
> > 
> > Most recent kernel where this bug did not occur: unknown
> > Distribution: Kubuntu 6.06 (Dapper), SUSE 10.0 (liveCD), SUSE 10.1 (liveCD)
> > Hardware Environment: Notebook nx7000, Thinkpad R40
> > Software Environment: Standard installation
> > 
> > Problem Description:
> > 
> > As soon as a Vivanco bluetooth usb dongle is plugged in, the syslog is flooded
> > with "hci_scodata_packet: hci0 SCO packet for unknown connection handle 0"
> > messages. The flood rate is ~5000 entries/second.
> > 
> > This Bug was originally filed in
> > https://launchpad.net/distros/ubuntu/+source/linux-source-2.6.15/+bug/39414
> > but as it also occurs with the SUSE liveCDs, I think this is an upstream bug.
> 
> this is broken hardware from RTX Telecom. I have a fix for it. You need
> to activate the quirk to disable the ISOC transfers.
> 

Let's cc Uwe and bugzilla then.

Is there any patch which Uwe can test?

I assume "the quirk" refers to a quirk which is implemented in that patch?

Comment 2 Marcel Holtmann 2006-07-18 09:58:25 UTC
Hi Andrew,

> > > Date: Fri, 14 Jul 2006 07:49:19 -0700
> > > From: bugme-daemon@bugzilla.kernel.org
> > > To: bugme-new@lists.osdl.org
> > > Subject: [Bugme-new] [Bug 6833] New: Syslog flooded with "hci_scodata_packet: hci0 SCO packet for unknown connection handle 0" messages
> > > 
> > > 
> > > http://bugzilla.kernel.org/show_bug.cgi?id=6833
> > > 
> > >            Summary: Syslog flooded with "hci_scodata_packet: hci0 SCO packet
> > >                     for unknown connection handle 0" messages
> > >     Kernel Version: 2.6.15-26-686
> > >             Status: NEW
> > >           Severity: high
> > >              Owner: greg@kroah.com
> > >          Submitter: uwe.menges@web.de
> > > 
> > > 
> > > Most recent kernel where this bug did not occur: unknown
> > > Distribution: Kubuntu 6.06 (Dapper), SUSE 10.0 (liveCD), SUSE 10.1 (liveCD)
> > > Hardware Environment: Notebook nx7000, Thinkpad R40
> > > Software Environment: Standard installation
> > > 
> > > Problem Description:
> > > 
> > > As soon as a Vivanco bluetooth usb dongle is plugged in, the syslog is flooded
> > > with "hci_scodata_packet: hci0 SCO packet for unknown connection handle 0"
> > > messages. The flood rate is ~5000 entries/second.
> > > 
> > > This Bug was originally filed in
> > > https://launchpad.net/distros/ubuntu/+source/linux-source-2.6.15/+bug/39414
> > > but as it also occurs with the SUSE liveCDs, I think this is an upstream bug.
> > 
> > this is broken hardware from RTX Telecom. I have a fix for it. You need
> > to activate the quirk to disable the ISOC transfers.
> > 
> 
> Let's cc Uwe and bugzilla then.
> 
> Is there any patch which Uwe can test?
> 
> I assume "the quirk" refers to a quirk which is implemented in that patch?

the patch looks like this:

diff --git a/drivers/bluetooth/hci_usb.c b/drivers/bluetooth/hci_usb.c
index d73eb10..963c014 100644
--- a/drivers/bluetooth/hci_usb.c
+++ b/drivers/bluetooth/hci_usb.c
@@ -124,8 +124,9 @@ static struct usb_device_id blacklist_id
        /* ISSC Bluetooth Adapter v3.1 */
        { USB_DEVICE(0x1131, 0x1001), .driver_info = HCI_RESET },
 
-       /* RTX Telecom based adapter with buggy SCO support */
+       /* RTX Telecom based adapters with buggy SCO support */
        { USB_DEVICE(0x0400, 0x0807), .driver_info = HCI_BROKEN_ISOC },
+       { USB_DEVICE(0x0400, 0x080a), .driver_info = HCI_BROKEN_ISOC },
 
        /* Belkin F8T012 and F8T013 devices */
        { USB_DEVICE(0x050d, 0x0012), .driver_info = HCI_WRONG_SCO_MTU },

The hardware from RTX Telecom is simply buggy. Even the new dongle has
this problem.

Regards

Marcel


Comment 3 Greg Kroah-Hartman 2006-08-30 01:06:59 UTC
Great, am now closing, thanks.
Comment 4 Pavel Chromy 2009-02-10 00:59:43 UTC
I observed the same issue with device 0a12:0001 (Cambridge Silicon Radio, Ltd Bluetooth Dongle). It is interesting, that this does not happen when the device is plugged into an external USB 2.0 hub (Kensington PocketHub 7 Port), but it does appear if the dongle is plugged directly to a USB contoller, either onboard
(nforce4 4x) or PCI addon card (NEC chipset). Kernel version is 2.6.24-23 (Kubuntu)
Comment 5 Michał Z. Gołębiowski 2009-06-13 15:33:50 UTC
@Pavel Chromy
I can confirm it. I've observed the same behaviour with my Bluetooth USB dongle; this is the same model (and the same device address, 0a12:0001).

Should this bug be closed? Is it another issue?

Note You need to log in before you can comment on or make changes to this bug.