Bug 6822 - p4-clockmod on Intel Celeron is now having only 2 states
Summary: p4-clockmod on Intel Celeron is now having only 2 states
Status: CLOSED PATCH_ALREADY_AVAILABLE
Alias: None
Product: Power Management
Classification: Unclassified
Component: cpufreq (show other bugs)
Hardware: i386 Linux
: P2 high
Assignee: Dave Jones
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-07-12 00:07 UTC by Cijoml Cijomlovic Cijomlov
Modified: 2007-02-01 02:44 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.16,2.6.17,2.6.18
Tree: Mainline
Regression: ---


Attachments
Output of acpidump (20.57 KB, application/gzip)
2007-01-19 07:47 UTC, Giuseppe D'Angelo
Details

Description Cijoml Cijomlovic Cijomlov 2006-07-12 00:07:30 UTC
Most recent kernel where this bug did not occur: 2.6.18-rc1
Distribution: Debian testing
Hardware Environment: Acer TravelMate 242
Software Environment:
Problem Description:

Steps to reproduce: boot kernel, cat
/sys/devices/system/cpu/cpu0/cpufreq/scaling_available_frequencies
Comment 1 Cijoml Cijomlovic Cijomlov 2006-07-12 00:10:23 UTC
notas:/home/cijoml# cat
/sys/devices/system/cpu/cpu0/cpufreq/scaling_available_frequencies
2100000 2400000

Before we had minimum 300000 and I think 6 states
Comment 2 Alexey Starikovskiy 2006-07-17 02:00:24 UTC
Please attach output of acpidump utility and give reason why you want to use
p4-clockmod...
Comment 3 Cijoml Cijomlovic Cijomlov 2006-07-17 02:36:14 UTC
Hi,

I need this, because only this modulation is available on my laptop. No
throttling, nothink more :(

notas:/home/cijoml# cat /proc/acpi/processor/CPU0/throttling
<not supported>
Comment 4 Len Brown 2006-07-25 19:28:07 UTC
I think the fix is to delete p4-clockmod.c from the kernel source tree,
since all it does is slow the machine down without saving any energy.
(power [Watt-Hour] = energy/time [Watt])
Comment 5 Cijoml Cijomlovic Cijomlov 2006-07-25 23:03:16 UTC
It is not true, coz when running low speed, emitted heat is lower. In fact it
prolongs battery live for about 30/45 mins, which is good!
Comment 6 Dave Jones 2006-07-28 20:01:08 UTC
The lower frequencies were removed in later kernels as part of an errata
workaround.  It's possible that using them on affected CPUs can cause lockups.
Comment 7 Cijoml Cijomlovic Cijomlov 2006-07-30 23:49:15 UTC
Hi,

I have in company more than 20 laptops with this CPU from different vendors and
no one ever locked for 2 years. If you want workaround somethink, which never
occur, can you also provide force option to tell the kernel use all of these states?

Thank you a lot
Comment 8 Giuseppe D'Angelo 2007-01-19 07:47:11 UTC
Created attachment 10123 [details]
Output of acpidump
Comment 9 Giuseppe D'Angelo 2007-01-19 07:49:19 UTC
I submitted this bug report to Debian BTS:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=360773

I think that it is very similar to this one.

Since 2.6.16 I'm unable to have my laptop cpu scaling working. Under a kernel <=
2.6.15 I have:

alien:/sys/devices/system/cpu/cpu0/cpufreq# cat scaling_available_frequencies
333325 666650 999975 1333300 1666625 1999950 2333275 2666600

Under a kernel >= 2.6.16 I get instead

alien:/sys/devices/system/cpu/cpu0/cpufreq# cat scaling_available_frequencies
2333275 2666600

It was told to me to try with the latest 2.6.19 and 2.6.20-rc kernels. I tried
both of them but got the same results. 

My /proc/cpuinfo:
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Intel(R) Pentium(R) 4 CPU 2.66GHz
stepping        : 9
cpu MHz         : 332.072
cache size      : 512 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe cid xtpr
bogomips        : 5314.32

Lspci:
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 651 Host (rev 02)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] Virtual PCI-to-PCI bridge (AGP)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS962 [MuTIOL Media IO]
(rev 14)
00:02.1 SMBus: Silicon Integrated Systems [SiS] SiS961/2 SMBus Controller
00:02.3 FireWire (IEEE 1394): Silicon Integrated Systems [SiS] FireWire Controller
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE]
00:02.6 Modem: Silicon Integrated Systems [SiS] AC'97 Modem Controller (rev a0)
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] AC'97
Sound Controller (rev a0)
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.2 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 PCI Fast
Ethernet (rev 91)
00:0a.0 CardBus bridge: ENE Technology Inc CB1410 Cardbus Controller
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 65x/M650/740
PCI/AGP VGA Display Adapter

CPU info from dmesg:
CPU: After generic identify, caps: bfebfbff 00000000 00000000 00000000 00004400
000000
00 00000000
CPU: After vendor identify, caps: bfebfbff 00000000 00000000 00000000 00004400
0000000
0 00000000
CPU: Trace cache: 12K uops, L1 D cache: 8K
CPU: L2 cache: 512K
CPU: After all inits, caps: bfebfbff 00000000 00000000 00000080 00004400
00000000 0000
0000
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
CPU0: Intel P4/Xeon Extended MCE MSRs (12) available
CPU0: Thermal monitoring enabled
mtrr: v2.0 (20020519)
CPU: Intel(R) Pentium(R) 4 CPU 2.66GHz stepping 09

An acpidump is attached. 

Thanks
Comment 10 Cijoml Cijomlovic Cijomlov 2007-01-19 09:13:09 UTC
Hi 

it is same problem as I do have. See Dave's post:

------- Additional Comment #6 From Dave Jones  2006-07-28 20:01 -------

The lower frequencies were removed in later kernels as part of an errata
workaround.  It's possible that using them on affected CPUs can cause lockups.
Comment 11 Cijoml Cijomlovic Cijomlov 2007-02-01 02:44:09 UTC
Fixed in 2.6.20-rc7

Note You need to log in before you can comment on or make changes to this bug.