Bug 67811 - Kernel 3.13-rc5 doesn't boot with a PA6T cpu
Summary: Kernel 3.13-rc5 doesn't boot with a PA6T cpu
Status: CLOSED CODE_FIX
Alias: None
Product: Platform Specific/Hardware
Classification: Unclassified
Component: PPC-64 (show other bugs)
Hardware: PPC-64 Linux
: P1 normal
Assignee: Anton Blanchard
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-27 18:43 UTC by Christian Zigotzky
Modified: 2014-01-04 10:23 UTC (History)
2 users (show)

See Also:
Kernel Version: 3.13-rc5
Tree: Mainline
Regression: Yes


Attachments
Kernel 3.13-rc3 config (74.32 KB, application/octet-stream)
2013-12-27 22:00 UTC, Christian Zigotzky
Details
Kernel 3.13-rc5 config (74.32 KB, application/octet-stream)
2013-12-27 22:04 UTC, Christian Zigotzky
Details
Nemo patch (25.20 KB, patch)
2013-12-27 22:05 UTC, Christian Zigotzky
Details | Diff
nemo_3.13-2.patch (25.67 KB, patch)
2013-12-29 14:40 UTC, Christian Zigotzky
Details | Diff
Picture of the kernel boot (1.93 MB, image/jpeg)
2014-01-01 14:52 UTC, Christian Zigotzky
Details

Description Christian Zigotzky 2013-12-27 18:43:00 UTC
Hi All,

I've tried to test the RC5 on my Nemo board with a PA6T cpu. But it hangs before starting cpu. The kernels 3.12, 3.11, 3.10, 3.9, 3.8 etc. work fine without any problems. It seems that the new kernel 3.13 has a problem with the PA6T CPU. I know that you have done a lot of changes in the CPU code of the kernel 3.13. Do you have an idea?

Rgds,
Christian

Computer
********

Summary
-------

-Computer-
Processor		: PowerPC PA6T, altivec supported (1800,00MHz)
Memory		: 8087MB (534MB used)
Operating System		: Debian GNU/Linux jessie/sid
User Name		: christian (christian)
Date/Time		: Fr 27 Dez 2013 19:26:11 CET
-Display-
Resolution		: 1280x1024 pixels
OpenGL Renderer		: Gallium 0.4 on AMD BARTS
X11 Vendor		: The X.Org Foundation
-Multimedia-
Audio Adapter		: HDA-Intel - HD-Audio Generic
Audio Adapter		: HDA-Intel - HDA ATI SB
-Input Devices-
   USB Keyboard
   USB Keyboard
 Device USB Device
 A SPEED-LINK Competition Pro
-Printers-
No printers found
-SCSI Disks-
ATA ST2000DM001-9YN1
HL-DT-ST DVDRAM GH22NS50
ATA ESA3SF1240GB
ATA SanDisk SDCFB-25

Operating System
----------------

-Version-
Kernel		: Linux 3.11.0AmigaOneX1000 (ppc64)
Compiled		: #3 SMP Mon Oct 28 19:30:15 EDT 2013
C Library		: Unknown
Default C Compiler		: GNU C Compiler version 4.6.4 (Debian 4.6.4-5) 
Distribution		: Debian GNU/Linux jessie/sid
-Current Session-
Computer Name		: AmigaoneX1000
User Name		: christian (christian)
Home Directory		: /home/christian
Desktop Environment		: XFCE 4
-Misc-
Uptime		: 2 hours, 23 minutes
Load Average		: 0,00, 0,00, 0,00

Kernel Modules
--------------

-Loaded Modules-
ipv6		: IPv6 protocol stack for Linux
loop

Processor
---------

-Processor-
Machine		: (null)
CPU		: PowerPC PA6T, altivec supported (1800,00MHz)
L2 Cache		: 0kB
Frequency		: 1800,00MHz
BogoMips		: 0,00
Byte Order		: Big Endian

PCI Devices
-----------

-PCI Devices-
Host bridge		: PA Semi, Inc PWRficient Host Bridge 
Memory controller		: PA Semi, Inc PWRficient L2 Cache 
PIC		: PA Semi, Inc PWRficient System/Debug Controller 
RAM memory		: PA Semi, Inc PWRficient DDR2 Memory Controller 
RAM memory		: PA Semi, Inc PWRficient DDR2 Memory Controller 
Power PC		: PA Semi, Inc PA6T Core 
Power PC		: PA Semi, Inc PA6T Core 
PCI bridge		: PA Semi, Inc PWRficient PCI-Express Port 
PCI bridge		: PA Semi, Inc PWRficient PCI-Express Port 
PCI bridge		: PA Semi, Inc PWRficient PCI-Express Port 
PCI bridge		: PA Semi, Inc PWRficient PCI-Express Port 
PCI bridge		: PA Semi, Inc PWRficient PCI-Express Port 
PCI bridge		: PA Semi, Inc PWRficient PCI-Express Port 
PCI bridge		: PA Semi, Inc PWRficient PCI-Express Port 
PCI bridge		: PA Semi, Inc PWRficient PCI-Express Port 
Ethernet controller		: PA Semi, Inc PWRficient Gigabit Ethernet 
Ethernet controller		: PA Semi, Inc PWRficient Gigabit Ethernet 
Ethernet controller		: PA Semi, Inc PWRficient Gigabit Ethernet 
Ethernet controller		: PA Semi, Inc PWRficient Gigabit Ethernet 
Ethernet controller		: PA Semi, Inc PWRficient 10-Gigabit Ethernet 
Ethernet controller		: PA Semi, Inc PWRficient 10-Gigabit Ethernet 
DMA controller		: PA Semi, Inc PWRficient DMA Controller 
System peripheral		: PA Semi, Inc PWRficient SERDES 
SMBus		: PA Semi, Inc PWRficient SMBus Controller 
SMBus		: PA Semi, Inc PWRficient SMBus Controller 
SMBus		: PA Semi, Inc PWRficient SMBus Controller 
Serial controller		: PA Semi, Inc PWRficient 16550 UART 
Serial controller		: PA Semi, Inc PWRficient 16550 UART 
ISA bridge		: PA Semi, Inc PWRficient LPC/Localbus Interface 
VGA compatible controller		: Advanced Micro Devices, Inc. [AMD/ATI] Barts XT [Radeon HD 6870] 
Audio device		: Advanced Micro Devices, Inc. [AMD/ATI] Barts HDMI Audio [Radeon HD 6800 Series]
SATA controller		: Advanced Micro Devices, Inc. [AMD/ATI] SB600 Non-Raid-5 SATA 
USB controller		: Advanced Micro Devices, Inc. [AMD/ATI] SB600 USB 
USB controller		: Advanced Micro Devices, Inc. [AMD/ATI] SB600 USB 
USB controller		: Advanced Micro Devices, Inc. [AMD/ATI] SB600 USB 
USB controller		: Advanced Micro Devices, Inc. [AMD/ATI] SB600 USB 
USB controller		: Advanced Micro Devices, Inc. [AMD/ATI] SB600 USB 
USB controller		: Advanced Micro Devices, Inc. [AMD/ATI] SB600 USB Controller 
SMBus		: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 SMBus Controller 
IDE interface		: Advanced Micro Devices, Inc. [AMD/ATI] SB600 IDE 
Audio device		: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia 
ISA bridge		: Advanced Micro Devices, Inc. [AMD/ATI] SB600 PCI to LPC Bridge
PCI bridge		: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 PCI to PCI Bridge 
Ethernet controller		: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ 

Other information about the system:

http://en.wikipedia.org/wiki/AmigaOne_X1000
http://www.supertuxkart-amiga.de/amiga/x1000.html
http://en.wikipedia.org/wiki/Common_Firmware_Environment
Comment 1 Olof Johansson 2013-12-27 21:32:36 UTC
3.13-rc5 with pasemi_defconfig works just fine here on an eval board. They never sent me an X1000 as promised so I could support the mainline kernel on it, so I'm sorry but you're mostly on your own here.


Do you have a serial port available for console? If so, what's the last output you get there?
Comment 2 Christian Zigotzky 2013-12-27 21:55:08 UTC
Hi Olof,

Thank you for your answer. Unfortunately I don't have a serial port. The last output are the RAM addresses. I don't see that the CPU started.

By the way there are new Nemo boards available. Link: http://www.a-eon.com/?news=21-11-2013

And we're looking for Linux beta testers for our new PowerPC board. The new
board, codenamed Cyrus Plus, will be an replacement for the Nemo board. The revision 2.0 prototype contains a Freescale P5020 CPU which is a 2 GHz, 64-bit
dual-core PowerPC SoC. The Cyrus Plus board will also accept the new
P5040 when it becomes commercially available in greater volume. This is
a 64-bit quad-core PowerPC Freescale CPU which operates up to 2.4 GHz.
As with Nemo, the Cyrus Plus motherboard has been custom designed to run
the latest version of AmigaOS 4 and will support multiple PowerPC Linux
distributions. The deadline for applications is at the end of December.

OK, back to the topic. It's very strange, that the kernel 3.12.5 works very well but 3.13-rc5 have boot problems.

All the best,

Christian
Comment 3 Christian Zigotzky 2013-12-27 22:00:27 UTC
Created attachment 119761 [details]
Kernel 3.13-rc3 config
Comment 4 Christian Zigotzky 2013-12-27 22:04:23 UTC
Created attachment 119771 [details]
Kernel 3.13-rc5 config
Comment 5 Christian Zigotzky 2013-12-27 22:05:06 UTC
Created attachment 119781 [details]
Nemo patch
Comment 6 Christian Zigotzky 2013-12-27 22:25:18 UTC
... but 3.13-rc5 has boot problems. Sorry, my English isn't very well. I hope you know what I mean. I've compiled the kernel 3.14-rc4 as framebuffer kernel. But it hasn't solved the boot problem yet. It hangs before starting cpu. I've tried to compile the kernel with another firmware package. But it also hasn't solved the issue. It seems, that it isn't a problem with the graphics card.
Comment 7 Olof Johansson 2013-12-28 07:13:36 UTC
2.2kUSD for a 5-year old motherboard? Thanks but no thanks. :-)

And based on previous experience with "beta programs", I have no interest in "participating". But thanks for the info.

Anyway, I've been able to reproduce with ppc64_defconfig. I've been able to bisect it down to the little endian fixup code, but I can't yet explain why it's failing there. I think I'll take this to the mailing list for discussion.
Comment 8 Christian Zigotzky 2013-12-28 23:28:18 UTC
Hi Olof,

Thanks a lot for your effort. I have added the SB600 chipset and the Radeon graphics parts to the pasemi_defconfig. Then I have tried to compile the kernel 3.13-rc5 with the modified pasemi_defconfig. But it didn't compile. It seems the pasemi_defconfig isn't complete enough to build the kernel. How do you compile the kernel with the pasemi_defconfig? You told me you have an eval board. Is it the Electra board? At this time the kernel 3.12 series is the last for the Nemo board. But it would be very nice to have new kernels for the Nemo board in the future.

All the best and thank you for your help,

Christian
Comment 9 Olof Johansson 2013-12-28 23:38:30 UTC
I have several eval boards, but the one I have hooked up and easily bootable is a Chitra -- it's essentially an Electra without CF/IDE and with a PCI bridge on-board with a USB host controller (and onboard MV SATA).
Comment 10 Christian Zigotzky 2013-12-29 14:32:09 UTC
Hi Olof,

I read your posts on the mailing list. I was curious and I've tried your fix. And you're right it doesn't work. I have before I was compile the kernel, created a patch file for the Nemo board (PASEMI_SB600) with your fix. You find it as attachment.

Have a nice weekend and thanks for your effort,

Christian
Comment 11 Christian Zigotzky 2013-12-29 14:38:42 UTC
Sorry I meant ... I have before I have compiled the kernel, created a patch file for the Nemo board (PASEMI_SB600) with your fix. ... Sorry for my English.
Comment 12 Christian Zigotzky 2013-12-29 14:40:56 UTC
Created attachment 120061 [details]
nemo_3.13-2.patch
Comment 13 Christian Zigotzky 2014-01-01 14:50:15 UTC
Today, I have compiled the RC 6. But it also doesn't boot. You find a picture of the kernel boot as attachment.
Comment 14 Christian Zigotzky 2014-01-01 14:52:03 UTC
Created attachment 120481 [details]
Picture of the kernel boot
Comment 15 Christian Zigotzky 2014-01-04 00:00:58 UTC
Hi Olof,

Thank you very much for your work. :-) I've compilied the RC 6 of kernel 3.13 with your fixes. And the kernel boots and works.
But there are a problem with the Radeon driver. I could see just lines all over the screen. The reason is that the Radeon Dynamic Power Management doesn't work. I have to add the argument and the value "radeon.dpm=0" to the bootargs. For example: setenv bootargs "root=/dev/sda4 radeon.dpm=0"

Rgds,

Christian
Comment 16 Olof Johansson 2014-01-04 00:53:48 UTC
I'm pretty sure the radeon issue is unrelated; it might even be non-ppc-specific. I completely lack radeon hardware, so you should bug report that separately for those driver guys.

This can be marked fixed. I don't seem to have permissions to do so.
Comment 17 Christian Zigotzky 2014-01-04 10:22:04 UTC
Olof,

Thanks a lot for your effort. :-) I'm very happy that you have solved this issue.

Download Kernel 3.13-rc6: http://www.xenosoft.de/vmlinux-3.13-rc6-AmigaOneX1000.tar.bz2

All the best,

Christian

Note You need to log in before you can comment on or make changes to this bug.