Bug 6778 - S3: resume: black screen - Toshiba M50
S3: resume: black screen - Toshiba M50
Status: REJECTED UNREPRODUCIBLE
Product: ACPI
Classification: Unclassified
Component: Power-Sleep-Wake
i386 Linux
: P2 normal
Assigned To: acpi_aml-interpreter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-30 03:51 UTC by Scott Murphy
Modified: 2007-09-06 15:04 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.17.1
Tree: Mainline
Regression: ---


Attachments
Decompiled dsdt.dsl file (144.41 KB, text/plain)
2006-06-30 03:52 UTC, Scott Murphy
Details

Description Scott Murphy 2006-06-30 03:51:20 UTC
Most recent kernel where this bug did not occur:
None

Distribution:
Ubuntu 6.06 LTS Dapper Drake

Software environment:
Gnome 2.14.2
Gnome-power-manager 2.15.4
hald-0.5.4

Problem Description:

Shuts down, power button flashes red. When I press the power button again, the
screen just goes to black and doesn't recover.

Steps to reproduce:
echo mem > /sys/power/state
Comment 1 Scott Murphy 2006-06-30 03:52:43 UTC
Created attachment 8464 [details]
Decompiled dsdt.dsl file
Comment 2 Len Brown 2006-07-01 10:19:58 UTC
It is possible that the system has resumed, but failed
to re-enable the LCD.

on resume, is the LCD backlight off (black in a dark room)?
or is it on but blank (LCD glows slightly in a dark room)?

is there any indication of life on the resume?
ie. can you ping the machine on the network, or
do you see the disk LED blink?
Comment 3 Scott Murphy 2006-07-01 11:06:43 UTC
The screen seems to be completely black. No blacklight or glow of any kind. 
There is no hard drive activity and I can't ping the machine.

The disk led blinks once for about a milisecond, but then there is nothing. The
fan doesn't power up full speed like on a normal boot either. It starts at the
normal speed.
Comment 4 Len Brown 2006-08-09 21:19:40 UTC
can you ping the machine on the network after the resume attempt?
Comment 5 Scott Murphy 2006-08-09 23:55:58 UTC
Nope, I can't ping the machine.
Comment 6 Len Brown 2007-09-06 15:04:35 UTC
Please re-open if this is still a problem in linux-2.6.22.stable or later.

Note You need to log in before you can comment on or make changes to this bug.