Bug 67721 - SATA driver spew a lot of "hard resetting link" message after suspend cycle on macbook air 6,2
Summary: SATA driver spew a lot of "hard resetting link" message after suspend cycle o...
Status: RESOLVED DUPLICATE of bug 62351
Alias: None
Product: IO/Storage
Classification: Unclassified
Component: Serial ATA (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Tejun Heo
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-25 20:44 UTC by Lionel Landwerlin
Modified: 2013-12-26 14:29 UTC (History)
0 users

See Also:
Kernel Version: 3.12.3
Tree: Mainline
Regression: No


Attachments

Description Lionel Landwerlin 2013-12-25 20:44:19 UTC
Hi,

Just noticed a lot of messages in my logs, though the system seems to be working fine.

Dec 25 20:40:44 airy kernel: ata1.00: unexpected _GTF length (8)
Dec 25 20:40:44 airy kernel: ata1.00: unexpected _GTF length (8)
Dec 25 20:40:44 airy kernel: ata1.00: configured for UDMA/33
Dec 25 20:40:44 airy kernel: ata1: EH complete
Dec 25 20:40:44 airy kernel: ata1: exception Emask 0x10 SAct 0x0 SErr 0x10000 action 0xe frozen
Dec 25 20:40:44 airy kernel: ata1: irq_stat 0x00400000, PHY RDY changed
Dec 25 20:40:44 airy kernel: ata1: SError: { PHYRdyChg }
Dec 25 20:40:44 airy kernel: ata1: hard resetting link
Dec 25 20:40:44 airy kernel: ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
Dec 25 20:40:44 airy kernel: ata1.00: unexpected _GTF length (8)
Dec 25 20:40:44 airy kernel: ata1.00: unexpected _GTF length (8)
Dec 25 20:40:44 airy kernel: ata1.00: configured for UDMA/33
Dec 25 20:40:44 airy kernel: ata1: EH complete
Dec 25 20:40:45 airy kernel: ata1: exception Emask 0x10 SAct 0x0 SErr 0x10000 action 0xe frozen
Dec 25 20:40:45 airy kernel: ata1: irq_stat 0x00400000, PHY RDY changed
Dec 25 20:40:45 airy kernel: ata1: SError: { PHYRdyChg }
Dec 25 20:40:45 airy kernel: ata1: hard resetting link

This is what I get about every second after a suspend cycle on my macbook air 6,2.

Here are the references for the SATA phy :

04:00.0 SATA controller: Marvell Technology Group Ltd. Device 9183 (rev 14)
04:00.0 0106: 1b4b:9183 (rev 14)

I tried fixing this problem by adding libata.force=1:noncq to the command line, it didn't help.

Any idea?
Comment 1 Lionel Landwerlin 2013-12-26 14:29:09 UTC

*** This bug has been marked as a duplicate of bug 62351 ***

Note You need to log in before you can comment on or make changes to this bug.