Bug 6751 - Failure to resume from ACPI sleep with Radeon, IFF 3d accel is enabled (Thinkpad X22)
Failure to resume from ACPI sleep with Radeon, IFF 3d accel is enabled (Think...
Status: CLOSED PATCH_ALREADY_AVAILABLE
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel)
i386 Linux
: P2 normal
Assigned To: drivers_video-other
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-26 07:49 UTC by Richard Neill
Modified: 2007-04-28 12:49 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.12.*, 2.6.16.20, 2.6.17.1
Tree: Mainline
Regression: ---


Attachments

Description Richard Neill 2006-06-26 07:49:21 UTC
Summary: ACPI sleep/resume is fine, but only if 3d isn't enabled. If 3d accel is
enabled (by loading the dri module in X), even if X is subsequently stopped(!),
then the thinkpad (x22) doesn't resume from sleep. 

I have had this problem with kernels 2.6.12.x (Mandriva 2006 distro), and with
unpatched kernel.org 2.6.16.20 and 2.6.17.1. It occurs in exactly the same way 
whether I use the older echo mem > /proc/acpi/sleep  or the newer s2ram -f -a3.

I've tried all the fixes on google and thinkwiki, to no avail:  
  permutations of: noapic; nolapic; ec_intr=0,
  vbetool,
  saving and restoring the video device state. 
  killall -STOP X; [suspend]; killall -CONT X
  all other permutations of s2ram -f,-p,-a1-3,s 

All tests are done from VT1. ACPI is otherwise working fine.

 
The hardware is a Thinkpad X22 laptop, with an ATI Radeon Mobility M6 LY.
Xorg is version 6.9.0-11  using the ati driver.

When it crashes, the suspend itself is fine, but on pressing 'Fn' to resume, 
the HDD powers up, the floppy clunks once, but the crescent LED doesn't go out;
thereafter, it is totally dead and responds only to the reset button.


Here are some more diagnostics:

TEST 1)

Boot up with "linux single". Very few modules are loaded.
echo 3 > /proc/acpi/sleep.
It sleeps (and resumes) happily, and repeatedly.

TEST 2)

Restart, to avoid bias. Again, boot up with "linux single".
modprobe drm; modprobe radeon
echo 3 > /proc/acpi/sleep.
It sleeps (and resumes) happily, and repeatedly.


TEST 3)

linux single
modprobe drm; modprobe radeon
startx
STOP x
[drm and radeon modules are automatically removed when X shuts down]
echo 3 > /proc/acpi/sleep
Result: it suspends fine, but will not wake up!
Pressing Fn-F4 spins up the HDD and CPU fan, but nothing else.


TEST 4)

Running X, but without the "Load dri" line is fine.

Test 5)

Running X, with "load dri", AND with Mesa installed is fine.



I repeated this with both kernel 2.6.16.20 and 2.6.17.1 and 2.6.12. The results
are identical (except that 2.6.16 needs to use echo mem > /sys/power/state
instead of echo 3 > /proc/acpi/sleep)

My conclusion is that something in Xorg does something to the graphics card
which interferes with resume.


----
Thanks very much for your help - Richard
Comment 1 Richard Neill 2006-06-26 07:55:15 UTC
See also this thread on the suspend-devel mailing list.
http://sourceforge.net/mailarchive/message.php?msg_id=20800067
Comment 2 Len Brown 2006-08-09 21:10:53 UTC
this appears to be a Radeon issue, rather than an ACPI issue.
Moving to drivers/video.
Comment 3 Pavel Machek 2006-09-29 04:28:46 UTC
Does it happen in 2.6.18? Does s2ram from suspend.sf.net help?
Comment 4 Richard Neill 2006-09-29 13:34:01 UTC
Re #3, I am sorry, but the machine is no longer in my hands. I configured it
with Linux, then sent it to a computer-inept ex-XP friend. [In the end, I just
sent it with sleep disabled].

I did try s2ram back in June (see comment #1), with no success.

I shall cross-post this to the Linux-thinkpad list, to see if any X22 owners can
help.
Comment 5 Rafael J. Wysocki 2006-10-30 09:51:25 UTC
Does the lack of activity mean the issue is not reproducible any more?
Comment 6 Richard Neill 2006-10-30 20:16:54 UTC
Re #5, it's true that I can't reproduce it any more, since I no longer own the
affected machine! But as far as I know it's still valid. Someone with an
X21,X22,X23 or X24 thinkpad might wish to test it. Sorry to be of no more help.
Comment 7 F Louro 2006-11-01 08:40:18 UTC
I have the exact same problem and am willing to run tests on my X22.
Comment 8 Rafael J. Wysocki 2006-11-02 09:44:32 UTC
First, please visit http://en.opensuse.org/S2ram and see if the tool helps.
Comment 9 Tabrez Ali 2006-11-28 19:23:37 UTC
Things seem to work fine with 2.6.18 and radeonfb. I have been able to use dri
and havent seen the problem over the last 18-20 suspend/resume cycles on my x22.
Comment 10 Rafael J. Wysocki 2006-12-04 10:04:49 UTC
Okay, so can we close this bug?
Comment 11 Tabrez Ali 2006-12-13 16:02:33 UTC
For 

Note You need to log in before you can comment on or make changes to this bug.