Bug 67461 - [bisected] [regression] vgaswitcheroo & runpm causing lockups with radeon
Summary: [bisected] [regression] vgaswitcheroo & runpm causing lockups with radeon
Status: CLOSED DUPLICATE of bug 61891
Alias: None
Product: ACPI
Classification: Unclassified
Component: Config-Hotplug (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: acpi_config-hotplug
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-21 03:33 UTC by Mike Lothian
Modified: 2015-07-21 17:16 UTC (History)
4 users (show)

See Also:
Kernel Version: 3.12-rc4
Tree: Mainline
Regression: Yes


Attachments
Acpidump (391.50 KB, text/plain)
2013-12-23 08:57 UTC, Mike Lothian
Details

Description Mike Lothian 2013-12-21 03:33:31 UTC
I've bisected this issue back to bbd34fcdd1b201e996235731a7c98fd5197d9e51 ACPI / hotplug / PCI: Register all devices under the given bridge

More details can be found in bugs:
https://bugs.freedesktop.org/show_bug.cgi?id=71930
https://bugzilla.kernel.org/show_bug.cgi?id=61891
https://bugzilla.kernel.org/show_bug.cgi?id=64891
https://bugzilla.kernel.org/show_bug.cgi?id=65761

There are possibly others

I'll happily provide any more logs from my system but I'm not sure what acpi debug layer / level options to use. Using 0xFFFFFFFF for both gave way to much info

Sorry this bug report comes a kernel cycle late I was using a private branch testing out the radeon runpm code during the 3.12 cycle as it wasn't merged in time
Comment 1 Lan Tianyu 2013-12-23 01:25:52 UTC
Cc Rafael.

Please provide the output of acpidump.
Comment 2 Mike Lothian 2013-12-23 08:57:20 UTC
Created attachment 119331 [details]
Acpidump
Comment 3 Mike Lothian 2014-01-02 14:12:58 UTC
Fixed in 61891
Comment 4 Len Brown 2015-07-21 17:16:15 UTC

*** This bug has been marked as a duplicate of bug 61891 ***

Note You need to log in before you can comment on or make changes to this bug.