Bug 67321 - Cannot hear anything using HDMI/DisplayPort audio connection on Intel D54250WYK with igfx IOMMU on
Summary: Cannot hear anything using HDMI/DisplayPort audio connection on Intel D54250W...
Status: RESOLVED DUPLICATE of bug 60769
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel) (show other bugs)
Hardware: Intel Linux
: P1 normal
Assignee: Jaroslav Kysela
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-18 18:00 UTC by Philip Langdale
Modified: 2015-01-28 14:51 UTC (History)
8 users (show)

See Also:
Kernel Version: 3.15
Tree: Mainline
Regression: No


Attachments
alsa-info (32.53 KB, text/plain)
2014-01-10 17:31 UTC, Philip Langdale
Details
xrandr --verbose (8.18 KB, text/plain)
2014-01-10 17:34 UTC, Philip Langdale
Details

Description Philip Langdale 2013-12-18 18:00:53 UTC
I'm running on a new Intel NUC d54250wyk.

When I plug in an HDMI or DisplayPort display which supports audio, I see the audio device reported as present in all the expected places - PulseAudio, ALSA, EDID output in dmesg, etc.

But when I try and play any noise, I simply don't hear anything.

These display have worked correctly with audio on an older NUC DC3217IYE, and the analog audio out on the new NUC works fine.
Comment 1 Jani Nikula 2013-12-19 09:21:14 UTC
Haswell? Which kernel version is this?
Comment 2 Philip Langdale 2013-12-19 16:18:10 UTC
Kernel 3.12.5 and I also tested with 3.13rc3

Yes, Haswell: http://ark.intel.com/products/76977/Intel-NUC-Kit-D54250WYK?q=d54
Comment 3 Daniel Vetter 2014-01-10 08:40:21 UTC
Since the visual stuff seems to work this can't possible be a gfx bug ;-)

More seriously: Reassigning to grab the audio ppl's attention. I'll keep our bug m-l on cc.
Comment 4 Takashi Iwai 2014-01-10 08:58:17 UTC
Check /proc/asound/card*/eld#* files to see whether you get the ELD properly received from the graphics.  If no monitor and ELD content is found there, the problem is outside the sound stuff.

If there is a corresponding entry, you must play with this port.
Comment 5 Raymond 2014-01-10 09:02:05 UTC
you have to post output of alsa-info.sh 

xrandr --verbose



Intel ® High Definition (Intel ® HD) Audio 
via  the Mini HDMI v1.4a 
and Mini DisplayPort 1.2 interfaces through the processor
•Intel HD Audio via a stereo microphone/headphone jack on the front panel
•Front panel audio jack (3.5 mm jack)

are you using hdmi or displayport audio ?
Comment 6 Philip Langdale 2014-01-10 17:31:15 UTC
Created attachment 121591 [details]
alsa-info

I've attached the alsa-info.txt.

More notes:

1) Using either the displayport or the hdmi port, audio does not work.
2) Using the analog audio port (which is on the separate PCH audio controller) works fine.
3) The ELD information looks correct for both displayport and hdmi. I see the right device identity and capabilities reported
4) When the computer is playing audio, /proc/asound reports the right device in use and valid sample format information, etc. But of course, no sound is produced.
5) I've verified that the displays in question (Dell Ultrasharps) do correctly output sound from other computers.
Comment 7 Philip Langdale 2014-01-10 17:34:05 UTC
Created attachment 121601 [details]
xrandr --verbose
Comment 8 Takashi Iwai 2014-01-10 17:37:43 UTC
How did you test the playback?  Looking at alsa-info.sh output, the monitor is connected to the secondary audio HDMI port.

Just to be sure, could you try 3.12 kernel as well?
Comment 9 Philip Langdale 2014-01-10 17:46:41 UTC
I tried with 3.12.x and 3.13rc, all with the same results.

To test playback, I plug my headphones into the stereo-out port on the monitor and try to play some audio from the desktop environment (pulse audio, etc). The software side of all this is exactly the same as it was on my previous computer - I copied the OS image over directly - and it worked fine previously, and not now.

And yes, the monitor is connected to the second port (which happens to be DisplayPort). When I connect my other monitor over HDMI it is to the first port, and all the ELD information appears against the other device.
Comment 10 Raymond 2014-01-11 08:25:00 UTC
seem connect to DP1

HDMI1 disconnected (normal left inverted right x axis y axis)

	audio: auto 
		supported: force-dvioffautoon

DP1 connected primary 2560x1600+0+0 (0xad) normal (normal left inverted right x axis y axis) 641mm x 401mm
	audio: auto 
		supported: force-dvioffautoon


HDMI2 disconnected (normal left inverted right x axis y axis)
	audio: auto 
		supported: force-dvioffautoon






Manufacturer: DEL Model 4065 Serial Number 825309004
Made week 34 of 2010
EDID version: 1.4
Digital display
10 bits per primary color channel
DisplayPort interface

Serial number: PH5NY08P117L
Monitor name: DELL
Monitor ranges (GTF): 49-86Hz V, 29-113kHz H, max dotclock 280MHz
Has 1 extension blocks
Checksum: 0xb (valid)

CEA extension block
Extension version: 3
25 bytes of CEA data

  Audio data block
    Linear PCM, max channels 5
    Supported sample rates (kHz): 192 176.4 96 88.2 48 44.1 32
    Supported sample sizes (bits): 24 20 16
  Speaker allocation data block
Comment 11 Philip Langdale 2014-05-23 20:42:28 UTC
Some new data.

Currently running 3.14.3 and I happened to try again on the Dell U3011. This display supports 5.1 analog output of the audio signal so I set the output to 5.1 and plugged my head phones into the front L/R channel. Surprisingly I actually got some sound. It was recognisable but it was stuttering. If I set it to stereo mode, then I get no sound as reported previously.
Comment 12 Diego Elio Pettenò 2014-06-09 14:11:01 UTC
So I seem to have the same problem on the same device even with 3.15.0.

Did anybody got any sound on this device? I've been told hat it should have been fully supported by OpenELEC, maybe there is a patch that hey apply that is needed? Or a kernel config option that we missed?
Comment 13 Diego Elio Pettenò 2014-06-10 14:41:58 UTC
This looks like a duplicate of bug #60769 or at least has the same solution:

intel_iommu=on,igfx_off
Comment 14 Philip Langdale 2014-06-11 18:41:55 UTC
Good catch. I've updated the summary.
Comment 15 Tobias Jakobi 2014-10-11 22:37:10 UTC
Having the same issue here on a D34010WYK.
Comment 16 Gabor Gombas 2014-10-14 21:53:39 UTC
Same here - Intel NUC D54250WYK, kernel 3.16.5, no sound over HDMI unless intel_iommu=on,igfx_off is passed to the kernel.
Comment 17 Jani Nikula 2014-10-16 07:28:21 UTC
See also 86221.
Comment 18 Jani Nikula 2015-01-28 14:51:20 UTC

*** This bug has been marked as a duplicate of bug 60769 ***

Note You need to log in before you can comment on or make changes to this bug.