Bug 6723 - some ohci hardware is broken
some ohci hardware is broken
Status: RESOLVED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: USB
i386 Linux
: P2 normal
Assigned To: David Brownell
:
Depends on:
Blocks: USB
  Show dependency treegraph
 
Reported: 2006-06-20 03:44 UTC by Boris Nicolaev
Modified: 2007-04-17 13:16 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.17
Tree: Mainline
Regression: ---


Attachments
dmesg 2.6.17 (14.95 KB, text/plain)
2006-06-20 03:47 UTC, Boris Nicolaev
Details
dmesg 2.6.17 with enabled usb-debug (14.16 KB, text/plain)
2006-06-21 22:17 UTC, Boris Nicolaev
Details
dmesg 2.6.17 after rmmod ohci-hcd (14.99 KB, text/plain)
2006-06-21 22:21 UTC, Boris Nicolaev
Details
lspci -vvv (8.72 KB, text/plain)
2006-06-21 22:23 UTC, Boris Nicolaev
Details
patch queued for 2.6.19 (15.11 KB, patch)
2006-08-30 01:18 UTC, David Brownell
Details | Diff
dmesg 2.6.18-rc5 kernel with applied patch (14.50 KB, text/plain)
2006-09-06 01:30 UTC, Boris Nicolaev
Details
proposed patch for this board-specific quirk (1.89 KB, patch)
2006-10-07 19:16 UTC, David Brownell
Details | Diff
lspci -vvn 2.6.18 kernel with applied patch (7.72 KB, text/plain)
2006-10-12 09:20 UTC, Boris Nicolaev
Details
Patch being submitted (3.22 KB, patch)
2007-04-17 13:05 UTC, David Brownell
Details | Diff

Description Boris Nicolaev 2006-06-20 03:44:55 UTC
Most recent kernel where this bug did not occur: 2.6.16.20
Distribution: Slackware 10.2
Hardware Environment: Toshiba portege 4000
Problem Description:
after loading ohci-hcd module, I get continuous kernel messages:
ohci_hcd 0000:00:02.0: wakeup
ohci_hcd 0000:00:02.0: wakeup
ohci_hcd 0000:00:02.0: wakeup
.............................
usb devices are not detecting.
But, if I boot system after power off -- all ok. 
This problem occurs only after system reboot. 
reboot={b,w,c,h} option is useless.

Steps to reproduce:
reboot toshiba portege 4000 and load ohci-hcd module.
Comment 1 Boris Nicolaev 2006-06-20 03:47:50 UTC
Created attachment 8351 [details]
dmesg 2.6.17
Comment 2 Boris Nicolaev 2006-06-21 22:17:30 UTC
Created attachment 8372 [details]
dmesg 2.6.17 with enabled usb-debug
Comment 3 Boris Nicolaev 2006-06-21 22:21:49 UTC
Created attachment 8373 [details]
dmesg 2.6.17 after rmmod ohci-hcd
Comment 4 Boris Nicolaev 2006-06-21 22:23:21 UTC
Created attachment 8374 [details]
lspci -vvv
Comment 5 David Brownell 2006-08-30 01:18:49 UTC
Created attachment 8901 [details]
patch queued for 2.6.19

please try current 2.6.18-rc5 with the attached patch, which is
already queued for 2.6.19-early
Comment 6 Boris Nicolaev 2006-09-06 01:30:58 UTC
Created attachment 8947 [details]
dmesg 2.6.18-rc5 kernel with applied patch

Unfortunately, this patch don't resolve trouble.
Comment 7 David Brownell 2006-09-09 03:15:03 UTC
The problem looks to be your hardware then, since the  
root hub is misbehaving.  
    
Probable workaround:  as root   
   
  # cd /sys/bus/pci/devices/0000:00:02.0   
  # cd usb1/power   
  # echo disabled > wakeup   
  #   
 
That tells the driver that the root hub wakeup mechanism 
must not be used. 
 
You'd have to do that on each boot; I have no reason  
to think this is generic to every ALI root hub, since  
in the past I've used them with no problems.  
  
 
Comment 8 David Brownell 2006-09-19 11:37:35 UTC
Since this is clearly a hardware bug and I've included the workaround, 
I'm reducing its priority and will probably mark it as closed unless 
there's confirmation that the problem exists in 2.6.18 ... 
 
 
Comment 9 Boris Nicolaev 2006-09-20 08:40:07 UTC
This problem occurs 2.6.18 kernel.
Is it possible to add kernel option, which 
enable workaround for this hardware?
Comment 10 David Brownell 2006-10-07 19:16:46 UTC
Created attachment 9176 [details]
proposed patch for this board-specific quirk

Please see if this patch properly works around the problem on your
board.	If it does not, please provide "lspci -vvn" info for the
OHCI controller with this problem.
Comment 11 David Brownell 2006-10-10 10:15:01 UTC
ping ... any updates on testing?  I'm waiting for info about 
both (a) the /sys/devices/.../wakeup workaround, (b) the patch 
that knows about this board quirk 
Comment 12 David Brownell 2006-10-10 10:15:46 UTC
Comment on attachment 8901 [details]
patch queued for 2.6.19

patch is now merged
Comment 13 Boris Nicolaev 2006-10-11 23:06:41 UTC
Sorry for delay, today I'll provide all information. 
Comment 14 Boris Nicolaev 2006-10-12 09:20:59 UTC
Created attachment 9241 [details]
lspci -vvn 2.6.18 kernel with applied patch

Workaround works. Patch does not resolve problem.
Comment 15 Boris Nicolaev 2007-02-05 11:31:32 UTC
With 2.6.20 kernel -- all ok. Suppose, now bug can be closed.
Comment 16 David Brownell 2007-04-17 13:05:11 UTC
Created attachment 11221 [details]
Patch being submitted

Previous patches had infrastructure that wasn't validated ... now that the
infrastructure has been merged, this updated patch should be OK.  I'm
submitting it (plus a followup patch, verified as making another system work)
for the 2.6.22 kernel.

Note You need to log in before you can comment on or make changes to this bug.