Bug 66981 - radeon 7970M, skyrim with mesa git: "GPU fault detected: 146"
Summary: radeon 7970M, skyrim with mesa git: "GPU fault detected: 146"
Status: RESOLVED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel) (show other bugs)
Hardware: x86-64 Linux
: P1 normal
Assignee: drivers_video-dri
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-14 13:56 UTC by Christoph Haag
Modified: 2013-12-19 18:27 UTC (History)
1 user (show)

See Also:
Kernel Version: 3.13-rc2
Tree: Mainline
Regression: No


Attachments
systemd journal/dmesg (200.82 KB, text/x-log)
2013-12-14 13:56 UTC, Christoph Haag
Details

Description Christoph Haag 2013-12-14 13:56:02 UTC
Created attachment 118371 [details]
systemd journal/dmesg

muxless hybrid graphics

00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Wimbledon XT [Radeon HD 7970M]

dpm enabled, runpm disabled.

Software: xorg server 1.14.5, xf86-video-ati git d571d6a, glamor git 71e7168, llvm svn 197173, mesa git 40070e7.

So I'm not sure whether to report this to mesa or the kernel, but I decided for the kernel because it causes some errors there.

Playing skyrim in wine 1.7.8 with mesa git 00faf82 was working fine. mesa git 40070e7 introduced some rendering errors, but the thing here is that after a while the gpu locks up and if I'm lucky it recovers and I simply can not render anything anymore on the radeon gpu and if I'm unlucky I get a hard lockup of the whole machine.

Important parts for people who google this:

Dez 14 14:07:12 c-l kernel: radeon 0000:01:00.0: GPU lockup CP stall for more than 10000msec
Dez 14 14:07:12 c-l kernel: radeon 0000:01:00.0: GPU lockup (waiting for 0x000000000025e0a5 last fence id 0x000000000025e0a4 on ring 0)
Dez 14 14:07:12 c-l kernel: radeon 0000:01:00.0: failed to get a new IB (-35)
Dez 14 14:07:12 c-l kernel: [drm:radeon_cs_ib_fill] *ERROR* Failed to get ib !

and

Dez 14 14:07:15 c-l kernel: VM fault (0x00, vmid 0) at page 0, read from unknown (0)
Dez 14 14:07:15 c-l kernel: radeon 0000:01:00.0: GPU fault detected: 146 0x0b06550c
Dez 14 14:07:15 c-l kernel: radeon 0000:01:00.0:   VM_CONTEXT1_PROTECTION_FAULT_ADDR   0x00000000
Dez 14 14:07:15 c-l kernel: radeon 0000:01:00.0:   VM_CONTEXT1_PROTECTION_FAULT_STATUS 0x00000000
Comment 1 Arek Ruśniak 2013-12-14 22:22:59 UTC
You can try run wine with R600_DEBUG=nohyperz, it should prevent GPU crash.
Comment 2 Christoph Haag 2013-12-14 23:32:15 UTC
Indeed, it does prevent all of the above. So I guess the new hyperz implementation for radeonsi is buggy for me... Anyway, it would be preferable to only have the application crash and not the driver. :)
Comment 3 Michel Dänzer 2013-12-18 02:23:47 UTC
Does HyperZ work better with current Mesa Git?
Comment 4 Christoph Haag 2013-12-18 13:52:10 UTC
I'm not completely sure it's gone, but it's looking good I think. I'll be "testing" it some more later. :)
Comment 5 Christoph Haag 2013-12-19 18:27:17 UTC
Ok, I'll close this since I have seen nothing like that anymore so I assume it is fixed by mesa.

Note You need to log in before you can comment on or make changes to this bug.