Bug 66861 - Device ID 2013:024f PCTV Systems nanoStick T2 290e fails with 3.10.22-1.el6.elrepoNONPAE.i686; previously OK
Device ID 2013:024f PCTV Systems nanoStick T2 290e fails with 3.10.22-1.el6....
Status: RESOLVED CODE_FIX
Product: v4l-dvb
Classification: Unclassified
Component: dvb-usb
IA-32 Linux
: P1 normal
Assigned To: dvb-usb
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-12-10 20:08 UTC by John Pilkington
Modified: 2013-12-22 22:19 UTC (History)
9 users (show)

See Also:
Kernel Version: 3.10.22-1.el6.elrepoNONPAE.i686
Tree: Mainline
Regression: Yes


Attachments

Description John Pilkington 2013-12-10 20:08:40 UTC
This device has worked with earlier versions of the elrepo kernel, since May 2013.  It still works with 3.10.21-1

With 3.10.22-1, and with 3.10.23-1, dmesg has /NOT/ reported "em28174 #0: Successfully loaded em28xx-dvb," an adapter has not been created, and no TV reception has been possible.

The problem appears to be in i2c_transfer to the tda18271 chip.  dmesg shows:

tda18271 8-0060: creating new instance
tda18271_read_regs: [8-0060|M] ERROR: i2c_transfer returned: -19
Error reading device ID @ 8-0060, bailing out.
tda18271_attach: [8-0060|M] error -5 on line 1285
tda18271 8-0060: destroying instance

https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.10.22 [^] has a commit affecting the tda18271 chip causing the dmesg error above. It could affect a lot of other chips too :-( 

As a test, I have plugged the same device into my Fedora 18 box.  dmesg on that does /NOT/ show this error.

3.11.10-100.fc18.x86_64

24742.813920] TDA18271HD/C2 detected @ 8-0060
[24742.981302] DVB: registering new adapter (em28174 #0)
[24742.981313] usb 1-2: DVB: registering adapter 4 frontend 0 (Sony CXD2820R)...
[24742.984337] em28174 #0: Successfully loaded em28xx-dvb
[24742.984343] Em28xx: Initialized (Em28xx dvb Extension) extension

More details at http://elrepo.org/bugs/view.php?id=438
Comment 1 Alan Bartlett 2013-12-10 21:39:34 UTC
This regression occurred in linux-3.10.22
Comment 2 Georg Wolfram 2013-12-11 13:10:39 UTC
Here at Archlinux we have the same problem, but with kernel version 3.12.3 previous version 3.12.2 (and older) worked fine.

See the thread at <https://bbs.archlinux.org/viewtopic.php?id=173982>
Comment 3 Steve Goodey 2013-12-15 10:25:49 UTC
Comment on blog.

"FYI, working just fine on 3.11.0-15-generic (Ubuntu 13.10, kept up-to-date)."

http://angrytechnician.wordpress.com/2011/10/25/how-to-stream-freeview-hd-dvb-t2-over-multicast-using-dvblast-you-idiots/#comment-5683
Comment 4 John Pilkington 2013-12-22 13:14:14 UTC
It's working again with 3.10.25-1.el6.elrepoNONPAE.i686

Thank you.

Note You need to log in before you can comment on or make changes to this bug.