Bug 66771 - System freeze when plugging/unplugging the VGA connector - Sony laptop VGN-SR19XN
Summary: System freeze when plugging/unplugging the VGA connector - Sony laptop VGN-SR...
Status: CLOSED CODE_FIX
Alias: None
Product: ACPI
Classification: Unclassified
Component: BIOS (show other bugs)
Hardware: All Linux
: P3 normal
Assignee: Chen Yu
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-08 09:32 UTC by Lionel Duriez
Modified: 2015-07-21 19:11 UTC (History)
4 users (show)

See Also:
Kernel Version: 3.11.0-14
Tree: Mainline
Regression: No


Attachments
uname -a (114 bytes, text/x-log)
2013-12-08 09:33 UTC, Lionel Duriez
Details
lspci -vvnn (30.81 KB, text/plain)
2013-12-08 09:33 UTC, Lionel Duriez
Details
dmesg (63.14 KB, text/plain)
2013-12-08 09:34 UTC, Lionel Duriez
Details
acpidump (166.63 KB, text/plain)
2013-12-11 22:24 UTC, Lionel Duriez
Details
Do nothing in acpi_video_bus_notify to debug (374 bytes, patch)
2013-12-20 06:09 UTC, Aaron Lu
Details | Diff
patch to blacklist vista on this laptop (1.07 KB, application/octet-stream)
2015-03-11 04:51 UTC, Chen Yu
Details

Description Lionel Duriez 2013-12-08 09:32:28 UTC
Latest working kernel : none to my knowledge

Current kernel having the problem : 3.11.0-14-generic

Distribution : Ubuntu 64 13.10

Hardware environment : Sony laptop VGN-SR19XN
-Processor : Intel(R) Core(TM)2 Duo CPU     P8400  @ 2.26GHz
- Memory : 4GB DDR2

Problem description:
The system freezes when plugging or unplugging the VGA connector on a Sony Vaio VGN-SR19XN with an Intel 4500MHD graphic card. I initially reported the problem to freedesktop (https://bugs.freedesktop.org/show_bug.cgi?id=58436) but it appears the problem resides on the ACPI side : disabling ACPI makes the problem disappears.

Steps to reproduce :
- Plug or unplug the VGA connector
Comment 1 Lionel Duriez 2013-12-08 09:33:00 UTC
Created attachment 117821 [details]
uname -a
Comment 2 Lionel Duriez 2013-12-08 09:33:31 UTC
Created attachment 117831 [details]
lspci -vvnn
Comment 3 Lionel Duriez 2013-12-08 09:34:47 UTC
Created attachment 117841 [details]
dmesg
Comment 4 Aaron Lu 2013-12-10 07:21:10 UTC
acpidump please:
# acpidump > acpidump.txt

After a normal boot, do you see the video module get loaded?
# lsmod |grep video
If so, please remove it and then test plugging/unplugging VGA connector again see if system still freezes.
Comment 5 Lionel Duriez 2013-12-11 22:24:41 UTC
Created attachment 118101 [details]
acpidump
Comment 6 Lionel Duriez 2013-12-11 22:29:17 UTC
After a normal boot the video modile is loaded :
video                  19318  1 i915

After removing video module (by blacklisting relevant modules in /etc/modprobe.d/blacklist.conf and sudo modprobe -r video) the system still freezes when plugging/unplugging VGA connector.
Comment 7 Aaron Lu 2013-12-20 06:09:20 UTC
Created attachment 119121 [details]
Do nothing in acpi_video_bus_notify to debug

Please apply this one line debug patch, you do not need to blacklist video module or remove it with this patch, let's see if it makes any difference.
Comment 8 Lionel Duriez 2013-12-23 13:33:38 UTC
No difference after patching acpi_video_bus_notify, still crashing when plugging or unplugging VGA connector.
Comment 9 Aaron Lu 2013-12-24 02:15:42 UTC
Looks like a firmware issue to me.
Comment 10 Lionel Duriez 2014-01-08 07:11:42 UTC
More information :
I have tested FreeBSD and OpenBSD with the same result : system freezes.
So far, only Windows vista and seven have survived the VGA plugging/unplugging.
Comment 11 Zhang Rui 2014-12-02 08:36:12 UTC
Please blacklist i915 driver and check if the problem still exists.
Comment 12 Lionel Duriez 2015-01-10 10:32:34 UTC
I couldn't get rid of i915 driver by blacklisting it so I started in VESA and rmmoded i915 just to be sure. The problem still exists.
Comment 13 Zhang Rui 2015-03-02 02:19:55 UTC
please check if the problem still exists if you boot with acpi_osi="!Windows 2006" or acpi_osi=!.
Comment 14 Lionel Duriez 2015-03-05 20:25:54 UTC
Problem disappears with both parameters.
Comment 15 Chen Yu 2015-03-11 04:51:00 UTC
Created attachment 170371 [details]
patch to blacklist vista on this laptop
Comment 16 Chen Yu 2015-03-11 04:54:44 UTC
Please apply the patch attached comment #15 to see if the problem disappears or not. Thanks!
Comment 17 Lionel Duriez 2015-03-12 21:36:35 UTC
I have applied the patch on 3.16.0-31.
Everything is OK, problem solved.
Thanks a lot !
Comment 18 Len Brown 2015-07-21 19:11:00 UTC
shipped in Linux 4.1-rc1:

commit 8a5de52afc5f9a20a356e49351292d098cc455b2
Author: Chen Yu <yu.c.chen@intel.com>
Date:   Mon Mar 16 17:35:18 2015 +0800

    ACPI / blacklist: Disable Vista compatibility for Sony VGN-SR19XN.

Note You need to log in before you can comment on or make changes to this bug.