Bug 66451 - [pandaboard] audio initialization fails due to TWL6040
[pandaboard] audio initialization fails due to TWL6040
Status: RESOLVED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA)
ARM Linux
: P1 normal
Assigned To: Jaroslav Kysela
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-12-03 22:43 UTC by Tobias Jakobi
Modified: 2013-12-14 13:59 UTC (History)
1 user (show)

See Also:
Kernel Version: 3.13-rc2
Tree: Mainline
Regression: No


Attachments
Fix patch (4.23 KB, patch)
2013-12-13 11:58 UTC, Takashi Iwai
Details | Diff

Description Tobias Jakobi 2013-12-03 22:43:32 UTC
Hello!

dmesg:
omap-abe-twl6040 sound.7: ASoC: CODEC twl6040-codec not registered
omap-abe-twl6040 sound.7: snd_soc_register_card() failed: -517
platform sound.7: Driver omap-abe-twl6040 requests probe deferral
omap-abe-twl6040 sound.7: Coherent DMA mask 0xffffffffffffffff is larger than dma_addr_t allows
omap-abe-twl6040 sound.7: Driver did not use or check the return value from dma_set_coherent_mask()?
omap-pcm-audio omap-pcm-audio: ASoC: pcm constructor failed: -12
omap-abe-twl6040 sound.7: ASoC: can't create pcm TWL6040 :-12
omap-abe-twl6040 sound.7: ASoC: failed to instantiate card -12
omap-abe-twl6040 sound.7: snd_soc_register_card() failed: -12
omap-abe-twl6040: probe of sound.7 failed with error -12

3.13 killed what was left of my audio support on the panda-es *tears*

Greets,
Tobias

PS:
The current kernel config can be found here: https://bugzilla.kernel.org/attachment.cgi?id=117301
And the full log: https://bugzilla.kernel.org/attachment.cgi?id=117311
Comment 1 Takashi Iwai 2013-12-04 13:42:49 UTC
Is this a regression in 3.13 kernel, and it worked with 3.12 kernel?
Comment 2 Tobias Jakobi 2013-12-04 14:08:11 UTC
Yes, you probably remember this one here:
https://bugzilla.kernel.org/show_bug.cgi?id=64741

So, on 3.12 at least the 96kHz rate worked.
Comment 3 Takashi Iwai 2013-12-13 11:57:53 UTC
The upstream patch below should fix the issue.  It's found in linux-next, and will be merged to Linus tree later.
Comment 4 Takashi Iwai 2013-12-13 11:58:14 UTC
Created attachment 118241 [details]
Fix patch
Comment 5 Tobias Jakobi 2013-12-14 13:59:23 UTC
Can verify that the applying the patch lets the device appear again.

Note You need to log in before you can comment on or make changes to this bug.