Bug 66271 - subwoofer doesn't work in ALC668
Summary: subwoofer doesn't work in ALC668
Status: RESOLVED DUPLICATE of bug 65091
Alias: None
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Jaroslav Kysela
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-01 19:57 UTC by jfesparterov
Modified: 2013-12-02 14:42 UTC (History)
1 user (show)

See Also:
Kernel Version: 3.11
Tree: Mainline
Regression: No


Attachments
alsa-info (37.74 KB, text/plain)
2013-12-02 12:49 UTC, jfesparterov
Details

Description jfesparterov 2013-12-01 19:57:18 UTC
I buy new laptop Asus, N550JV model. I configure subwoofer (http://askubuntu.com/questions/189304/no-sound-from-external-subwoofer-sonic-master-on-an-asus-n76vm). I don't work. Do its error realtek driver with ALC668 Chip?

Sorry for me english
Comment 1 Takashi Iwai 2013-12-02 09:15:17 UTC
It's because of the buggy BIOS.

Please give alsa-info.sh output.  Run it with --no-upload option and attach the generated file to bugzilla (don't paste).

The bass support for N550 was already added recently.  Did try 3.12.2 kernel?
Comment 2 jfesparterov 2013-12-02 11:26:42 UTC
ok, I compiler 3.12.2 kernel and writer result.
Comment 3 jfesparterov 2013-12-02 12:49:15 UTC
I have compiler 3.12.2 kernel and i don't work subwoofer. I add the file result alsa-info.sh --no-upload
Comment 4 jfesparterov 2013-12-02 12:49:41 UTC
Created attachment 117171 [details]
alsa-info
Comment 5 Takashi Iwai 2013-12-02 12:53:43 UTC
Hrm, something wrong in alsa-info.sh output.
It doesn't show any DMI strings and PCI entries.
Did you install bash?
Comment 6 Takashi Iwai 2013-12-02 13:03:20 UTC
BTW, sorry, I thought the patch was sent to 3.12 stable, but it was only for 3.13.  You can try 3.13-rc2 if you want.

Or, as a quick workaround, prepare a file /lib/firmware/alsa/n550-bass containing the contents below:

[codec]
0x10ec0668 0x104311cd 0

[pincfg]
0x1a 0x80106111


Then pass "patch=,alsa/n550-bass" option to snd-hda-intel module.  (Don't strip a comma before "alsa//n550-bass".)

Also, don't pass model= option.  This doesn't work for your machine.

*** This bug has been marked as a duplicate of bug 65091 ***
Comment 7 jfesparterov 2013-12-02 14:42:18 UTC
very good, thaks

Note You need to log in before you can comment on or make changes to this bug.