Bug 6554 - usb off after resuming from suspend2
usb off after resuming from suspend2
Status: REJECTED INVALID
Product: Drivers
Classification: Unclassified
Component: USB
i386 Linux
: P2 normal
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks: USB
  Show dependency treegraph
 
Reported: 2006-05-14 17:13 UTC by michaelm
Modified: 2006-06-13 12:36 UTC (History)
0 users

See Also:
Kernel Version: 2.6.16.16 vanilla
Tree: Mainline
Regression: ---


Attachments

Description michaelm 2006-05-14 17:13:25 UTC
redirected to usb devs. details here:

http://bugzilla.suspend2.net/show_bug.cgi?id=218

lspci part:

0000:00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6
+Family) USB UHCI #1 (rev 03)
0000:00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6
+Family) USB UHCI #2 (rev 03)
0000:00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6
+Family) USB UHCI #3 (rev 03)
0000:00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6
+Family) USB UHCI #4 (rev 03)
0000:00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6
+Family) USB2 EHCI Controller (rev 03)
Comment 1 Greg Kroah-Hartman 2006-06-06 01:08:41 UTC
We can't support suspend2, that's up to Nigel.

Also, just try to unload the usb controllers modules before suspending, and
loading them when resuming, that usually fixes this.
Comment 2 David Brownell 2006-06-13 12:36:20 UTC
FWIW this seems to be the same bug addressed by my 
recent patches that added a new PRETHAW PM event. 

Note You need to log in before you can comment on or make changes to this bug.