Bug 6526 - USB devices stop working after burning a DVD
USB devices stop working after burning a DVD
Status: REJECTED INSUFFICIENT_DATA
Product: Drivers
Classification: Unclassified
Component: USB
i386 Linux
: P2 normal
Assigned To: Alan Stern
:
Depends on:
Blocks: USB
  Show dependency treegraph
 
Reported: 2006-05-09 19:25 UTC by Jason Bouzane
Modified: 2006-11-30 19:44 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.16.12
Tree: Mainline
Regression: ---


Attachments
dmesg output (42.74 KB, text/plain)
2006-05-09 19:26 UTC, Jason Bouzane
Details
/var/log/messages (2.14 KB, text/plain)
2006-05-09 19:27 UTC, Jason Bouzane
Details
Kernel config (36.24 KB, text/plain)
2006-05-09 19:28 UTC, Jason Bouzane
Details

Description Jason Bouzane 2006-05-09 19:25:53 UTC
Most recent kernel where this bug did not occur: Unknown
Distribution: Gentoo
Hardware Environment: Dell Inspiron 5150
Software Environment: K3B
Problem Description:

I burned a DVD+R at 8x in K3B. The burn failed about a quarter of the way
through. After the burn failed, USB plug and unplug events cease. I.e. plugging
in a USB hard drive or the burner (after unplugging it) fail. Even
non-usb-storage devices (USB keyboard and mouse) wouldn't work. In fact, the
devices don't even receive power.

That's the brief description. The more detailed description is as follows.

The burner is a Pioneer DVR-A09XL [1]. It is attached to the laptop via an
external drive enclosure: A Vantec NexStar 2 [2]. The drive has the latest
firmware, but I've always had trouble burning disks under Linux. I've never
tried with Windows. Usually, any burn requires 2.5 minutes at the start for it
to detect the media (when burning with K3B; from the command line, it doesn't
have this problem). There are often messages in the system log about the drive
not being ready. However, this is the first time that I've ever had the drive
break the USB interface altogether.

Normally, when burning a disk, the drive has several points where it will stop
burning, speed up the rotation of the disk, and then recontinue burning. The
burn was at 8x, but the drive was burning at only 6x just prior to it failing.
The drive stopped burning and began spinning the disk faster. Before the drive
started burning again, the burn failed.

After the burn failed, I could not eject the disk, so I powered off the device.
Upon powering it on again, it no longer was detected (no messages in the
syslog). However, I had a hard drive (connected via a NexStar 3 drive enclosure)
on the second USB connector. That drive continued to work until I unplugged it.
After unplugging it, neither USB port worked, even if I plugged in a USB mouse
and keyboard.

There are still two usb-storage processes running on my machine. I don't have
kernel debugging enabled on this kernel, so I can't really do much with it.

I'm attaching the dmesg output. You'll notice there are a lot of errors about
hda and sda near the end. The hda errors aren't relevant, and the sda errors
occured when I tried to mount the hard disk again after the burn failed. I'm
also attaching the relevant portions of /var/log/messages (though that's pretty
much the same as the dmesg output) and my kernel config.

I realize that isn't very much information, but it's really all I have to go on.
If you can think of anything else you need to solve this, let me know.

[1]
http://www.pioneerelectronics.com/pna/product/detail/0,,2076_103674852_207918120,00.html)
[2] http://www.vantecusa.com/p_nst525uf.html
Comment 1 Jason Bouzane 2006-05-09 19:26:37 UTC
Created attachment 8076 [details]
dmesg output
Comment 2 Jason Bouzane 2006-05-09 19:27:23 UTC
Created attachment 8077 [details]
/var/log/messages
Comment 3 Jason Bouzane 2006-05-09 19:28:15 UTC
Created attachment 8078 [details]
Kernel config
Comment 4 Alan Stern 2006-08-30 12:55:02 UTC
You filed this report over three months ago, and I only learned about it today.
 Are there still any problems, or was this a one-time occurrence?
Comment 5 Adrian Bunk 2006-11-30 19:44:17 UTC
Please reopen this bug if it's still present in kernel 2.6.19.

Note You need to log in before you can comment on or make changes to this bug.