Bug 65121 - Possible memory leak in qxl drm driver
Summary: Possible memory leak in qxl drm driver
Status: RESOLVED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel) (show other bugs)
Hardware: x86-64 Linux
: P1 normal
Assignee: drivers_video-dri
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-18 02:24 UTC by Matthew Stapleton
Modified: 2014-06-20 15:35 UTC (History)
3 users (show)

See Also:
Kernel Version: 3.11.6
Tree: Mainline
Regression: No


Attachments
3.11.9-config (114.19 KB, application/octet-stream)
2013-11-21 05:30 UTC, Matthew Stapleton
Details
fix (914 bytes, patch)
2013-11-28 05:41 UTC, Dave Airlie
Details | Diff

Description Matthew Stapleton 2013-11-18 02:24:58 UTC
The QXL DRM driver seems to have a memory leak on my current custom kernel build using Gentoo Hardened kernel: 3.11.6-hardened-r2 (also on 3.11.3-hardened).  This can be seen by running "watch 'cat /proc/slabinfo  | grep ^kmalloc'", and on my qemu virtual machine running on qemu-1.6.0, kmalloc-64 allocation will constantly increase until system runs out of ram and then OOM killer kills everything and causes the system to crash.  I should be able to test with a vanilla kernel in a few days if needed.
Comment 1 Alan 2013-11-18 14:42:15 UTC
Please do test a standard kernel, and if you can see if you can figure out if the leak is always occurring or seems to be triggered by some specific application or activity.
Comment 2 Matthew Stapleton 2013-11-21 05:27:36 UTC
I just tested with standard kernel: 3.11.9 and booted into a basic rescue initrd image with qxl enabled and "cat /proc/slabinfo  | grep ^kmalloc-64" still shows constantly increasing active_objs and num_objs.
Comment 3 Matthew Stapleton 2013-11-21 05:30:34 UTC
Created attachment 115361 [details]
3.11.9-config

This is the kernel config that was used
Comment 4 Alan 2013-11-26 22:06:02 UTC
Thanks for confirming
Comment 5 Dave Airlie 2013-11-28 05:29:33 UTC
what are you running just console?

or is X running?
Comment 6 Dave Airlie 2013-11-28 05:41:36 UTC
Created attachment 116501 [details]
fix

does this fix it?
Comment 7 Matthew Stapleton 2013-11-29 05:27:59 UTC
It looks like that fixes it.  Thanks.  Also, I'm only running on console, X isn't running.
Comment 8 xerofoify 2014-06-20 04:09:06 UTC
IF the attachment here seems to fix this I would close this.
Just a friendly reminder,
Nick
Comment 9 Dave Airlie 2014-06-20 04:34:45 UTC
kernel bugzilla sucks I can't change bug states.
Comment 10 xerofoify 2014-06-20 04:43:46 UTC
Our you sure, other people seem to 
be able to do it with other bugs.
Thanks Nick
Comment 11 xerofoify 2014-06-20 04:45:32 UTC
It seems to be only the opener or maintainer of this subsystem who can close it.
Cheers Nick
Comment 12 Alan 2014-06-20 15:35:28 UTC
Dave - ask the bugzilla contact address for your superman powers. I'm sure you'll have no trouble then

Note You need to log in before you can comment on or make changes to this bug.