Bug 6510 - hp4x serial usb driver stopped working with 2.6.16
hp4x serial usb driver stopped working with 2.6.16
Status: CLOSED PATCH_ALREADY_AVAILABLE
Product: Drivers
Classification: Unclassified
Component: USB
i386 Linux
: P2 normal
Assigned To: Greg Kroah-Hartman
:
: 6509 (view as bug list)
Depends on:
Blocks: USB
  Show dependency treegraph
 
Reported: 2006-05-07 18:51 UTC by Samuel Thibault
Modified: 2006-08-30 13:06 UTC (History)
0 users

See Also:
Kernel Version: 2.6.16
Tree: Mainline
Regression: ---


Attachments
dmesg of lsusb + minicom try (11.96 KB, text/plain)
2006-05-07 18:53 UTC, Samuel Thibault
Details
lsusb (9.70 KB, text/plain)
2006-05-07 18:53 UTC, Samuel Thibault
Details

Description Samuel Thibault 2006-05-07 18:51:43 UTC
Most recent kernel where this bug did not occur: 2.6.15
Distribution: debian
Hardware Environment: USB 1.1 hub
Software Environment: cat/minicom
Problem Description:
character transfer between pc and hp4x stopped working with kernel 2.6.16

Steps to reproduce:
plug hp4x device (it is properly recognized), start minicom, type characters in minicom or on hp4x, nothing appears on the other side.  With 2.6.15 it works ok.

I enabled debugging in the module, and I'll attach lsusb + dmesg
Note that the USBDEVFS_CONTROL errors in dmesg correspond to the "cannot read device status" error in lsusb
Comment 1 Samuel Thibault 2006-05-07 18:53:03 UTC
Created attachment 8034 [details]
dmesg of lsusb + minicom try
Comment 2 Samuel Thibault 2006-05-07 18:53:31 UTC
Created attachment 8035 [details]
lsusb
Comment 3 Samuel Thibault 2006-05-07 18:54:28 UTC
*** Bug 6509 has been marked as a duplicate of this bug. ***
Comment 4 Greg Kroah-Hartman 2006-05-08 09:39:42 UTC
I don't see anything wrong with that kernel log, what are you seeing
happening?  I see the data go to the device successfully, and that's about it.
Comment 5 Samuel Thibault 2006-05-08 09:48:50 UTC
Indeed, data seems to go, but the device doesn't get it at all. And in the first part of the log (where it looks like the device is idle), I was actually typing data from the device to the computer (which it apparently never received). 
Comment 6 Greg Kroah-Hartman 2006-08-30 00:58:27 UTC
Is this fixed in the latest 2.6.18-rc5 release?
Comment 7 Samuel Thibault 2006-08-30 13:06:27 UTC
2.6.18-rc5 works fine indeed, thanks! 

Note You need to log in before you can comment on or make changes to this bug.