Bug 6494 - sata hdd doesn't resume properly from suspend to ram (ata_piix)
sata hdd doesn't resume properly from suspend to ram (ata_piix)
Status: RESOLVED CODE_FIX
Product: SCSI Drivers
Classification: Unclassified
Component: Other
i386 Linux
: P2 normal
Assigned To: Jeff Garzik
:
: 7067 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-04 15:54 UTC by Arkadiusz Miskiewicz
Modified: 2007-04-28 12:49 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.17rc3-git10
Tree: Mainline
Regression: ---


Attachments
just for documentation: the patches I applied and mentioned above - tar.bz2 (5.38 KB, application/x-tar)
2006-08-30 23:36 UTC, Martin Lorenz
Details

Description Arkadiusz Miskiewicz 2006-05-04 15:54:44 UTC
Most recent kernel where this bug did not occur:
2.6.14.7 resumes fine (but with ata timeout; fortunately it recovers properly from that timeout)

Distribution:
PLD

Hardware Environment:
IBM ThinkPad Z60m

Software Environment:
Problem Description:

scsi subsystems dumps tons of errors, fs is remounted read-only, detailed description:

http://groups.google.com/group/linux.kernel/browse_frm/thread/96c701d3271c80a9/f116cc99ee81f09a?
lnk=st&q=Arkadiusz+resume+site%3Alkml.org&rnum=3&hl=pl#f116cc99ee81f09a

Note that one patch helps:
http://groups.google.com/group/linux.kernel/browse_frm/thread/621e9ea516259aa4/913ca54b1f1703a
0?lnk=st&q=Arkadiusz+resume+site%3Alkml.org&rnum=7&hl=pl#913ca54b1f1703a0
which later was replaced with smaller one:
http://groups.google.com/group/linux.kernel/tree/browse_frm/thread/621e9ea516259aa4/c9c00b29e
35628bd?rnum=11&hl=pl&q=Arkadiusz+resume+site%3Alkml.org&_done=%2Fgroup%2Flinux.kernel%2
Fbrowse_frm%2Fthread%2F621e9ea516259aa4%2F913ca54b1f1703a0%3Flnk%3Dst%26q%3
DArkadiusz+resume+site%3Alkml.org%26rnum%3D7%26hl%3Dpl%26#doc_38c829006391ae38

Please read entire thread for information what's happening.
Comment 1 Stephen Rothwell 2006-08-28 20:25:37 UTC
*** Bug 7067 has been marked as a duplicate of this bug. ***
Comment 2 Arkadiusz Miskiewicz 2006-08-28 22:58:02 UTC
It's fixed for me in recent kernels.
Comment 3 Martin Lorenz 2006-08-30 03:48:11 UTC
not for me on a X60s with 2.8.18-rc5 and no other patches
Comment 4 Arkadiusz Miskiewicz 2006-08-30 03:53:11 UTC
Z60m and X60s have different sata chipsets I guess. The one in z60m is ata_pix 
(no ahci available) and it works fine now.
Comment 5 Martin Lorenz 2006-08-30 04:11:22 UTC
I got a 

SATA controller: Intel Corporation 82801GBM/GHM (ICH7 Family) Serial ATA Storage
Controller AHCI (rev 02)
Comment 6 Martin Lorenz 2006-08-30 14:42:30 UTC
great

forrest zhaos set of ahci patches does the trick for my SATA controller
it resumes nicely now that I have applied them to the 2.6.18-rc5 kernel
Comment 7 Martin Lorenz 2006-08-30 23:36:59 UTC
Created attachment 8916 [details]
just for documentation: the patches I applied and mentioned above - tar.bz2
Comment 8 Martin Lorenz 2006-09-03 01:46:04 UTC
Is there a chance that those patches will go into 2.6.18?
Comment 9 Pavel Machek 2006-09-27 01:46:49 UTC
IIRC this patch series was deemed too intrusive for 2.6.18, but they should be
in 2.6.19-rc1 and 2.6.18-mm1.
Comment 10 Martin Lorenz 2006-09-27 01:59:22 UTC
already found them in the current tree :-)
in snapshot -git6 they are included
Comment 11 Pavel Machek 2006-09-29 04:20:55 UTC
Ok, so problem is fixed, right?

Note You need to log in before you can comment on or make changes to this bug.