Bug 6489 - High Speed USB devices don't work when ehci_hcd loaded (nforce4)
High Speed USB devices don't work when ehci_hcd loaded (nforce4)
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: USB
i386 Linux
: P2 normal
Assigned To: David Brownell
:
: 6214 (view as bug list)
Depends on:
Blocks: USB
  Show dependency treegraph
 
Reported: 2006-05-03 14:22 UTC by Jan Christoph uhde
Modified: 2006-11-29 19:10 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.17-rc3
Tree: Mainline
Regression: ---


Attachments
syslog, messages information (5.38 KB, text/plain)
2006-05-03 14:31 UTC, Jan Christoph uhde
Details
syslog - no udev [and no hal] (15.63 KB, text/plain)
2006-05-04 10:42 UTC, Jan Christoph uhde
Details
apply NForce workaround earlier (2.52 KB, patch)
2006-06-13 12:17 UTC, David Brownell
Details | Diff

Description Jan Christoph uhde 2006-05-03 14:22:41 UTC
Most recent kernel where this bug did not occur: 2.6.17-rc3
Distribution: debian/unstable
Hardware Environment: amd64 && a8n-premium
Probably copy of Bug: 5835|6201

Steps to reproduce:
Boot the system with a kernel wich has ehci_hcd enabled and plug the device in
any usb port.
Comment 1 Jan Christoph uhde 2006-05-03 14:31:35 UTC
Created attachment 8019 [details]
syslog, messages information

lsusb will not work as soon the device is attached.
Comment 2 Greg Kroah-Hartman 2006-05-03 14:36:21 UTC
So this worked in 2.6.17-rc3, yet it does not work now?

When did this last work?

And what are the kernel log messages you get when you plug the device in?
Comment 3 Greg Kroah-Hartman 2006-05-03 14:37:08 UTC
Ok, usb-storage issue, that's matt's area...
Comment 4 Matthew Dharm 2006-05-03 15:45:04 UTC
Interesting.... basic communication works for a little while, then the device
totally dies.

Can you turn off HALD and UDEVD and re-test?
Comment 5 Jan Christoph uhde 2006-05-04 10:42:42 UTC
Created attachment 8024 [details]
syslog - no udev [and no hal]

Most recent kernel where this bug did not occur: --
Please excuse for skimming over this:( UMS && ehci_hcd never worked on this
system in combination with linux:( The device works fine at other computers
(eg. my old pc && pre udev kernel [< 2.6.13 afaik]) and on this pc using the
'other' OS.

hardware-abstraction-layer-question:)
I am not sure about your request concerning HALD, i think that i do not have
the hal or hal-device-manager package installed. And i was not able to find any
hald executable anywhere. In case it should still be turned on please tell me
how to deactivate it.
Comment 6 Matthew Dharm 2006-05-04 11:06:43 UTC
If usb-storage and ehci_hcd never worked on this system, then it's likely an
EHCI problem.  The fact that the unit works on other systems with relatively
recent kernels is a futher indication that something is wrong with the
lower-level driver.

Greg, please re-assign.
Comment 7 Jim Siler 2006-05-22 12:23:17 UTC
I found this when I increased my system memory from 2GB to 4GB.  It had worked
previously.  If I
   #rmmod ehci_hcd
   #modprobe -i ehci_hcd
All is well again.

Kernels include 2.6.16-1.2096_FC5 and  2.6.16.13-4-smp (Suse 10.1).

Motherboards include Asus A8N32SLI Deluxe
and Gigaabyte GA-K8NPRO-SLI.

Comment 8 David Brownell 2006-06-13 12:17:08 UTC
Created attachment 8296 [details]
apply NForce workaround earlier

This patch may well resolve the problem with nforce and
more than 2 GB memory ...
Comment 9 Gonzalo Aguilar 2006-06-21 10:38:34 UTC
I can confirm this bug... 

Has been around from earlier 2.6.1X kernels, and still is not solved.
Comment 10 Greg Kroah-Hartman 2006-08-30 00:56:32 UTC
Please test David's last patch everyone...
Comment 11 Greg Kroah-Hartman 2006-08-30 01:19:20 UTC
*** Bug 6214 has been marked as a duplicate of this bug. ***
Comment 12 Adrian Bunk 2006-11-29 19:10:15 UTC
The patch from this bug was included in kernel 2.6.18.

Note You need to log in before you can comment on or make changes to this bug.