Bug 6474 - acpi-cpufreq not working anymore
acpi-cpufreq not working anymore
Status: CLOSED CODE_FIX
Product: ACPI
Classification: Unclassified
Component: Power-Processor
i386 Linux
: P2 normal
Assigned To: Len Brown
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-01 14:37 UTC by Brice Goglin
Modified: 2007-03-08 00:08 UTC (History)
5 users (show)

See Also:
Kernel Version: since 2.6.16-rc1 and 2.6.15-mm2
Tree: Mainline
Regression: ---


Attachments
acpi-cpufreq, speedstep-centrino merged driver (36.05 KB, patch)
2006-06-05 10:43 UTC, Denis Sadykov
Details | Diff

Description Brice Goglin 2006-05-01 14:37:09 UTC
Most recent kernel where this bug did not occur: 2.6.15-mm1 and 2.6.15
Distribution: Debian testing
Hardware Environment: IBM Thinkpad T43

I reported on January 7th that acpi-cpufreq did not work anymore on my IBM
Thinkpad T43 (fails to load with ENODEV). The problem appeared first in
2.6.15-mm2 and has been reported in the following thread on LKML:
http://lkml.org/lkml/2006/1/7/181

The issue has been discussed a little bit with Len Brown and Venkatesh Pallipadi
on linux-acpi, for instance in
  http://marc.theaimsgroup.com/?l=linux-acpi&m=113770495819445&w=2
and in private mails.

Andrew Morton tracked the ENODEV down in this post
  http://marc.theaimsgroup.com/?l=linux-kernel&m=113672322608497&w=2

The last news I heard was that I should use speedstep-centrino since it is not
broken and is actually faster. I now use speedstep-centrino and it works fine.
But Andrew Morton does not like this solution. The acpi-cpufreq driver should
either fixed or removed. That's why I am opening a bug here.
Comment 1 Len Brown 2006-05-18 01:13:08 UTC
Andrew is correct, and there is a fix for this bug in the works.
Comment 2 Jeremy Olexa 2006-05-21 14:04:03 UTC
I have also been expierencing the same issues. I cannot load the acpi-cpufreq
module anymore. I have tested this with the newest development kernel
(2.6.17_rc4) I can provide dmesg output and config if requested. Last known
kernel to have acpi work was 2.6.15-gentoo-r1 for me. Thanks.
Comment 3 Daniel Drake 2006-05-21 14:21:41 UTC
Gentoo have several reports of this regression. If there is anything we can do
to help (more info, acpi dumps, testing patches), ask away.
Comment 4 Denis Sadykov 2006-06-05 10:43:10 UTC
Created attachment 8257 [details]
acpi-cpufreq, speedstep-centrino merged driver

All ACPI related things have been removed from the speedstep-centrino driver
and added to the acpi-cpiufreq one. acpi-cpufreq now combines MSR and SystemIO
capabilities.
Comment 5 Daniel Drake 2006-06-20 08:15:36 UTC
Should this bug be closed? I don't see the patch in the cpufreq git tree or any
branch of the acpi git tree.
Comment 6 Daniel Drake 2006-06-20 08:18:38 UTC
Denis, which kernel does the patch apply to? Most hunks fail on 2.6.16 and
2.6.17 for me.
Comment 7 Daniel Drake 2006-07-01 04:24:56 UTC
Can someone test a recent -git snapshot to confirm this bug still exists?
Comment 8 Brice Goglin 2006-07-07 16:49:07 UTC
Since 2.6.18-rc1, acpi-cpufreq is able to load again. But it does not work. It
seems to acquire the device but no cpufreq capability seems to be exported.
speedstep-centrino still works fine.
Comment 9 Daniel Drake 2006-07-12 13:05:17 UTC
Brice: I suggest you open a new bug about that.
Comment 10 Len Brown 2007-03-08 00:08:01 UTC
As of 2.6.20, speedstep-centrino is depricated and acpi-cpufreq is preferred.
If either of them don't work in 2.6.20, please re-open.

Going forward, the ACPI part of speedstep-centrino will be removed
and it will rot on the vine as a legacy-only driver with hard-coded
tables for non-ACPI mode.

Note You need to log in before you can comment on or make changes to this bug.