Bug 64431 - [ivy bridge] intel_crtc_wait_for_pending_flips crash
Summary: [ivy bridge] intel_crtc_wait_for_pending_flips crash
Status: RESOLVED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel) (show other bugs)
Hardware: All Linux
: P2 normal
Assignee: intel-gfx-bugs@lists.freedesktop.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-05 00:38 UTC by Micael Dias
Modified: 2015-10-07 10:54 UTC (History)
17 users (show)

See Also:
Kernel Version: 3.12-rc1
Tree: Mainline
Regression: No


Attachments
dmesg crash 3.12 (102.76 KB, text/plain)
2013-11-24 03:17 UTC, Micael Dias
Details
dmesg from linux 3.16-rc6 (109.27 KB, text/plain)
2014-07-22 20:34 UTC, Christoph Haag
Details
crash on 3.16 (68.83 KB, text/plain)
2014-08-26 18:35 UTC, Micael Dias
Details
trimmed dmesg output (9.25 KB, text/plain)
2014-10-11 20:32 UTC, Tobias Jakobi
Details
Log showing lockup in intel_crtc_wait_for_pending_flips on 3.17.2 (4.53 KB, text/plain)
2014-11-02 00:31 UTC, rocko
Details
i915 bug dmesg output from 3.18rc5 on Ubuntu 14.10 (8.05 KB, text/plain)
2014-11-28 08:00 UTC, Rob
Details
trace from 3.18-rc6 (3.62 KB, text/plain)
2014-11-30 08:25 UTC, rocko
Details

Description Micael Dias 2013-11-05 00:38:10 UTC
Today I left my computer for a couple of hours and I left my 2 screens on. When I came back the monitors were in standby and I couldn't wake it up.
I logged in with another computer via SSH to find out what was wrong, and dmesg had the following listed several times:

[368401.823959] INFO: task X:21291 blocked for more than 120 seconds.
[368401.823963]       Not tainted 3.12.0-1-dirty #1
[368401.823963] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
[368401.823965] X               D ffff880210670c40     0 21291    309 0x00400000
[368401.823967]  ffff880105f13c48 0000000000000082 00000000000144c0 ffff880105f13fd8
[368401.823969]  ffff880105f13fd8 00000000000144c0 ffff880129eb0000 0000000000000000
[368401.823970]  0000000000000000 0000000000000000 0000000000000000 0000000000000000
[368401.823972] Call Trace:
[368401.823977]  [<ffffffff814e52e9>] schedule+0x29/0x70
[368401.823988]  [<ffffffffa07af3dd>] intel_crtc_wait_for_pending_flips+0x8d/0x120 [i915]
[368401.823990]  [<ffffffff81084990>] ? wake_up_atomic_t+0x30/0x30
[368401.823995]  [<ffffffffa07b622f>] ironlake_crtc_disable+0x7f/0x930 [i915]
[368401.824000]  [<ffffffffa07bd9d7>] ? intel_modeset_check_state+0x477/0x780 [i915]
[368401.824005]  [<ffffffffa07ba43f>] intel_crtc_update_dpms+0x6f/0xa0 [i915]
[368401.824009]  [<ffffffffa07bdd22>] intel_connector_dpms+0x42/0x80 [i915]
[368401.824015]  [<ffffffffa0703ec8>] drm_mode_obj_set_property_ioctl+0x308/0x320 [drm]
[368401.824018]  [<ffffffffa0703f10>] drm_mode_connector_property_set_ioctl+0x30/0x40 [drm]
[368401.824021]  [<ffffffffa06f2ef2>] drm_ioctl+0x522/0x650 [drm]
[368401.824025]  [<ffffffff811a0f42>] ? do_readv_writev+0x1a2/0x240
[368401.824028]  [<ffffffff81291254>] ? timerqueue_del+0x24/0x70
[368401.824029]  [<ffffffff81086bd6>] ? __remove_hrtimer+0x46/0xa0
[368401.824031]  [<ffffffff811b27d5>] do_vfs_ioctl+0x2e5/0x4d0
[368401.824033]  [<ffffffff8107083b>] ? recalc_sigpending+0x1b/0x50
[368401.824034]  [<ffffffff81071492>] ? __set_task_blocked+0x32/0x70
[368401.824036]  [<ffffffff811b2a41>] SyS_ioctl+0x81/0xa0
[368401.824038]  [<ffffffff814ee8dd>] system_call_fastpath+0x1a/0x1f

I had to soft reboot to have the screen turn on again. And this is not easily reproducible...
I know the kernel isn't the most up to date one, but I'm posting the bug anyway in case someone stumbles upon the same problem with other more recent kernels.
Comment 1 Daniel Vetter 2013-11-05 06:42:56 UTC
Yeah, 3.12-rc1 is rather likely to be just a bit too old:

commit 17e1df07df0fbc77696a1e1b6ccf9f2e5af70e40
Author: Daniel Vetter <daniel.vetter@ffwll.ch>
Date:   Sun Sep 8 21:57:13 2013 +0200

    drm/i915: fix wait_for_pending_flips vs gpu hang deadlock

Thanks for the bug report and please reopen if it happens again on more recent kernels.
Comment 2 Micael Dias 2013-11-24 03:17:03 UTC
This just happened again. This time with mainline 3.12.
I'm attaching the dmesg.
Comment 3 Micael Dias 2013-11-24 03:17:32 UTC
Created attachment 115781 [details]
dmesg crash 3.12
Comment 4 Daniel Vetter 2013-11-25 09:35:09 UTC
Ok, that smells like the other neat DP hang then. Thanks for reopening, I'll try to have a look.
Comment 5 Christoph Haag 2014-07-22 20:34:41 UTC
Created attachment 143951 [details]
dmesg from linux 3.16-rc6

So, this was never closed as fixed...

I sometimes experience hangs too up to linux 3.16. I looked at the stacktrace and to my untrained eyes it looks mostly similar.

ivy bridge with upstream 3.16-rc6, xorg 1.16 and xf86-video-intel git master with sna, rendernode and tearfree.

Symptoms: Xorg display randomly freezes. Changing num status led on the keyboard still works. Switching to a tty with ctrl+alt+f2 switches my (primary) laptop screen to a black screen. The external DVI(=HDMI) monitor stays at displaying the stuck Xorg content. After a while this message appears in dmesg and the system recovers and is usable without issues again. I am pretty sure this only happens when an external monitor is attached.

Sorry if this is something else, but it looked similar enough.
Comment 6 Micael Dias 2014-08-26 18:35:05 UTC
Created attachment 148401 [details]
crash on 3.16

Just got another crash on 3.16 too.

This time I was just watching a movie with smplayer.
Comment 7 Dmitry Osipenko 2014-08-28 16:14:09 UTC
Same issue on my ivy, a complete xorg lockup at least once in 2-3 weeks and rebooting/suspending after lockup hangs pc completely. I also use two monitors setup (dvi+hdmi).
Comment 8 Jani Nikula 2014-09-24 12:01:32 UTC
Please try drm-intel-nightly branch of http://cgit.freedesktop.org/drm-intel.
Comment 9 Christoph Haag 2014-10-02 20:17:57 UTC
The problem is that this happens so sporadically. I have been using drm-next 3.18 and 3.17 rcs for a while and it hasn't happened to me in a few weeks.

But maybe tomorrow it will...
Comment 10 Micael Dias 2014-10-10 17:47:45 UTC
I will try to compile it today and use it from today on. As soon as/if I find a crash I will report.
However, like Christoph says; not crashing in a few days may not mean the bug is fixed.
Comment 11 Tobias Jakobi 2014-10-11 20:32:12 UTC
Created attachment 153271 [details]
trimmed dmesg output

I'm seeing a similar problem here on an i7-4700HQ Haswell.

WARNING: CPU: 5 PID: 2290 at drivers/gpu/drm/i915/intel_display.c:3324 intel_crtc_wait_for_pending_flips+0x160/0x170()

The internal display of this laptop system is attached via eDP. The mentioned switching between VT and X didn't restore the display. I had to reboot to get it into useable state again.

Kernel is 3.16.5. The issue doesn't appear very often, this is maybe the second time I've experienced it.
Comment 12 a_user 2014-10-12 09:54:39 UTC
Hi,
i have similar/same issue on my i3-4330 Haswell. This is the second time i got the crash in about a month. Both happend on ubuntu unicorn using a 3.16.0 kernel. This time it was 3.16.0-22. XBMC  froze while ideling over the night/morning.

Oct 12 11:38:50 htpc vdr: [2952] frontend 0/0 timed out while tuning to channel 0, tp 211817
Oct 12 11:38:58 htpc kernel: [86035.822825] ------------[ cut here ]------------
Oct 12 11:38:58 htpc kernel: [86035.822859] WARNING: CPU: 0 PID: 1506 at /build/buildd/linux-3.16.0/drivers/gpu/drm/i915/intel_display.c:3324 intel_crtc_wait_f
or_pending_flips+0x16c/0x180 [i915]()
Oct 12 11:38:58 htpc kernel: [86035.822861] Modules linked in: ufs qnx4 hfsplus hfs minix ntfs msdos jfs xfs libcrc32c isl6421 cx24116 cx88_dvb cx88_vp3054_i2c
 ir_lirc_codec videobuf_dvb lirc_dev ir_mce_kbd_decoder ir_sanyo_decoder ir_sharp_decoder ir_sony_decoder dvb_core ir_jvc_decoder ir_nec_decoder ir_rc5_decoder
 ir_rc6_decoder rc_hauppauge joydev snd_hda_codec_hdmi hid_generic eeepc_wmi asus_wmi sparse_keymap intel_rapl x86_pkg_temp_thermal tuner intel_powerclamp kvm_
intel kvm bnep rfcomm crct10dif_pclmul crc32_pclmul ghash_clmulni_intel bluetooth aesni_intel 6lowpan_iphc aes_x86_64 lrw gf128mul glue_helper ablk_helper snd_
hda_intel cryptd snd_hda_controller snd_hda_codec snd_hwdep rc_imon_pad snd_seq_midi snd_seq_midi_event cx88_alsa cx8802 cx8800 cx88xx uas imon btcx_risc usbhi
d tveeprom videobuf_dma_sg serio_raw snd_rawmidi videobuf_core usb_storage v4l2_common rc_core hid videodev snd_pcm media snd_seq snd_seq_device snd_timer binf
mt_misc i915 wmi snd drm_kms_helper drm video lpc_ich soundcore mei_me tpm_infineon mei i2c_algo_bit shpchp mac_hid parport_pc ppdev lp parport nls_iso8859_1 c
oretemp btrfs xor raid6_pq psmouse ahci libahci r8169 mii
Oct 12 11:38:58 htpc kernel: [86035.822905] CPU: 0 PID: 1506 Comm: Xorg Not tainted 3.16.0-22-generic #29-Ubuntu
Oct 12 11:38:58 htpc kernel: [86035.822906] Hardware name: ASUS All Series/H87M-PLUS, BIOS 2102 08/08/2014
Oct 12 11:38:58 htpc kernel: [86035.822907]  0000000000000009 ffff88020991fc18 ffffffff8277fcbc 0000000000000000
Oct 12 11:38:58 htpc kernel: [86035.822909]  ffff88020991fc50 ffffffff8206fd8d 0000000000000000 ffff8802130fd000
Oct 12 11:38:58 htpc kernel: [86035.822911]  ffff880213438210 ffff880212e3d000 ffff880212e3d000 ffff88020991fc60
Oct 12 11:38:58 htpc kernel: [86035.822913] Call Trace:
Oct 12 11:38:58 htpc kernel: [86035.822919]  [<ffffffff8277fcbc>] dump_stack+0x45/0x56
Oct 12 11:38:58 htpc kernel: [86035.822924]  [<ffffffff8206fd8d>] warn_slowpath_common+0x7d/0xa0
Oct 12 11:38:58 htpc kernel: [86035.822926]  [<ffffffff8206fe6a>] warn_slowpath_null+0x1a/0x20
Oct 12 11:38:58 htpc kernel: [86035.822939]  [<ffffffffc0570ffc>] intel_crtc_wait_for_pending_flips+0x16c/0x180 [i915]
Oct 12 11:38:58 htpc kernel: [86035.822943]  [<ffffffff820b9590>] ? prepare_to_wait_event+0x100/0x100
Oct 12 11:38:58 htpc kernel: [86035.822955]  [<ffffffffc0573ac3>] intel_crtc_disable_planes+0x33/0x1c0 [i915]
Oct 12 11:38:58 htpc kernel: [86035.822958]  [<ffffffff82784e5b>] ? __ww_mutex_lock+0x1b/0xb0
Oct 12 11:38:58 htpc kernel: [86035.822969]  [<ffffffffc0574a17>] haswell_crtc_disable+0x57/0x2e0 [i915]
Oct 12 11:38:58 htpc kernel: [86035.822970]  [<ffffffff82785ab2>] ? mutex_lock+0x12/0x30
Oct 12 11:38:58 htpc kernel: [86035.822981]  [<ffffffffc0575457>] intel_crtc_update_dpms+0x67/0xa0 [i915]
Oct 12 11:38:58 htpc kernel: [86035.822993]  [<ffffffffc0579ac9>] intel_connector_dpms+0x59/0x70 [i915]
Oct 12 11:38:58 htpc kernel: [86035.823005]  [<ffffffffc04ade19>] drm_mode_obj_set_property_ioctl+0x399/0x3a0 [drm]
Oct 12 11:38:58 htpc kernel: [86035.823015]  [<ffffffffc04ade50>] drm_mode_connector_property_set_ioctl+0x30/0x40 [drm]
Oct 12 11:38:58 htpc kernel: [86035.823024]  [<ffffffffc049ca4f>] drm_ioctl+0x1df/0x680 [drm]
Oct 12 11:38:58 htpc kernel: [86035.823029]  [<ffffffff8221f9bc>] ? fsnotify+0x27c/0x350
Oct 12 11:38:58 htpc kernel: [86035.823032]  [<ffffffff8221f9bc>] ? fsnotify+0x27c/0x350
Oct 12 11:38:58 htpc kernel: [86035.823036]  [<ffffffff821f4bc8>] do_vfs_ioctl+0x2c8/0x4a0
Oct 12 11:38:58 htpc kernel: [86035.823039]  [<ffffffff821e31a1>] ? __sb_end_write+0x31/0x60
Oct 12 11:38:58 htpc kernel: [86035.823042]  [<ffffffff821e0d12>] ? vfs_write+0x1b2/0x1f0
Oct 12 11:38:58 htpc kernel: [86035.823044]  [<ffffffff821f4e21>] SyS_ioctl+0x81/0xa0
Oct 12 11:38:58 htpc kernel: [86035.823046]  [<ffffffff82787ced>] system_call_fastpath+0x1a/0x1f
Oct 12 11:38:58 htpc kernel: [86035.823047] ---[ end trace eb855d38e8823900 ]---
Comment 13 Micael Dias 2014-10-25 17:16:36 UTC
I have not yet had this crash since I began running drm-intel revision ea4bec8e96ea8b33b49a7892c1c7f20041a56da6 (15 days ago).
Comment 14 rocko 2014-11-02 00:31:57 UTC
Created attachment 156091 [details]
Log showing lockup in intel_crtc_wait_for_pending_flips on 3.17.2

I'm also getting lockups in 3.17.2 (Sandy Bridge hardware), and the log output is very similar to the log posted for 3.16 in the previous comment. Is the issue I'm getting related to this bug or is it a separate one?
Comment 15 Jonathan D 2014-11-12 17:59:29 UTC
Are you guys aware of this bug on the launchpad tracker? https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1384342

There's a lot of info on there about how this is still happening in 3.17 and detailed logs from users who are experiencing this crash!

Also in turns of reproducing this bug, I've found doing VT switches between two active desktop sessions usually makes this happen fairly quickly so try doing that a dozen times and it will (probably) happen! :)
Comment 16 Rob 2014-11-28 07:54:10 UTC
Hi,

I'm running 3.18 rc5 on Ubuntu 14.10 and also experieced this problem.

[461516.248789] WARNING: CPU: 0 PID: 1644 at /home/apw/COD/linux/drivers/gpu/drm/i915/intel_display.c:3479 intel_crtc_wait_for_pending_flips+0x1a8/0x1c0 [i915]()
[461516.248794] Removing stuck page flip
[461516.248812] Modules linked in: mmc_block nfnetlink_queue nfnetlink_log nfnetlink snd_usb_audio snd_usbmidi_lib msr xt_addrtype dm_thin_pool dm_persistent_data dm_bio_prison dm_bufio libcrc32c ctr ccm xt_conntrack ipt_REJECT nf_reject_ipv4 uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_core v4l2_common videodev media btusb xt_CHECKSUM iptable_mangle ipt_MASQUERADE nf_nat_masquerade_ipv4 iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack xt_tcpudp nvram bridge stp llc iptable_filter ip_tables x_tables dell_wmi sparse_keymap arc4 dell_laptop dcdbas iwldvm mac80211 intel_rapl x86_pkg_temp_thermal intel_powerclamp kvm_intel kvm joydev serio_raw iwlwifi cfg80211 lpc_ich mei_me mei 8250_fintek dell_smo8800 dw_dmac dw_dmac_core snd_hda_codec_hdmi snd_soc_rt5640 8250_dw snd_soc_rl6231
[461516.248990]  snd_soc_core snd_soc_sst_acpi snd_hda_codec_realtek i2c_hid snd_hda_codec_generic hid snd_compress snd_pcm_dmaengine snd_hda_intel intel_smartconnect snd_hda_controller snd_hda_codec snd_hwdep i2c_designware_platform spi_pxa2xx_platform i2c_designware_core mac_hid snd_pcm snd_seq_midi snd_seq_midi_event snd_rawmidi snd_seq snd_seq_device snd_timer snd bnep soundcore rfcomm ie31200_edac shpchp edac_core bluetooth parport_pc ppdev coretemp lp parport binfmt_misc nls_iso8859_1 dm_crypt crct10dif_pclmul crc32_pclmul ghash_clmulni_intel aesni_intel aes_x86_64 lrw gf128mul glue_helper ablk_helper cryptd i915 psmouse ahci libahci i2c_algo_bit sdhci_pci drm_kms_helper e1000e drm ptp pps_core wmi sdhci_acpi video sdhci
[461516.249156] CPU: 0 PID: 1644 Comm: Xorg Tainted: G        W      3.18.0-031800rc5-generic #201411162035
[461516.249162] Hardware name: Dell Inc. Latitude E6440/0YX2X3, BIOS A05 02/18/2014
[461516.249167]  0000000000000d97 ffff8800d4fcfae8 ffffffff8279f8d5 0000000000000007
[461516.249192]  ffff8800d4fcfb38 ffff8800d4fcfb28 ffffffff8206eafc ffff8800d4fcfb18
[461516.249201]  ffff8800d2e3e1a8 ffff88020ed61000 0000000000000296 ffff8800d2e3e000
[461516.249211] Call Trace:
[461516.249239]  [<ffffffff8279f8d5>] dump_stack+0x46/0x58
[461516.249251]  [<ffffffff8206eafc>] warn_slowpath_common+0x8c/0xc0
[461516.249262]  [<ffffffff8206ebe6>] warn_slowpath_fmt+0x46/0x50
[461516.249380]  [<ffffffffc03bd708>] intel_crtc_wait_for_pending_flips+0x1a8/0x1c0 [i915]
[461516.249405]  [<ffffffff820aec10>] ? prepare_to_wait_event+0x100/0x100
[461516.249500]  [<ffffffffc03c14b4>] intel_crtc_disable_planes+0x34/0x150 [i915]
[461516.249592]  [<ffffffffc03c1b2d>] haswell_crtc_disable+0x5d/0x220 [i915]
[461516.249686]  [<ffffffffc03be817>] intel_crtc_control+0x57/0x130 [i915]
[461516.249789]  [<ffffffffc03be957>] intel_crtc_update_dpms+0x67/0x80 [i915]
[461516.249880]  [<ffffffffc03c4611>] intel_connector_dpms+0x61/0x70 [i915]
[461516.249943]  [<ffffffffc025ccb4>] drm_mode_connector_set_obj_prop+0xa4/0xb0 [drm]
[461516.250020]  [<ffffffffc02639e4>] drm_mode_obj_set_property_ioctl+0x134/0x1d0 [drm]
[461516.250092]  [<ffffffffc0263ab0>] drm_mode_connector_property_set_ioctl+0x30/0x40 [drm]
[461516.250144]  [<ffffffffc0253e46>] drm_ioctl+0x2e6/0x590 [drm]
[461516.250154]  [<ffffffff822604e3>] ? sysfs_notify+0x53/0xb0
[461516.250230]  [<ffffffffc0263a80>] ? drm_mode_obj_set_property_ioctl+0x1d0/0x1d0 [drm]
[461516.250256]  [<ffffffff82412960>] ? brightness_store+0xe0/0x100
[461516.250267]  [<ffffffff8225f0db>] ? kernfs_fop_write+0x5b/0x170
[461516.250276]  [<ffffffff822274d4>] ? fsnotify+0x204/0x260
[461516.250301]  [<ffffffff821fc2c5>] do_vfs_ioctl+0x75/0x2c0
[461516.250310]  [<ffffffff821ea106>] ? vfs_write+0x196/0x1f0
[461516.250321]  [<ffffffff822068f5>] ? __fget_light+0x25/0x70
[461516.250345]  [<ffffffff821fc5a1>] SyS_ioctl+0x91/0xb0
[461516.250355]  [<ffffffff821fe6bb>] ? SyS_poll+0x6b/0x100
[461516.250365]  [<ffffffff827ad12d>] system_call_fastpath+0x16/0x1b
[461516.250385] ---[ end trace 7002fe106f21a4f6 ]---

My kernel is tainted though probably because of i915.lvds_downclock=1 and/or drm.vblankoffdelay=1 on my cmdline. I'm not sure if that's enabled by default on Haswell?

#cat /proc/sys/kernel/tainted
512
Comment 17 Rob 2014-11-28 07:57:47 UTC
Oh okay it's tainted because I pasted the 2nd time it happened (same bug tainted it). I will attach the dmesg output so you can see both.
Comment 18 Rob 2014-11-28 08:00:02 UTC
Created attachment 159011 [details]
i915 bug dmesg output from 3.18rc5 on Ubuntu 14.10
Comment 19 rocko 2014-11-30 08:25:19 UTC
Created attachment 159201 [details]
trace from 3.18-rc6

It just happened in 3.18-rc6. I'm using the boot default settings for Ubuntu 14.10 on a Sandy Bridge chipset. Let me know if there's more info I can provide.
Comment 20 Jani Nikula 2014-12-04 07:59:14 UTC
Reassigning back to intel-gfx-bugs.

Daniel, do you have any ideas on this one? We have a user at the office saying he can reproduce this.
Comment 21 Rob 2014-12-10 20:59:03 UTC
So my desktop froze and all I could do was moving the cursor, so I switched to a VT and for about a minute or so the screen was blank. I tried to switch back to X but it didn't work (blank screen). So I was forced to reboot.
Comment 22 Dmitry Osipenko 2014-12-10 21:08:02 UTC
About 1.5 month ago I disabled irq balance daemon and since that time no one issue... dunno if it's just coincidence.
Comment 23 Arno Wald 2015-01-10 11:34:45 UTC
I had the same error message in syslog after my Xorg has frozen. 

What happened:
* Xorg did freeze, only the mouse cuzsor could still be moved.
* I tried to switch to console (ctrl+alt+f1) but it did not work. Only the mouse cursor did disappear, so I thought I had to reboot. (But I did not)
* After some time (1 minute or so) the switch to the console suprisingly did happen.
* Switching back to X (ctrl+alt+f7) I have found X unfrozen and everything working fine again.

In the syslog I have found:

Jan 10 11:43:28 flupp kernel: [ 2535.270826] ------------[ cut here ]------------
Jan 10 11:43:28 flupp kernel: [ 2535.270867] WARNING: CPU: 2 PID: 1989 at /build/buildd/linux-3.16.0/drivers/gpu/drm/i915/intel_display.c:3324 intel_crtc_wait_for_pending_flips+0x16c/0x180 [i915]()
Jan 10 11:43:28 flupp kernel: [ 2535.270869] Modules linked in: autofs4 rfcomm bnep bluetooth 6lowpan_iphc nfsd auth_rpcgss nfs_acl nfs lockd binfmt_misc sunrpc fscache snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_codec_generic gpio_ich snd_hda_intel snd_hda_controller intel_rapl x86_pkg_temp_thermal intel_powerclamp snd_hda_codec kvm_intel snd_hwdep kvm snd_pcm crct10dif_pclmul crc32_pclmul ghash_clmulni_intel aesni_intel aes_x86_64 serio_raw snd_seq_midi lrw gf128mul glue_helper ablk_helper snd_seq_midi_event cryptd snd_rawmidi snd_seq lpc_ich snd_seq_device snd_timer snd soundcore parport_pc shpchp ppdev tpm_infineon it87 hwmon_vid mac_hid mei_me mei coretemp lp parport hid_generic usbhid hid i915 mxm_wmi video i2c_algo_bit firewire_ohci drm_kms_helper ahci r8169 firewire_core drm libahci mii crc_itu_t wmi
Jan 10 11:43:28 flupp kernel: [ 2535.270922] CPU: 2 PID: 1989 Comm: Xorg Not tainted 3.16.0-28-generic #38-Ubuntu
Jan 10 11:43:28 flupp kernel: [ 2535.270924] Hardware name: Gigabyte Technology Co., Ltd. Z68X-UD3H-B3/Z68X-UD3H-B3, BIOS F2 05/02/2011
Jan 10 11:43:28 flupp kernel: [ 2535.270926]  0000000000000009 ffff8802109cbbf8 ffffffff81781eaa 0000000000000000
Jan 10 11:43:28 flupp kernel: [ 2535.270930]  ffff8802109cbc30 ffffffff8106fedd 0000000000000000 ffff880213c3a000
Jan 10 11:43:28 flupp kernel: [ 2535.270933]  ffff8802105c8210 ffff880210890800 ffff880210890800 ffff8802109cbc40
Jan 10 11:43:28 flupp kernel: [ 2535.270937] Call Trace:
Jan 10 11:43:28 flupp kernel: [ 2535.270945]  [<ffffffff81781eaa>] dump_stack+0x45/0x56
Jan 10 11:43:28 flupp kernel: [ 2535.270951]  [<ffffffff8106fedd>] warn_slowpath_common+0x7d/0xa0
Jan 10 11:43:28 flupp kernel: [ 2535.270955]  [<ffffffff8106ffba>] warn_slowpath_null+0x1a/0x20
Jan 10 11:43:28 flupp kernel: [ 2535.270976]  [<ffffffffc01e504c>] intel_crtc_wait_for_pending_flips+0x16c/0x180 [i915]
Jan 10 11:43:28 flupp kernel: [ 2535.270981]  [<ffffffff810b9710>] ? prepare_to_wait_event+0x100/0x100
Jan 10 11:43:28 flupp kernel: [ 2535.271001]  [<ffffffffc01e7b13>] intel_crtc_disable_planes+0x33/0x1c0 [i915]
Jan 10 11:43:28 flupp kernel: [ 2535.271020]  [<ffffffffc01e80e0>] ironlake_crtc_disable+0x50/0x980 [i915]
Jan 10 11:43:28 flupp kernel: [ 2535.271040]  [<ffffffffc00f3f53>] ? drm_modeset_lock+0x33/0xf0 [drm]
Jan 10 11:43:28 flupp kernel: [ 2535.271044]  [<ffffffff81787c92>] ? mutex_lock+0x12/0x30
Jan 10 11:43:28 flupp kernel: [ 2535.271064]  [<ffffffffc01e94a7>] intel_crtc_update_dpms+0x67/0xa0 [i915]
Jan 10 11:43:28 flupp kernel: [ 2535.271085]  [<ffffffffc01edb19>] intel_connector_dpms+0x59/0x70 [i915]
Jan 10 11:43:28 flupp kernel: [ 2535.271101]  [<ffffffffc00eae19>] drm_mode_obj_set_property_ioctl+0x399/0x3a0 [drm]
Jan 10 11:43:28 flupp kernel: [ 2535.271115]  [<ffffffffc00eae50>] drm_mode_connector_property_set_ioctl+0x30/0x40 [drm]
Jan 10 11:43:28 flupp kernel: [ 2535.271126]  [<ffffffffc00d9a4f>] drm_ioctl+0x1df/0x680 [drm]
Jan 10 11:43:28 flupp kernel: [ 2535.271133]  [<ffffffff8121ffac>] ? fsnotify+0x27c/0x350
Jan 10 11:43:28 flupp kernel: [ 2535.271136]  [<ffffffff8121ffac>] ? fsnotify+0x27c/0x350
Jan 10 11:43:28 flupp kernel: [ 2535.271140]  [<ffffffff811f5138>] do_vfs_ioctl+0x2c8/0x4a0
Jan 10 11:43:28 flupp kernel: [ 2535.271144]  [<ffffffff811e3641>] ? __sb_end_write+0x31/0x60
Jan 10 11:43:28 flupp kernel: [ 2535.271148]  [<ffffffff811e11b2>] ? vfs_write+0x1b2/0x1f0
Jan 10 11:43:28 flupp kernel: [ 2535.271152]  [<ffffffff811f5391>] SyS_ioctl+0x81/0xa0
Jan 10 11:43:28 flupp kernel: [ 2535.271156]  [<ffffffff81789eed>] system_call_fastpath+0x1a/0x1f
Jan 10 11:43:28 flupp kernel: [ 2535.271158] ---[ end trace 68daaa91e81e9d0c ]---


In the Xorg.0.log I only found:
...
[    63.338] (II) intel(0): Modeline "1280x720"x60.0   74.48  1280 1336 1472 1664  720 721 724 746 -hsync +vsync (44.8 kHz e)
[  2474.092] (II) AIGLX: Suspending AIGLX clients for VT switch
[  2542.894] (II) AIGLX: Resuming AIGLX clients after VT switch
[  2542.894] (II) intel(0): switch to mode 1920x1200@60.0 on HDMI1 using pipe 0, position (0, 0), rotation normal, reflection none


my system (kubuntu 14.10):
sandybridge Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz
Linux flupp 3.16.0-28-generic #38-Ubuntu SMP Fri Dec 12 17:37:40 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
ii  xorg                             1:7.7+7ubuntu2            
ii  xorg-docs-core                   1:1.7-1                   
ii  xorg-sgml-doctools               1:1.11-1                  
ii  xserver-xorg                     1:7.7+7ubuntu2            
ii  xserver-xorg-core                2:1.16.0-1ubuntu1.2       
ii  xserver-xorg-input-all           1:7.7+7ubuntu2            
ii  xserver-xorg-input-evdev         1:2.9.0-1ubuntu2          
ii  xserver-xorg-input-mouse         1:1.9.0-1build2           
ii  xserver-xorg-video-all           1:7.7+7ubuntu2            
ii  xserver-xorg-video-fbdev         1:0.4.4-1build2           
ii  xserver-xorg-video-intel         2:2.99.914-1~exp1ubuntu4.1
libdrm-intel1:amd64 2.4.56-1

ii  libgl1-mesa-glx:amd64        10.3.0-0ubuntu3 amd64 
ii  libgl1-mesa-glx:i386         10.3.0-0ubuntu3 i386  
ii  libva-glx1:amd64             1.3.1-3         amd64 
ii  libxcb-glx0:amd64            1.10-2ubuntu1   amd64 
ii  libxcb-glx0:i386             1.10-2ubuntu1   i386  
ii  libxcb-glx0-dev:amd64        1.10-2ubuntu1   amd64
Comment 24 Milan Kocian 2015-01-28 14:16:28 UTC
hello,

I can confirm it on selfcompiled vanilla kernel 3.18.3 (debian unstable).
After disconnecting of the second monitor and some console/xorg
switching the system is back in usable state. Kern log:

Jan 28 14:59:19 ntm2 kernel: ------------[ cut here ]------------
Jan 28 14:59:19 ntm2 kernel: WARNING: CPU: 0 PID: 3557 at drivers/gpu/drm/i915/intel_display.c:3473 intel_crtc_wait_for_pending_flips+0x17b/0x1e0 [i915]()
Jan 28 14:59:19 ntm2 kernel: Modules linked in: ntfs msdos jfs ext4 jbd2 ext3 jbd ext2 mbcache cpuid ccm bnep ipv6 nfnetlink_queue nfnetlink_log nfnetlink cpufreq_userspace cpufreq_stats cpufreq_powersave cpufreq_ondemand cpufreq_conservative deflate ctr twofish_avx_x86_64 twofish_x86_64_3way twofish_x86_64 twofish_common camellia_generic camellia_aesni_avx2 camellia_aesni_avx_x86_64 camellia_x86_64 serpent_avx2 serpent_avx_x86_64 serpent_sse2_x86_64 xts serpent_generic blowfish_generic blowfish_x86_64 blowfish_common cast5_avx_x86_64 cast5_generic cast_common des3_ede_x86_64 des_generic cmac xcbc rmd160 sha512_ssse3 sha512_generic sha1_mb mcryptd sha1_ssse3 sha1_generic hmac crypto_null af_key xfrm_algo nls_iso8859_1 nls_cp437 vfat fat fuse vhost_net tun vhost macvtap macvlan uinput usbhid algif_skcipher af_alg sha256_ssse3 sha256_generic md_mod ecb btusb bluetooth crc16 uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_core v4l2_common videodev media snd_hda_codec_hdmi cdc_mbim cdc_wdm cdc_ncm usbnet mii snd_hda_codec_realtek snd_hda_codec_generic iTCO_wdt arc4 tpm_infineon x86_pkg_temp_thermal intel_powerclamp coretemp kvm_intel kvm crct10dif_pclmul crct10dif_common iwlmvm crc32_pclmul mac80211 crc32c_intel ghash_clmulni_intel aesni_intel aes_x86_64 lrw gf128mul glue_helper ablk_helper cryptd iwlwifi psmouse i915 toshiba_acpi sg cfg80211 lpc_ich snd_hda_intel mfd_core toshiba_bluetooth toshiba_haps sparse_keymap snd_hda_controller tpm_tis tpm snd_hda_codec snd_hwdep snd_pcm_oss i2c_algo_bit e1000e snd_mixer_oss drm_kms_helper xhci_pci xhci_hcd ptp snd_pcm wmi usbcore mei_me pps_core mei snd_timer usb_common ac battery video drm snd thermal soundcore acpi_cpufreq i2c_core processor
Jan 28 14:59:19 ntm2 kernel: CPU: 0 PID: 3557 Comm: Xorg Tainted: G        W      3.18.3 #33
Jan 28 14:59:19 ntm2 kernel: Hardware name: TOSHIBA PORTEGE Z30-A/PORTEGE Z30-A, BIOS Version 3.70   07/25/2014
Jan 28 14:59:19 ntm2 kernel: 0000000000000000 0000000000000009 ffffffff814507e4 0000000000000000
Jan 28 14:59:19 ntm2 kernel: ffffffff8104723d 0000000000000000 ffff8800dac282c0 ffff88021546b000
Jan 28 14:59:19 ntm2 kernel: ffff8800dac33800 ffff88021546b000 ffffffffa02b5cfb ffff880215beed60
Jan 28 14:59:19 ntm2 kernel: Call Trace:
Jan 28 14:59:19 ntm2 kernel: [<ffffffff814507e4>] ? dump_stack+0x49/0x6a
Jan 28 14:59:19 ntm2 kernel: [<ffffffff8104723d>] ? warn_slowpath_common+0x6d/0x90
Jan 28 14:59:19 ntm2 kernel: [<ffffffffa02b5cfb>] ? intel_crtc_wait_for_pending_flips+0x17b/0x1e0 [i915]
Jan 28 14:59:19 ntm2 kernel: [<ffffffff81078a70>] ? __wake_up_sync+0x10/0x10
Jan 28 14:59:19 ntm2 kernel: [<ffffffffa02be0eb>] ? intel_crtc_disable_planes+0x2b/0x140 [i915]
Jan 28 14:59:19 ntm2 kernel: [<ffffffffa02bf0c7>] ? haswell_crtc_disable+0x47/0x2f0 [i915]
Jan 28 14:59:19 ntm2 kernel: [<ffffffffa02b7b12>] ? __intel_set_mode+0x2c2/0x16d0 [i915]
Jan 28 14:59:19 ntm2 kernel: [<ffffffff81396a0d>] ? __alloc_skb+0x6d/0x1c0
Jan 28 14:59:19 ntm2 kernel: [<ffffffffa02c09ad>] ? intel_set_mode+0xd/0x30 [i915]
Jan 28 14:59:19 ntm2 kernel: [<ffffffffa02c1a9b>] ? intel_crtc_set_config+0xa8b/0xe40 [i915]
Jan 28 14:59:19 ntm2 kernel: [<ffffffffa0066b69>] ? drm_mode_set_config_internal+0x59/0xe0 [drm]
Jan 28 14:59:19 ntm2 kernel: [<ffffffffa01221b4>] ? restore_fbdev_mode+0xc4/0xe0 [drm_kms_helper]
Jan 28 14:59:19 ntm2 kernel: [<ffffffffa01221ed>] ? drm_fb_helper_restore_fbdev_mode_unlocked+0x1d/0x30 [drm_kms_helper]
Jan 28 14:59:19 ntm2 kernel: [<ffffffffa0124161>] ? drm_fb_helper_set_par+0x21/0x70 [drm_kms_helper]
Jan 28 14:59:19 ntm2 kernel: [<ffffffffa02cc831>] ? intel_fbdev_set_par+0x11/0x60 [i915]
Jan 28 14:59:19 ntm2 kernel: [<ffffffff8128a7ec>] ? fb_set_var+0x16c/0x3a0
Jan 28 14:59:19 ntm2 kernel: [<ffffffff8106f1e0>] ? update_curr+0x50/0x100
Jan 28 14:59:19 ntm2 kernel: [<ffffffff81070e92>] ? enqueue_entity+0x142/0x7b0
Jan 28 14:59:19 ntm2 kernel: [<ffffffff812855b5>] ? fbcon_blank+0x225/0x2e0
Jan 28 14:59:19 ntm2 kernel: [<ffffffff812dcfd2>] ? do_unblank_screen+0xa2/0x1c0
Jan 28 14:59:19 ntm2 kernel: [<ffffffff812d374f>] ? complete_change_console+0x4f/0xd0
Jan 28 14:59:19 ntm2 kernel: [<ffffffff812d48a3>] ? vt_ioctl+0x10d3/0x1350
Jan 28 14:59:19 ntm2 kernel: [<ffffffffa006159d>] ? drm_dropmaster_ioctl+0x5d/0x70 [drm]
Jan 28 14:59:19 ntm2 kernel: [<ffffffffa005d51e>] ? drm_ioctl+0x6e/0x570 [drm]
Jan 28 14:59:19 ntm2 kernel: [<ffffffff812c9644>] ? tty_ioctl+0x264/0xbb0
Jan 28 14:59:19 ntm2 kernel: [<ffffffff81156fd8>] ? fsnotify+0x308/0x4b0
Jan 28 14:59:19 ntm2 kernel: [<ffffffff81131400>] ? do_vfs_ioctl+0x2d0/0x4a0
Jan 28 14:59:19 ntm2 kernel: [<ffffffff811220db>] ? __sb_end_write+0x2b/0x70
Jan 28 14:59:19 ntm2 kernel: [<ffffffff81120003>] ? vfs_write+0x1b3/0x1f0
Jan 28 14:59:19 ntm2 kernel: [<ffffffff81131649>] ? SyS_ioctl+0x79/0x90
Jan 28 14:59:19 ntm2 kernel: [<ffffffff81455616>] ? system_call_fastpath+0x16/0x1b
Jan 28 14:59:19 ntm2 kernel: ---[ end trace e1d3a2b3ec983c95 ]---
Jan 28 14:59:19 ntm2 kernel: ------------[ cut here ]------------
Jan 28 14:59:19 ntm2 kernel: WARNING: CPU: 0 PID: 3557 at drivers/gpu/drm/i915/intel_display.c:3479 intel_crtc_wait_for_pending_flips+0x1d3/0x1e0 [i915]()
Jan 28 14:59:19 ntm2 kernel: Removing stuck page flip
Jan 28 14:59:19 ntm2 kernel: Modules linked in: ntfs msdos jfs ext4 jbd2 ext3 jbd ext2 mbcache cpuid ccm bnep ipv6 nfnetlink_queue nfnetlink_log nfnetlink cpufreq_userspace cpufreq_stats cpufreq_powersave cpufreq_ondemand cpufreq_conservative deflate ctr twofish_avx_x86_64 twofish_x86_64_3way twofish_x86_64 twofish_common camellia_generic camellia_aesni_avx2 camellia_aesni_avx_x86_64 camellia_x86_64 serpent_avx2 serpent_avx_x86_64 serpent_sse2_x86_64 xts serpent_generic blowfish_generic blowfish_x86_64 blowfish_common cast5_avx_x86_64 cast5_generic cast_common des3_ede_x86_64 des_generic cmac xcbc rmd160 sha512_ssse3 sha512_generic sha1_mb mcryptd sha1_ssse3 sha1_generic hmac crypto_null af_key xfrm_algo nls_iso8859_1 nls_cp437 vfat fat fuse vhost_net tun vhost macvtap macvlan uinput usbhid algif_skcipher af_alg sha256_ssse3 sha256_generic md_mod ecb btusb bluetooth crc16 uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_core v4l2_common videodev media snd_hda_codec_hdmi cdc_mbim cdc_wdm cdc_ncm usbnet mii snd_hda_codec_realtek snd_hda_codec_generic iTCO_wdt arc4 tpm_infineon x86_pkg_temp_thermal intel_powerclamp coretemp kvm_intel kvm crct10dif_pclmul crct10dif_common iwlmvm crc32_pclmul mac80211 crc32c_intel ghash_clmulni_intel aesni_intel aes_x86_64 lrw gf128mul glue_helper ablk_helper cryptd iwlwifi psmouse i915 toshiba_acpi sg cfg80211 lpc_ich snd_hda_intel mfd_core toshiba_bluetooth toshiba_haps sparse_keymap snd_hda_controller tpm_tis tpm snd_hda_codec snd_hwdep snd_pcm_oss i2c_algo_bit e1000e snd_mixer_oss drm_kms_helper xhci_pci xhci_hcd ptp snd_pcm wmi usbcore mei_me pps_core mei snd_timer usb_common ac battery video drm snd thermal soundcore acpi_cpufreq i2c_core processor
Jan 28 14:59:19 ntm2 kernel: CPU: 0 PID: 3557 Comm: Xorg Tainted: G        W      3.18.3 #33
Jan 28 14:59:19 ntm2 kernel: Hardware name: TOSHIBA PORTEGE Z30-A/PORTEGE Z30-A, BIOS Version 3.70   07/25/2014
Jan 28 14:59:19 ntm2 kernel: 0000000000000000 0000000000000009 ffffffff814507e4 ffff88020ec337d8
Jan 28 14:59:19 ntm2 kernel: ffffffff8104723d ffff8800dac339a0 0000000000000297 ffff88021546b000
Jan 28 14:59:19 ntm2 kernel: ffff8800dac33800 ffff88021546b000 ffffffff810472a5 ffffffffa0314a2a
Jan 28 14:59:19 ntm2 kernel: Call Trace:
Jan 28 14:59:19 ntm2 kernel: [<ffffffff814507e4>] ? dump_stack+0x49/0x6a
Jan 28 14:59:19 ntm2 kernel: [<ffffffff8104723d>] ? warn_slowpath_common+0x6d/0x90
Jan 28 14:59:19 ntm2 kernel: [<ffffffff810472a5>] ? warn_slowpath_fmt+0x45/0x50
Jan 28 14:59:19 ntm2 kernel: [<ffffffff81047242>] ? warn_slowpath_common+0x72/0x90
Jan 28 14:59:19 ntm2 kernel: [<ffffffffa02b5d53>] ? intel_crtc_wait_for_pending_flips+0x1d3/0x1e0 [i915]
Jan 28 14:59:19 ntm2 kernel: [<ffffffff81078a70>] ? __wake_up_sync+0x10/0x10
Jan 28 14:59:19 ntm2 kernel: [<ffffffffa02be0eb>] ? intel_crtc_disable_planes+0x2b/0x140 [i915]
Jan 28 14:59:19 ntm2 kernel: [<ffffffffa02bf0c7>] ? haswell_crtc_disable+0x47/0x2f0 [i915]
Jan 28 14:59:19 ntm2 kernel: [<ffffffffa02b7b12>] ? __intel_set_mode+0x2c2/0x16d0 [i915]
Jan 28 14:59:19 ntm2 kernel: [<ffffffff81396a0d>] ? __alloc_skb+0x6d/0x1c0
Jan 28 14:59:19 ntm2 kernel: [<ffffffffa02c09ad>] ? intel_set_mode+0xd/0x30 [i915]
Jan 28 14:59:19 ntm2 kernel: [<ffffffffa02c1a9b>] ? intel_crtc_set_config+0xa8b/0xe40 [i915]
Jan 28 14:59:19 ntm2 kernel: [<ffffffffa0066b69>] ? drm_mode_set_config_internal+0x59/0xe0 [drm]
Jan 28 14:59:19 ntm2 kernel: [<ffffffffa01221b4>] ? restore_fbdev_mode+0xc4/0xe0 [drm_kms_helper]
Jan 28 14:59:19 ntm2 kernel: [<ffffffffa01221ed>] ? drm_fb_helper_restore_fbdev_mode_unlocked+0x1d/0x30 [drm_kms_helper]
Jan 28 14:59:19 ntm2 kernel: [<ffffffffa0124161>] ? drm_fb_helper_set_par+0x21/0x70 [drm_kms_helper]
Jan 28 14:59:19 ntm2 kernel: [<ffffffffa02cc831>] ? intel_fbdev_set_par+0x11/0x60 [i915]
Jan 28 14:59:19 ntm2 kernel: [<ffffffff8128a7ec>] ? fb_set_var+0x16c/0x3a0
Jan 28 14:59:19 ntm2 kernel: [<ffffffff8106f1e0>] ? update_curr+0x50/0x100
Jan 28 14:59:19 ntm2 kernel: [<ffffffff81070e92>] ? enqueue_entity+0x142/0x7b0
Jan 28 14:59:19 ntm2 kernel: [<ffffffff812855b5>] ? fbcon_blank+0x225/0x2e0
Jan 28 14:59:19 ntm2 kernel: [<ffffffff812dcfd2>] ? do_unblank_screen+0xa2/0x1c0
Jan 28 14:59:19 ntm2 kernel: [<ffffffff812d374f>] ? complete_change_console+0x4f/0xd0
Jan 28 14:59:19 ntm2 kernel: [<ffffffff812d48a3>] ? vt_ioctl+0x10d3/0x1350
Jan 28 14:59:19 ntm2 kernel: [<ffffffffa006159d>] ? drm_dropmaster_ioctl+0x5d/0x70 [drm]
Jan 28 14:59:19 ntm2 kernel: [<ffffffffa005d51e>] ? drm_ioctl+0x6e/0x570 [drm]
Jan 28 14:59:19 ntm2 kernel: [<ffffffff812c9644>] ? tty_ioctl+0x264/0xbb0
Jan 28 14:59:19 ntm2 kernel: [<ffffffff81156fd8>] ? fsnotify+0x308/0x4b0
Jan 28 14:59:19 ntm2 kernel: [<ffffffff81131400>] ? do_vfs_ioctl+0x2d0/0x4a0
Jan 28 14:59:19 ntm2 kernel: [<ffffffff811220db>] ? __sb_end_write+0x2b/0x70
Jan 28 14:59:19 ntm2 kernel: [<ffffffff81120003>] ? vfs_write+0x1b3/0x1f0
Jan 28 14:59:19 ntm2 kernel: [<ffffffff81131649>] ? SyS_ioctl+0x79/0x90
Jan 28 14:59:19 ntm2 kernel: [<ffffffff81455616>] ? system_call_fastpath+0x16/0x1b
Jan 28 14:59:19 ntm2 kernel: ---[ end trace e1d3a2b3ec983c96 ]---
Jan 28 15:00:05 ntm2 kernel: ------------[ cut here ]------------
Jan 28 15:00:05 ntm2 kernel: WARNING: CPU: 2 PID: 3557 at drivers/gpu/drm/i915/intel_dp.c:137 intel_dp_max_link_bw+0x3a/0x90 [i915]()
Jan 28 15:00:05 ntm2 kernel: invalid max DP link bw val 0, using 1.62Gbps
Jan 28 15:00:05 ntm2 kernel: Modules linked in: ntfs msdos jfs ext4 jbd2 ext3 jbd ext2 mbcache cpuid ccm bnep ipv6 nfnetlink_queue nfnetlink_log nfnetlink cpufreq_userspace cpufreq_stats cpufreq_powersave cpufreq_ondemand cpufreq_conservative deflate ctr twofish_avx_x86_64 twofish_x86_64_3way twofish_x86_64 twofish_common camellia_generic camellia_aesni_avx2 camellia_aesni_avx_x86_64 camellia_x86_64 serpent_avx2 serpent_avx_x86_64 serpent_sse2_x86_64 xts serpent_generic blowfish_generic blowfish_x86_64 blowfish_common cast5_avx_x86_64 cast5_generic cast_common des3_ede_x86_64 des_generic cmac xcbc rmd160 sha512_ssse3 sha512_generic sha1_mb mcryptd sha1_ssse3 sha1_generic hmac crypto_null af_key xfrm_algo nls_iso8859_1 nls_cp437 vfat fat fuse vhost_net tun vhost macvtap macvlan uinput usbhid algif_skcipher af_alg sha256_ssse3 sha256_generic md_mod ecb btusb bluetooth crc16 uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_core v4l2_common videodev media snd_hda_codec_hdmi cdc_mbim cdc_wdm cdc_ncm usbnet mii snd_hda_codec_realtek snd_hda_codec_generic iTCO_wdt arc4 tpm_infineon x86_pkg_temp_thermal intel_powerclamp coretemp kvm_intel kvm crct10dif_pclmul crct10dif_common iwlmvm crc32_pclmul mac80211 crc32c_intel ghash_clmulni_intel aesni_intel aes_x86_64 lrw gf128mul glue_helper ablk_helper cryptd iwlwifi psmouse i915 toshiba_acpi sg cfg80211 lpc_ich snd_hda_intel mfd_core toshiba_bluetooth toshiba_haps sparse_keymap snd_hda_controller tpm_tis tpm snd_hda_codec snd_hwdep snd_pcm_oss i2c_algo_bit e1000e snd_mixer_oss drm_kms_helper xhci_pci xhci_hcd ptp snd_pcm wmi usbcore mei_me pps_core mei snd_timer usb_common ac battery video drm snd thermal soundcore acpi_cpufreq i2c_core processor
Jan 28 15:00:05 ntm2 kernel: CPU: 2 PID: 3557 Comm: Xorg Tainted: G        W      3.18.3 #33
Jan 28 15:00:05 ntm2 kernel: Hardware name: TOSHIBA PORTEGE Z30-A/PORTEGE Z30-A, BIOS Version 3.70   07/25/2014
Jan 28 15:00:05 ntm2 kernel: 0000000000000000 0000000000000009 ffffffff814507e4 ffff88020ec33ac8
Jan 28 15:00:05 ntm2 kernel: ffffffff8104723d 0000000000000000 ffff8800d395a000 ffff8800dac20000
Jan 28 15:00:05 ntm2 kernel: 0000000000000002 ffff88009b6a3400 ffffffff810472a5 ffffffffa0310880
Jan 28 15:00:05 ntm2 kernel: Call Trace:
Jan 28 15:00:05 ntm2 kernel: [<ffffffff814507e4>] ? dump_stack+0x49/0x6a
Jan 28 15:00:05 ntm2 kernel: [<ffffffff8104723d>] ? warn_slowpath_common+0x6d/0x90
Jan 28 15:00:05 ntm2 kernel: [<ffffffff810472a5>] ? warn_slowpath_fmt+0x45/0x50
Jan 28 15:00:05 ntm2 kernel: [<ffffffffa02d85aa>] ? intel_dp_max_link_bw+0x3a/0x90 [i915]
Jan 28 15:00:05 ntm2 kernel: [<ffffffffa02d868c>] ? intel_dp_compute_config+0x8c/0x620 [i915]
Jan 28 15:00:05 ntm2 kernel: [<ffffffffa02b839c>] ? __intel_set_mode+0xb4c/0x16d0 [i915]
Jan 28 15:00:05 ntm2 kernel: [<ffffffffa02c09ad>] ? intel_set_mode+0xd/0x30 [i915]
Jan 28 15:00:05 ntm2 kernel: [<ffffffffa02c1a9b>] ? intel_crtc_set_config+0xa8b/0xe40 [i915]
Jan 28 15:00:05 ntm2 kernel: [<ffffffffa0066b69>] ? drm_mode_set_config_internal+0x59/0xe0 [drm]
Jan 28 15:00:05 ntm2 kernel: [<ffffffffa006ab4a>] ? drm_mode_setcrtc+0x25a/0x570 [drm]
Jan 28 15:00:05 ntm2 kernel: [<ffffffffa005d62b>] ? drm_ioctl+0x17b/0x570 [drm]
Jan 28 15:00:05 ntm2 kernel: [<ffffffff81131400>] ? do_vfs_ioctl+0x2d0/0x4a0
Jan 28 15:00:05 ntm2 kernel: [<ffffffff811220db>] ? __sb_end_write+0x2b/0x70
Jan 28 15:00:05 ntm2 kernel: [<ffffffff81120003>] ? vfs_write+0x1b3/0x1f0
Jan 28 15:00:05 ntm2 kernel: [<ffffffff81131649>] ? SyS_ioctl+0x79/0x90
Jan 28 15:00:05 ntm2 kernel: [<ffffffff8104dfc6>] ? ns_capable+0x26/0x60
Jan 28 15:00:05 ntm2 kernel: [<ffffffff81455616>] ? system_call_fastpath+0x16/0x1b
Jan 28 15:00:05 ntm2 kernel: ---[ end trace e1d3a2b3ec983c97 ]---
Comment 25 Jani Nikula 2015-02-11 15:04:01 UTC
Please try drm-intel-nightly branch of http://cgit.freedesktop.org/drm-intel
Comment 26 Tin Tvrtković 2015-02-11 15:29:29 UTC
I've been running 3.19.0-031900 (RC5 from Vivid) since 2015-01-26, and no issues so far *knock on wood*.
Comment 27 Rob 2015-05-19 11:45:19 UTC
Seems to be fixed for me as well.
Comment 28 Jani Nikula 2015-10-07 10:54:37 UTC
Presumed fixed, closing.

Please file any new bug reports at the freedesktop.org bugzilla [1]. Thank you.

[1] https://bugs.freedesktop.org/enter_bug.cgi?product=DRI&component=DRM/Intel

Note You need to log in before you can comment on or make changes to this bug.