Bug 6432 - USB stick: repreated message in syslog : "assuming drive cache: write through"
USB stick: repreated message in syslog : "assuming drive cache: write through"
Status: REJECTED INVALID
Product: Drivers
Classification: Unclassified
Component: USB
i386 Linux
: P2 low
Assigned To: Alan Stern
:
Depends on:
Blocks: USB
  Show dependency treegraph
 
Reported: 2006-04-24 01:17 UTC by Toralf Förster
Modified: 2006-08-30 23:53 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.16-gentoo-r3
Tree: Mainline
Regression: ---


Attachments

Description Toralf Förster 2006-04-24 01:17:00 UTC
After plugin an (old) 32 MB USB stick I got the following messages in my syslog,
there is one message repeated again : "assuming drive cache: write through"

Here's the log:
...
Apr 24 10:11:26 n22 usb 2-2: new full speed USB device using uhci_hcd and address 6
Apr 24 10:11:26 n22 usb 2-2: configuration #1 chosen from 1 choice
Apr 24 10:11:27 n22 SCSI subsystem initialized
Apr 24 10:11:27 n22 Initializing USB Mass Storage driver...
Apr 24 10:11:27 n22 scsi0 : SCSI emulation for USB Mass Storage devices
Apr 24 10:11:27 n22 usb-storage: device found at 6
Apr 24 10:11:27 n22 usb-storage: waiting for device to settle before scanning
Apr 24 10:11:27 n22 usbcore: registered new driver usb-storage
Apr 24 10:11:27 n22 USB Mass Storage support registered.
Apr 24 10:11:32 n22 Vendor: IBM       Model: Memory Key        Rev: 4.50
Apr 24 10:11:32 n22 Type:   Direct-Access                      ANSI SCSI
revision: 00
Apr 24 10:11:32 n22 usb-storage: device scan complete
Apr 24 10:11:32 n22 scsi.agent[30376]: disk at
/devices/pci0000:00/0000:00:1d.1/usb2/2-2/2-2:1.0/host0/target0:0:0/0:0:0:0
Apr 24 10:11:32 n22 SCSI device sda: 63424 512-byte hdwr sectors (32 MB)
Apr 24 10:11:32 n22 sda: Write Protect is off
Apr 24 10:11:32 n22 sda: Mode Sense: 45 00 00 08
Apr 24 10:11:32 n22 sda: assuming drive cache: write through
Apr 24 10:11:32 n22 SCSI device sda: 63424 512-byte hdwr sectors (32 MB)
Apr 24 10:11:32 n22 sda: Write Protect is off
Apr 24 10:11:32 n22 sda: Mode Sense: 45 00 00 08
Apr 24 10:11:32 n22 sda: assuming drive cache: write through
Apr 24 10:11:32 n22 sda: sda1
Apr 24 10:11:32 n22 sd 0:0:0:0: Attached scsi removable disk sda
...

n22 /usr/src/linux # uname -a
Linux n22 2.6.16-gentoo-r3 #10 Sun Apr 23 21:04:53 CEST 2006 i686 Intel(R)
Pentium(R) M processor 1700MHz GNU/Linux
Comment 1 Andrew Morton 2006-04-24 01:33:39 UTC
Why is this a problem?
Comment 2 Toralf Förster 2006-04-24 01:45:06 UTC
It's not a problem, but sometimes such a message indicates a hidden problem/bug.
That's why I filed this report with a low severity.
So if this behaviour is wanted and/or not harmful this bug can be closed.
Comment 3 Alan Stern 2006-08-30 12:48:51 UTC
This is not a bug; it is normal behavior.  It has to do with the way the SCSI
and block layers work.  Each new device is revalidated (which involves checking
its total capacity, the write-protect setting, and the cache setting) when it is
first detected and then again when it is registered with the block layer.

The duplicated messages may be a little annoying, but they aren't a problem. 
And believe me, the developers are well aware of them.  I'm going to close out
this bug report.
Comment 4 Toralf Förster 2006-08-30 23:53:12 UTC
Ah, thanks for the comprehensive answer.

Note You need to log in before you can comment on or make changes to this bug.