Bug 6404 - SiS 661: APIC error on CPU0: 40(40)
SiS 661: APIC error on CPU0: 40(40)
Status: CLOSED CODE_FIX
Product: Platform Specific/Hardware
Classification: Unclassified
Component: i386
i386 Linux
: P2 normal
Assigned To: platform_i386
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-18 04:57 UTC by Emmanuel Fleury
Modified: 2012-05-12 01:35 UTC (History)
12 users (show)

See Also:
Kernel Version: 2.6.27
Tree: Mainline
Regression: No


Attachments
USB freaks out after APIC error (5.96 KB, text/plain)
2007-04-04 11:43 UTC, Bill McGonigle
Details

Description Emmanuel Fleury 2006-04-18 04:57:32 UTC
Most recent kernel where this bug did not occur: 2.6.16
Distribution: Debian (but home compiled kernel)
Hardware Environment: 
 lspci -tv:
 -[00]-+-00.0  Silicon Integrated Systems [SiS] 661FX/M661FX/M661MX Host
      +-01.0-[01]--+-00.0  ATI Technologies Inc RV350 AQ [Radeon 9600]
      |            \-00.1  ATI Technologies Inc RV350 AQ [Radeon 9600] (Secondary)
      +-02.0  Silicon Integrated Systems [SiS] SiS963 [MuTIOL Media IO]
      +-02.5  Silicon Integrated Systems [SiS] 5513 [IDE]
      +-02.7  Silicon Integrated Systems [SiS] Sound Controller
      +-03.0  Silicon Integrated Systems [SiS] USB 1.0 Controller
      +-03.1  Silicon Integrated Systems [SiS] USB 1.0 Controller
      +-03.3  Silicon Integrated Systems [SiS] USB 2.0 Controller
      +-04.0  Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet
      \-08.0  Intel Corporation 82541PI Gigabit Ethernet Controller

/proc/cpuinfo:
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 15
model           : 4
model name      : Intel(R) Pentium(R) 4 CPU 3.00GHz
stepping        : 1
cpu MHz         : 3002.629
cache size      : 1024 KB
physical id     : 0
siblings        : 2
core id         : 0
cpu cores       : 1
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 5
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe constant_tsc pni
monitor ds_cpl cid xtpr
bogomips        : 6007.05

processor       : 1
vendor_id       : GenuineIntel
cpu family      : 15
model           : 4
model name      : Intel(R) Pentium(R) 4 CPU 3.00GHz
stepping        : 1
cpu MHz         : 3002.629
cache size      : 1024 KB
physical id     : 0
siblings        : 2
core id         : 0
cpu cores       : 1
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 5
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe constant_tsc pni
monitor ds_cpl cid xtpr
bogomips        : 6000.91


Software Environment:
Problem Description: 
The kernel.log contain many APIC error:

Apr 14 17:04:41 carioca kernel: APIC error on CPU0: 40(40)
Apr 14 17:04:59 carioca kernel: APIC error on CPU0: 40(40)
Apr 14 17:33:15 carioca kernel: APIC error on CPU0: 40(40)
Apr 14 17:34:38 carioca kernel: APIC error on CPU0: 40(40)
Apr 14 17:34:54 carioca kernel: APIC error on CPU0: 40(40)
Apr 14 17:36:50 carioca last message repeated 2 times
Apr 14 17:40:23 carioca kernel: APIC error on CPU0: 40(40)
Apr 14 17:40:42 carioca kernel: APIC error on CPU0: 40(40)
Apr 14 17:44:45 carioca kernel: APIC error on CPU0: 40(40)
Apr 14 17:46:59 carioca kernel: APIC error on CPU0: 40(40)
Apr 14 17:52:29 carioca kernel: APIC error on CPU0: 40(40)
Apr 14 17:58:43 carioca kernel: APIC error on CPU0: 40(40)
Apr 14 18:02:44 carioca kernel: APIC error on CPU0: 40(40)
Apr 14 18:09:00 carioca kernel: APIC error on CPU0: 40(40)
Apr 14 18:09:16 carioca kernel: APIC error on CPU0: 40(40)
Apr 14 18:10:25 carioca kernel: APIC error on CPU0: 40(40)

As described in the kernel code: 40 = 32+8 = 2^5 + 2^3 meaning:
- Receive accept error
- Send illegal vector


Steps to reproduce:
I have no idea yet... I am monitoring the /var/log/kernel.log file to see when
this occurs (I noticed that the error occurs when I'm using my computer).
Comment 1 Emmanuel Fleury 2006-04-18 07:05:53 UTC
/proc/interrupts:
           CPU0       CPU1
  0: 1217071511          1  local-APIC-edge  timer
  1:          0     526947    IO-APIC-edge  i8042
  7:          0          0    IO-APIC-edge  parport0
  8:          0          4    IO-APIC-edge  rtc
  9:          0          0   IO-APIC-level  acpi
 12:          0    7603424    IO-APIC-edge  i8042
 14:          0    2014519    IO-APIC-edge  ide0
 15:          0    7402886    IO-APIC-edge  ide1
169:          0    7481656   IO-APIC-level  eth0
177:          0   73019105   IO-APIC-level  radeon@pci:0000:01:00.0
185:          0          0   IO-APIC-level  ohci_hcd:usb1
193:          0      15667   IO-APIC-level  ohci_hcd:usb2
201:          0      52566   IO-APIC-level  SiS SI7012
209:          0       2336   IO-APIC-level  ehci_hcd:usb3
NMI:          0          0
LOC: 1214026561 1214026560
ERR:        667
MIS:          0
Comment 2 Emmanuel Fleury 2006-04-19 06:22:40 UTC
I was monitoring the kernel logs since yesterday and the error seems to appear
when some screensavers are on... I only _suspect_ this I didn't find any strong
evidence yet. Still looking for it.

Regards
Comment 3 Emmanuel Fleury 2006-04-21 01:35:37 UTC
I confirm, the error message appears when the screensaver is on (I can reproduce
it at will now). I manage to get the error only on screensavers using OpenGL (I
don't know if it's because of OpenGL or if it's because those screensavers are
cruching a lot of data).

By now, I'm a bit stuck because I don't know how to investigate further (I can
reproduce the bug, it's a start).
Comment 4 Len Brown 2006-04-25 10:09:32 UTC
It is odd that this would appear in one realease and not another.

This is not an uncommon message for certain implementations
(go ahead, google it), and has not been shown to be a serious issue.

As it has nothing to do with ACPI, I'm moving this report out of the ACPI 
category.
Comment 5 Marijn Schouten 2006-06-01 07:14:01 UTC
I also get these error messages. The first is always 04 and then the 40's start 
happening. I don't have a screensaver running.

lspci:
00:00.0 Host bridge: ATI Technologies Inc RS480 Host Bridge (rev 10)
00:01.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:11.0 IDE interface: ATI Technologies Inc ATI 437A Serial ATA Controller (rev 
80)
00:13.0 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller (rev 
80)
00:13.1 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller (rev 
80)
00:13.2 USB Controller: ATI Technologies Inc IXP SB400 USB2 Host Controller 
(rev 80)
00:14.0 SMBus: ATI Technologies Inc IXP SB400 SMBus Controller (rev 81)
00:14.1 IDE interface: ATI Technologies Inc Standard Dual Channel PCI IDE 
Controller ATI (rev 80)
00:14.2 Audio device: ATI Technologies Inc Unknown device 437b (rev 01)
00:14.3 ISA bridge: ATI Technologies Inc IXP SB400 PCI-ISA Bridge (rev 80)
00:14.4 PCI bridge: ATI Technologies Inc IXP SB400 PCI-PCI Bridge (rev 80)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] 
HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address 
Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM 
Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] 
Miscellaneous Control
01:05.0 VGA compatible controller: ATI Technologies Inc RS482 [Radeon Xpress 
200]
02:03.0 Ethernet controller: Realtek Semiconductor Co., Ltd. 
RTL-8139/8139C/8139C+ (rev 10)
02:04.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller 
(rev 80)

I also just noticed that in the kernellog there is only

tail current
Jun  1 12:54:10 [kernel] VFS: Mounted root (ext3 filesystem) readonly.
Jun  1 12:54:10 [kernel] acpi_bus-0201 [01] bus_set_power         : Device is 
not power manageable
Jun  1 12:54:10 [kernel] ACPI: PCI Interrupt 0000:00:14.2[A] -> GSI 16 (level, 
low) -> IRQ 17
Jun  1 12:54:10 [kernel] hda_codec: Unknown model for ALC880, trying auto-probe 
from BIOS...
Jun  1 12:54:10 [kernel] Adding 1959920k swap on /dev/sda2.  Priority:-1 
extents:1 across:1959920k
Jun  1 12:54:10 [kernel] EXT3 FS on sda3, internal journal
Jun  1 12:54:13 [kernel] [drm] Initialized drm 1.0.1 20051102
Jun  1 12:54:14 [kernel] eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
Jun  1 12:54:35 [kernel] APIC error on CPU0: 04(40)
Jun  1 12:55:25 [kernel] APIC error on CPU0: 40(40)

two apic errors, but in dmesg the last apic error is repeated 40 times or so. 
I'm using kernel vanilla 2.6.16.14
Comment 6 David Tonhofer 2006-09-25 02:31:44 UTC
This error newly occurs on an "old" single-processor Intel Pentium III machine
that formerly was running 

  Red Hat ES kernel version 2.6.9-22.0.2.EL

but now is running

  Red Hat ES kernel version 2.6.9-42.0.2.EL



X is not running. No other trouble noticed so far, things are running well.

In the kernel log the errors appear right after boot with the new kernel:

Sep 11 19:36:56 rei1 kernel: Linux version 2.6.9-42.0.2.EL
(bhcompile@ls20-bc1-13.build.redhat.com) (gcc version 3.4.6 2
0060404 (Red Hat 3.4.6-3)) #1 Thu Aug 17 17:36:53 EDT 2006
[...]
Sep 11 19:36:56 rei1 kernel: APIC error on CPU0: 00(40)
[...]
Sep 11 19:36:56 rei1 kernel: APIC error on CPU0: 40(40)

...after that the 40(40) errors return a few hundred times a day.
Comment 7 Arjan van de Ven 2006-11-12 05:05:01 UTC
Please split this bug per chipset; this is not a case of "I see the same message
so I have the same bug"; this message is a symptom only, a symptom that can and
does have many different causes. Having them all in one bug is going to cause a
lot of confusion and mixed information.
Comment 8 Arjan van de Ven 2006-11-12 05:05:40 UTC
bugzilla doesn't let me do this; but can the owner of the bug please change the
"SUmmary" field of this bug to include the name of his chipset?
Comment 9 Adrian Bunk 2006-11-13 07:59:50 UTC
Original submitter had a SiS 661 with kernel 2.6.16 (changed the subject).

Other people said in this bug they observed it with:
- ATI RS480 (kernel 2.6.16.14)
- unknown chipset (kernel: RHEL 2.6.9)
Comment 10 starlight 2006-11-17 22:51:39 UTC
Have been seeing this for a year on a HP Presario SR1030Z AMD system with an
"ATI Radeon XPRESS 200" chipset.  Shows up when system is under high scheduler
stress (non-graphical in my case) with one or both cores running at or near
100%.  Recently upgraded from single-core Athlon 3500+ (Venice) to dual-core
Athlon 4800+ (Toledo) and the problem persists.  Running latest kernel on Centos
4.3 [2.6.9-42.0.3.ELsmp].  Same error appeared with non-SMP kernel.

I'm willing to try running a recent vanilla kernel and reproduce the error if
someone is interested in the outcome.
Comment 11 Amos Shapira 2007-02-14 19:57:15 UTC
For what it's worth, I see this error on an AMD Athlon 2500+ on a Gigabyte 7N400
running Debian Etch with latest kernel (2.6.18-3-k7) with the following lspci
output:

-[0000:00]-+-00.0  nVidia Corporation nForce2 AGP (different version?)
           +-00.1  nVidia Corporation nForce2 Memory Controller 1
           +-00.2  nVidia Corporation nForce2 Memory Controller 4
           +-00.3  nVidia Corporation nForce2 Memory Controller 3
           +-00.4  nVidia Corporation nForce2 Memory Controller 2
           +-00.5  nVidia Corporation nForce2 Memory Controller 5
           +-01.0  nVidia Corporation nForce2 ISA Bridge
           +-01.1  nVidia Corporation nForce2 SMBus (MCP)
           +-02.0  nVidia Corporation nForce2 USB Controller
           +-02.1  nVidia Corporation nForce2 USB Controller
           +-02.2  nVidia Corporation nForce2 USB Controller
           +-08.0-[0000:01]--+-08.0  Creative Labs SB Live! EMU10k1
           |                 +-08.1  Creative Labs SB Live! Game Port
           |                 \-09.0  3Com Corporation 3c905B 100BaseTX [Cyclone]
          +-09.0  nVidia Corporation nForce2 IDE
           \-1e.0-[0000:02]--+-00.0  ATI Technologies Inc Radeon RV250 If
[Radeon 9000]
                             \-00.1  ATI Technologies Inc Radeon RV250 [Radeon
9000] (Secondary)

As far as I can see the in logs it happens once a month, can't see correlation
to other stuff that happens on the system at that time.
Comment 12 Bill McGonigle 2007-03-30 17:22:31 UTC
I also see this on kernel 2.6.20-1.2933.fc6 with SiS 661:

00:00.0 Host bridge: Silicon Integrated Systems [SiS] 661FX/M661FX/M661MX Host
(rev 11)

This is a 2.5GHz P4.

No symptoms other than the messages (that I know of anyway).
Comment 13 Bill McGonigle 2007-04-04 11:17:40 UTC
I can force a lot of these errors to occur by doing intensive disk stuff over
USB, like rebuilding a RAID mirror.  dmesg will be quiet about it with the
machine not doing much work, but then quickly generate at least one per GB of
disk transfer when I ask it to do disk work.  I haven't detected any data
corruption from this error condition in that case.

I also saw one of these messages when I turned on a new USB drive which was
attached to the computer.  At that point the entire USB subsystem freaked out
and all my USB md devices vanished (I have 8 USB hard drives attached to this
machine).  I believe they all went simultaneously because upon shutting down all
the hardware and cold booting everything, the md devices started up without
needing to re-sync.  Typically if drives go offline in any kind of order one of
the mirrors needs to re-sync.

Booting with 'noapic' causes the USB controller to not detect any of the
external drives even though the USB controller was detected:

00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller

I'll make an attachment of the messages from the above event in case it's
helpful to anybody.
Comment 14 Bill McGonigle 2007-04-04 11:43:37 UTC
Created attachment 11049 [details]
USB freaks out after APIC error

as per Comment #13
Comment 15 Bill McGonigle 2007-08-06 10:09:12 UTC
Just to correct my Comment #13 - I have now detected data corruption from this condition - if I'm doing other I/O (copying a large file to the same drives over gigabit) while the RAID array is rebuilding, I can get a 'disk failure':

usb 4-2: reset high speed USB device using ehci_hcd and address 15
raid1: Disk failure on sdb1, disabling device. 
        Operation continuing on 1 devices

and the ring buffer is full of these errors.  I put 'disk failure' in quotes because if I just leave it be to rebuild (without the extra I/O) the RAID mirror rebuilds just fine.
Comment 16 Patrick Matthäi 2007-09-16 15:24:00 UTC
Hello,

I've got the same issue with my brand new HP Compaq 6715s. These errors seems to be appear randomly.

APIC error on CPU1: 40(40)
APIC error on CPU0: 40(40)

I'm using the newest 2.6.22 kernel in a 32 bit environment.

Here are some informations, if you need more, just say it:

me@gnu:~$ cat /proc/cpuinfo
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 72
model name      : AMD Turion(tm) 64 X2 Mobile Technology TL-56
stepping        : 2
cpu MHz         : 1600.000
cache size      : 512 KB
physical id     : 0
siblings        : 2
core id         : 0
cpu cores       : 2
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow pni cx16 lahf_lm cmp_legacy svm extapic cr8legacy ts fid vid ttp tm stc
bogomips        : 3200.38
clflush size    : 64

processor       : 1
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 72
model name      : AMD Turion(tm) 64 X2 Mobile Technology TL-56
stepping        : 2
cpu MHz         : 1600.000
cache size      : 512 KB
physical id     : 0
siblings        : 2
core id         : 1
cpu cores       : 2
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow pni cx16 lahf_lm cmp_legacy svm extapic cr8legacy ts fid vid ttp tm stc
bogomips        : 3200.38
clflush size    : 64

me@gnu:~$ lspci
00:00.0 Host bridge: ATI Technologies Inc Unknown device 7910
00:01.0 PCI bridge: ATI Technologies Inc Unknown device 7912
00:04.0 PCI bridge: ATI Technologies Inc Unknown device 7914
00:05.0 PCI bridge: ATI Technologies Inc Unknown device 7915
00:06.0 PCI bridge: ATI Technologies Inc Unknown device 7916
00:12.0 SATA controller: ATI Technologies Inc SB600 Non-Raid-5 SATA
00:13.0 USB Controller: ATI Technologies Inc SB600 USB (OHCI0)
00:13.1 USB Controller: ATI Technologies Inc SB600 USB (OHCI1)
00:13.2 USB Controller: ATI Technologies Inc SB600 USB (OHCI2)
00:13.3 USB Controller: ATI Technologies Inc SB600 USB (OHCI3)
00:13.4 USB Controller: ATI Technologies Inc SB600 USB (OHCI4)
00:13.5 USB Controller: ATI Technologies Inc SB600 USB Controller (EHCI)
00:14.0 SMBus: ATI Technologies Inc SB600 SMBus (rev 14)
00:14.1 IDE interface: ATI Technologies Inc SB600 IDE
00:14.2 Audio device: ATI Technologies Inc SB600 Azalia
00:14.3 ISA bridge: ATI Technologies Inc SB600 PCI to LPC Bridge
00:14.4 PCI bridge: ATI Technologies Inc SB600 PCI to PCI Bridge
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:05.0 VGA compatible controller: ATI Technologies Inc Unknown device 791f
02:04.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev b6)
10:00.0 Ethernet controller: Broadcom Corporation Unknown device 1713 (rev 02)
30:00.0 Network controller: Broadcom Corporation BCM4310 UART (rev 02)
Comment 17 Bill McGonigle 2007-09-16 15:27:38 UTC
You Compaq appears to have an AMD M690T Chipset.  This bug is specific to the SiS 661.

http://h10010.www1.hp.com/wwpc/uk/en/sm/WF06b/21675-283229-283229-283229-12434650-13123342-80298932.html
Comment 18 Natalie Protasevich 2008-03-20 01:15:16 UTC
Has anyone observer this problem with latest kernels? 
Comment 19 Patrick Matthäi 2008-03-20 01:31:11 UTC
APIC error on CPU0: 40(40)
APIC error on CPU1: 40(40)
APIC error on CPU0: 40(40)
APIC error on CPU1: 40(40)
gnu:~# uname -r
2.6.24.3-gnu

gnu:~# cat /proc/cpuinfo
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 72
model name      : AMD Turion(tm) 64 X2 Mobile Technology TL-56
stepping        : 2
cpu MHz         : 1800.000
cache size      : 512 KB
physical id     : 0
siblings        : 2
core id         : 0
cpu cores       : 2
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow pni cx16 lahf_lm cmp_legacy svm extapic cr8_legacy ts fid vid ttp tm stc
bogomips        : 3600.23
clflush size    : 64

processor       : 1
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 72
model name      : AMD Turion(tm) 64 X2 Mobile Technology TL-56
stepping        : 2
cpu MHz         : 1800.000
cache size      : 512 KB
physical id     : 0
siblings        : 2
core id         : 1
cpu cores       : 2
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow pni cx16 lahf_lm cmp_legacy svm extapic cr8_legacy ts fid vid ttp tm stc
bogomips        : 3600.23
clflush size    : 64


# lspci
00:00.0 Host bridge: ATI Technologies Inc RS690 Host Bridge
00:01.0 PCI bridge: ATI Technologies Inc RS690 PCI to PCI Bridge (Internal gfx)
00:04.0 PCI bridge: ATI Technologies Inc Unknown device 7914
00:05.0 PCI bridge: ATI Technologies Inc RS690 PCI to PCI Bridge (PCI Express Port 1)
00:06.0 PCI bridge: ATI Technologies Inc RS690 PCI to PCI Bridge (PCI Express Port 2)
00:12.0 SATA controller: ATI Technologies Inc SB600 Non-Raid-5 SATA
00:13.0 USB Controller: ATI Technologies Inc SB600 USB (OHCI0)
00:13.1 USB Controller: ATI Technologies Inc SB600 USB (OHCI1)
00:13.2 USB Controller: ATI Technologies Inc SB600 USB (OHCI2)
00:13.3 USB Controller: ATI Technologies Inc SB600 USB (OHCI3)
00:13.4 USB Controller: ATI Technologies Inc SB600 USB (OHCI4)
00:13.5 USB Controller: ATI Technologies Inc SB600 USB Controller (EHCI)
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 14)
00:14.1 IDE interface: ATI Technologies Inc SB600 IDE
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia
00:14.3 ISA bridge: ATI Technologies Inc SB600 PCI to LPC Bridge
00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:05.0 VGA compatible controller: ATI Technologies Inc RS690M [Radeon X1200 Series]
02:04.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev b6)
10:00.0 Ethernet controller: Broadcom Corporation NetLink BCM5906M Fast Ethernet PCI Express (rev 02)
30:00.0 Network controller: Broadcom Corporation BCM4312 802.11a/b/g (rev 02)
Comment 20 Bill McGonigle 2008-03-20 11:10:41 UTC
I can confirm this is still a problem on the SiS 661 at least as of 2.6.23.15 (which is the latest Fedora is pushing at the moment).
Comment 21 Armen K 2008-10-25 13:05:56 UTC
I've been plagued with this problem for a significant amount of time on a system with the following hardware. It hasn't caused any data loss (as far as I know) and is most certainly an annoyance if anything else. However, it seems (through informal testing) that disk and network IO performance is being hindered by it.

MB: Thunder HEsl (S2567)
Proc: Dual PIII @ 1GHz

Note: The chipset is not from SiS.

[~]$ uname -r
2.6.9-11.ELsmp

[~]$ cat /etc/redhat-release 
CentOS release 4.1 (Final)

[~]$ cat /proc/cpuinfo 
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 8
model name      : Pentium III (Coppermine)
stepping	: 10
cpu MHz		: 997.369
cache size	: 256 KB
fdiv_bug	: no
hlt_bug		: no
f00f_bug	: no
coma_bug	: no
fpu		: yes
fpu_exception	: yes
cpuid level	: 2
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 mmx fxsr sse
bogomips	: 1966.08

processor	: 1
vendor_id	: GenuineIntel
cpu family	: 6
model		: 8
model name	: Pentium III (Coppermine)
stepping	: 10
cpu MHz		: 997.369
cache size	: 256 KB
fdiv_bug	: no
hlt_bug		: no
f00f_bug	: no
coma_bug	: no
fpu		: yes
fpu_exception	: yes
cpuid level	: 2
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 mmx fxsr sse
bogomips	: 1990.65

[~]$ lspci 
00:00.0 Host bridge: Broadcom (formerly ServerWorks) CNB20HE Host Bridge (rev 23)
00:00.1 PCI bridge: Broadcom (formerly ServerWorks) CNB20LE Host Bridge (rev 01)
00:00.2 Host bridge: Broadcom (formerly ServerWorks) CNB20HE Host Bridge (rev 01)
00:00.3 Host bridge: Broadcom (formerly ServerWorks) CNB20HE Host Bridge (rev 01)
00:03.0 Unknown mass storage controller: Silicon Image, Inc. PCI0680 Ultra ATA-133 Host Controller (rev 02)
00:07.0 Ethernet controller: Intel Corporation 82557/8/9 [Ethernet Pro 100] (rev 08)
00:0f.0 ISA bridge: Broadcom (formerly ServerWorks) OSB4 South Bridge (rev 51)
00:0f.1 IDE interface: Broadcom (formerly ServerWorks) OSB4 IDE Controller
00:0f.2 USB Controller: Broadcom (formerly ServerWorks) OSB4/CSB5 OHCI USB Controller (rev 04)
01:00.0 VGA compatible controller: nVidia Corporation NV5 [RIVA TNT2/TNT2 Pro] (rev 15)




Comment 22 Bill McGonigle 2009-03-12 23:43:12 UTC
I'm seeing decreased severity as of late on this machine.  It's running:

  2.6.27.19-78.2.30.fc9.i686

Under light usage I can go days without seeing it, which is new.  Doing something intensive like forcing a RAID rebuild will bring it out, though.

I can't pinpoint the exact moment this got better, but it was somewhere between my first Fedora 9 upgrade (on 2.6.26) and now, and I took the first 2.6.27 kernel on Jan 2, which seems about right.

I haven't seen a 'USB freakout' as per my attachment in quite a while either.
Comment 23 Bill McGonigle 2009-04-09 02:38:56 UTC
If anybody wants to work on this and needs hardware, send me an e-mail.  I'm done with the machine so implicated here and can mail the mobo/cpu/memory out to anybody who wants to investigate.  It's a "PC Chips M963GV" MicroATX with 20-pin ATX power.
Comment 24 bledniy 2009-06-18 08:23:53 UTC
I have the same error on debian etch, kernel 2.6.24-etchnhalf.1-686:

$ dmesg |grep APIC
ACPI: APIC 2FFF6BC0, 0068 (r1 GBT    AWRDACPI 42302E31 AWRD  1010101)
ACPI: Local APIC address 0xfee00000
ACPI: LAPIC (acpi_id[0x00] lapic_id[0x00] enabled)
Processor #0 15:2 APIC version 20
ACPI: LAPIC (acpi_id[0x01] lapic_id[0x01] disabled)
ACPI: LAPIC_NMI (acpi_id[0x00] dfl dfl lint[0x1])
ACPI: LAPIC_NMI (acpi_id[0x01] dfl dfl lint[0x1])
ACPI: IOAPIC (id[0x02] address[0xfec00000] gsi_base[0])
IOAPIC[0]: apic_id 2, version 20, address 0xfec00000, GSI 0-23
Enabling APIC mode:  Flat.  Using 1 I/O APICs
mapped APIC to ffffb000 (fee00000)
mapped IOAPIC to ffffa000 (fec00000)
ENABLING IO-APIC IRQs
ACPI: Using IOAPIC for interrupt routing
APIC error on CPU0: 00(40)
APIC error on CPU0: 40(40)
APIC error on CPU0: 40(40)
APIC error on CPU0: 40(40)
APIC error on CPU0: 40(40)
APIC error on CPU0: 40(40)
APIC error on CPU0: 40(40)
APIC error on CPU0: 40(40)
APIC error on CPU0: 40(40)

$ uptime
 19:17:16 up 10 days,  7:21,  1 user,  load average: 0.51, 0.35, 0.27

$ lspci -tv
-[0000:00]-+-00.0  Silicon Integrated Systems [SiS] 645xx
           +-01.0-[0000:01]----00.0  nVidia Corporation NV17 [GeForce4 MX 440]
           +-02.0  Silicon Integrated Systems [SiS] SiS963 [MuTIOL Media IO]
           +-02.1  Silicon Integrated Systems [SiS] SiS961/2 SMBus Controller
           +-02.5  Silicon Integrated Systems [SiS] 5513 [IDE]
           +-02.7  Silicon Integrated Systems [SiS] AC'97 Sound Controller
           +-03.0  Silicon Integrated Systems [SiS] USB 1.0 Controller
           +-03.1  Silicon Integrated Systems [SiS] USB 1.0 Controller
           +-03.2  Silicon Integrated Systems [SiS] USB 1.0 Controller
           +-03.3  Silicon Integrated Systems [SiS] USB 2.0 Controller
           \-0d.0  Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+

$ cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Intel(R) Pentium(R) 4 CPU 2.40GHz
stepping        : 9
cpu MHz         : 300.000
cache size      : 512 KB
physical id     : 0
siblings        : 1
core id         : 0
cpu cores       : 1
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe up pebs bts sync_rdtsc cid xtpr
bogomips        : 4827.13
clflush size    : 64

$ cat /proc/interrupts
           CPU0
  0:        219   IO-APIC-edge      timer
  1:     220973   IO-APIC-edge      i8042
  3:          4   IO-APIC-edge
  4:          5   IO-APIC-edge      serial
  6:          5   IO-APIC-edge      floppy
  7:          0   IO-APIC-edge      parport0
  8:          1   IO-APIC-edge      rtc
  9:          1   IO-APIC-fasteoi   acpi
 12:    8311034   IO-APIC-edge      i8042
 14:    2122025   IO-APIC-edge      ide0
 15:    6286274   IO-APIC-edge      ide1
 16:          0   IO-APIC-fasteoi   ohci_hcd:usb1
 17:          0   IO-APIC-fasteoi   ohci_hcd:usb2
 18:          0   IO-APIC-fasteoi   ohci_hcd:usb3
 19:     591645   IO-APIC-fasteoi   ehci_hcd:usb4
 20:   51253871   IO-APIC-fasteoi   eth0
 21:   23322795   IO-APIC-fasteoi   SiS SI7012
 22:   66862913   IO-APIC-fasteoi   nvidia
NMI:          0   Non-maskable interrupts
LOC:  478085675   Local timer interrupts
RES:          0   Rescheduling interrupts
CAL:          0   function call interrupts
TLB:          0   TLB shootdowns
TRM:          0   Thermal event interrupts
SPU:          0   Spurious interrupts
ERR:          9
MIS:          0
Comment 25 Patrick Matthäi 2009-06-18 08:26:28 UTC
For me it seems to be fixed since Debian 2.6.29 and 2.6.30 kernels.

Note You need to log in before you can comment on or make changes to this bug.