Bug 6402 - KERNEL 2.6.16-rX (Gentoo) && PPPD && SNAT
Summary: KERNEL 2.6.16-rX (Gentoo) && PPPD && SNAT
Status: RESOLVED PATCH_ALREADY_AVAILABLE
Alias: None
Product: Drivers
Classification: Unclassified
Component: Other (show other bugs)
Hardware: i386 Linux
: P2 high
Assignee: drivers_other
URL:
Keywords:
Depends on: 6530
Blocks:
  Show dependency tree
 
Reported: 2006-04-17 14:56 UTC by Badalian Slava
Modified: 2007-06-08 21:46 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.16.ALL
Tree: Mainline
Regression: ---


Attachments
2.6.16.X my Config (36.32 KB, application/octet-stream)
2006-04-19 23:47 UTC, Badalian Slava
Details
tty rework for 2.6.15 (179.17 KB, patch)
2006-04-29 04:39 UTC, Daniel Drake
Details | Diff

Description Badalian Slava 2006-04-17 14:56:58 UTC
After start download file its stop after 4-10 mb and network is down.

Interface ppp0 is UP.
No new dmeseg or debug of syslog

try to ping ppp client:

slavon ~ # ping 192.168.0.2
PING 192.168.0.2 (192.168.0.2) 56(84) bytes of data.
ping: sendmsg: No buffer space available
ping: sendmsg: No buffer space available
ping: sendmsg: No buffer space available
ping: sendmsg: No buffer space available
ping: sendmsg: No buffer space available
ping: sendmsg: No buffer space available
ping: sendmsg: No buffer space available
ping: sendmsg: No buffer space available
ping: sendmsg: No buffer space available
ping: sendmsg: No buffer space available
ping: sendmsg: No buffer space available
ping: sendmsg: No buffer space available
ping: sendmsg: No buffer space available

#ifconfig ppp0
ppp0      Link encap:Point-to-Point Protocol
          inet addr:192.168.0.1  P-t-P:192.168.0.2  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1396  Metric:1
          RX packets:1648 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2407 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3
          RX bytes:75765 (73.9 Kb)  TX bytes:3242633 (3.0 Mb)

#iptables-save
*nat
:PREROUTING ACCEPT [6826:411515]
:POSTROUTING ACCEPT [11117:531811]
:OUTPUT ACCEPT [11118:531895]
-A POSTROUTING -s 192.168.0.0/255.255.255.0 -j SNAT --to-source XXX.XXX.XXX.XXX
COMMIT

slavon ~ # pppd --version
pppd version 2.4.3

slavon ~ # pptpd --version
pptpd v1.3.1

I try it in 3 Computers 2 - x86 and 1 - x86-64 - All have this trouble

its gentoo patches for kernel

 * Applying 1000_linux-2.6.16.1.patch (-p0+) 
 * Applying 1001_linux-2.6.16.2.patch (-p0+) 
 * Applying 1002_linux-2.6.16.3.patch (-p0+) 
 * Applying 1003_linux-2.6.16.4.patch (-p0+) 
 * Applying 1700_sparc-obp64-naming.patch (-p0+) 
 * Applying 1705_sparc-U1-hme-lockup.patch (-p0+) 
 * Applying 1710_sparc-sparsemem.patch (-p0+) 
 * Applying 1715_ppc32-crosscc-ssp.patch (-p0+) 
 * Applying 2400_sky2-1.1.patch (-p0+) 
 * Applying 2405_skge-1.5.patch (-p0+) 
 * Applying 2600_input-mod-devicetable.patch (-p0+) 
 * Applying 4000_deprecate-sk98lin.patch (-p0+) 
 * Applying 4100_libata-enable-atapi.patch (-p0+) 
 * Applying 4105_dm-bbr.patch (-p0+) 
 * Applying 4110_promise-pdc2037x.patch (-p0+) 
 * Applying 4200_fbsplash-0.9.2-r5.patch (-p0+) 
 * Applying 4205_vesafb-tng-1.0-rc1-r3.patch (-p0+) 
 * Applying 4300_squashfs-3.0.patch (-p0+) 
 * Applying 4400_speakup-20060103.patch (-p0+) 
 * Applying 4401_speakup-highlight-tracking-amd64.patch (-p0+) 
 * Applying 4405_alpha-sysctl-uac.patch (-p0+) 


!! In 2.6.15 kernel ALL WORK.
Comment 1 Andrew Morton 2006-04-17 15:28:09 UTC

Begin forwarded message:

Date: Mon, 17 Apr 2006 14:57:03 -0700
From: bugme-daemon@bugzilla.kernel.org
To: bugme-new@lists.osdl.org
Subject: [Bugme-new] [Bug 6402] New: KERNEL 2.6.16-rX (Gentoo) && PPPD && SNAT


http://bugzilla.kernel.org/show_bug.cgi?id=6402

           Summary: KERNEL 2.6.16-rX (Gentoo) && PPPD && SNAT
    Kernel Version: 2.6.16.ALL
            Status: NEW
          Severity: high
             Owner: shemminger@osdl.org
         Submitter: slavon@bigtelecom.ru


After start download file its stop after 4-10 mb and network is down.

Interface ppp0 is UP.
No new dmeseg or debug of syslog

try to ping ppp client:

slavon ~ # ping 192.168.0.2
PING 192.168.0.2 (192.168.0.2) 56(84) bytes of data.
ping: sendmsg: No buffer space available
ping: sendmsg: No buffer space available
ping: sendmsg: No buffer space available
ping: sendmsg: No buffer space available
ping: sendmsg: No buffer space available
ping: sendmsg: No buffer space available
ping: sendmsg: No buffer space available
ping: sendmsg: No buffer space available
ping: sendmsg: No buffer space available
ping: sendmsg: No buffer space available
ping: sendmsg: No buffer space available
ping: sendmsg: No buffer space available
ping: sendmsg: No buffer space available

#ifconfig ppp0
ppp0      Link encap:Point-to-Point Protocol
          inet addr:192.168.0.1  P-t-P:192.168.0.2  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1396  Metric:1
          RX packets:1648 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2407 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3
          RX bytes:75765 (73.9 Kb)  TX bytes:3242633 (3.0 Mb)

#iptables-save
*nat
:PREROUTING ACCEPT [6826:411515]
:POSTROUTING ACCEPT [11117:531811]
:OUTPUT ACCEPT [11118:531895]
-A POSTROUTING -s 192.168.0.0/255.255.255.0 -j SNAT --to-source XXX.XXX.XXX.XXX
COMMIT

slavon ~ # pppd --version
pppd version 2.4.3

slavon ~ # pptpd --version
pptpd v1.3.1

I try it in 3 Computers 2 - x86 and 1 - x86-64 - All have this trouble

its gentoo patches for kernel

 * Applying 1000_linux-2.6.16.1.patch (-p0+) 
 * Applying 1001_linux-2.6.16.2.patch (-p0+) 
 * Applying 1002_linux-2.6.16.3.patch (-p0+) 
 * Applying 1003_linux-2.6.16.4.patch (-p0+) 
 * Applying 1700_sparc-obp64-naming.patch (-p0+) 
 * Applying 1705_sparc-U1-hme-lockup.patch (-p0+) 
 * Applying 1710_sparc-sparsemem.patch (-p0+) 
 * Applying 1715_ppc32-crosscc-ssp.patch (-p0+) 
 * Applying 2400_sky2-1.1.patch (-p0+) 
 * Applying 2405_skge-1.5.patch (-p0+) 
 * Applying 2600_input-mod-devicetable.patch (-p0+) 
 * Applying 4000_deprecate-sk98lin.patch (-p0+) 
 * Applying 4100_libata-enable-atapi.patch (-p0+) 
 * Applying 4105_dm-bbr.patch (-p0+) 
 * Applying 4110_promise-pdc2037x.patch (-p0+) 
 * Applying 4200_fbsplash-0.9.2-r5.patch (-p0+) 
 * Applying 4205_vesafb-tng-1.0-rc1-r3.patch (-p0+) 
 * Applying 4300_squashfs-3.0.patch (-p0+) 
 * Applying 4400_speakup-20060103.patch (-p0+) 
 * Applying 4401_speakup-highlight-tracking-amd64.patch (-p0+) 
 * Applying 4405_alpha-sysctl-uac.patch (-p0+) 


!! In 2.6.15 kernel ALL WORK.

------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.

Comment 2 Badalian Slava 2006-04-19 23:44:31 UTC
I try Download 
ftp://ftp.altlinux.ru/pub/distributions/ALTLinux/ISO/Master-2.4-install-cd.iso

after 5-10 MB network not responsible.

Now try KERNEL 2.6.16-r3 -- bug is still here =)

lsmod:
Module                  Size  Used by
sha1                    1992  -
arc4                    1480  -
ppp_mppe                6092  -
ppp_async               8968  -
ppp_generic            25756  -
slhc                    5832  -
crc_ccitt               1576  -
ipt_DSCP                1704  -
iptable_mangle          1896  -
iptable_nat             6220  -
ip_nat                 14380  -
ip_conntrack           42712  -
nfnetlink               4736  -
xt_tcpudp               2888  -
iptable_filter          1960  -
ip_tables              10228  -
x_tables                9836  -
usbhid                 36448  -
hw_random               4416  -
ata_piix                7980  -
libata                 55188  -
scsi_mod               84488  -
uhci_hcd               29656  -
ehci_hcd               28464  -
usbcore               114820  -

I Attach .config bellow
Comment 3 Badalian Slava 2006-04-19 23:47:13 UTC
Created attachment 7907 [details]
2.6.16.X my Config
Comment 4 Badalian Slava 2006-04-24 04:05:53 UTC
I try to test 2.6.16.9 Native kernel (no gentoo patches)

Bug still here.
Comment 5 Badalian Slava 2006-04-26 06:40:18 UTC
I use bisect to found bug patch.
After 4 hour i do that!

What git-bisect report:

6ed80991a2dce4afc113be35089c564d62fa1f11 is first bad commit
diff-tree 6ed80991a2dce4afc113be35089c564d62fa1f11 (from
7e91c55b32a469d9dda845a90038c015a70838e3)
Author: Andrew Morton <akpm@osdl.org>
Date:   Mon Jan 9 20:54:09 2006 -0800

    [PATCH] tty-layer-buffering-revamp: jsm is broken

    Looks like JSM will be uncompilable after the TTY layer rework is merged into
    Linus's post-2.6.15 tree.

    It was complex to fix - the maintainers were notified in September.

    Cc: Wendy Xiong <wendyx@us.ltcfwd.linux.ibm.com>
    Cc: Alan Cox <alan@lxorguk.ukuu.org.uk>
    Signed-off-by: Andrew Morton <akpm@osdl.org>
    Signed-off-by: Linus Torvalds <torvalds@osdl.org>

:040000 040000 b474d2e1c08a1e189e631c16725bb928a26455b7
89ed9600c36b4f830273c11ccc8eaa9d2f85957b M      drivers
Comment 6 Badalian Slava 2006-04-26 06:51:17 UTC
slavon linux # git-bisect log
git-bisect start
# bad: [414ad0ded83f088608f7c0e774df8cccbba4e229] Linux 2.6.16
git-bisect bad 414ad0ded83f088608f7c0e774df8cccbba4e229
# good: [dab47a31f42a23d2b374e1cd7d0b797e8e08b23d] Linux v2.6.15
git-bisect good dab47a31f42a23d2b374e1cd7d0b797e8e08b23d
# bad: [9f3f46b5fe83a56d380d4006dd2cd906bc186f91] via-velocity: use
NETIF_F_IP_CSUM (hardware only support IPv4)
git-bisect bad 9f3f46b5fe83a56d380d4006dd2cd906bc186f91
# good: [50365c57860cd931c2d806057e0987634797e9af] [ARM] Make Acorn partition
types depend on ACORN_PARTITION
git-bisect good 50365c57860cd931c2d806057e0987634797e9af
# good: [977127174a7dff52d17faeeb4c4949a54221881f] Merge
master.kernel.org:/pub/scm/linux/kernel/git/gregkh/pci-2.6
git-bisect good 977127174a7dff52d17faeeb4c4949a54221881f
# bad: [bb7e8c5a55c1f5d4192f4b61a84a791796ebf0c3] [PKT_SCHED] net/sched/Kconfig:
fix typo in NET_EMATCH_META description
git-bisect bad bb7e8c5a55c1f5d4192f4b61a84a791796ebf0c3
# bad: [9979ead5d1eb23191a00453559927c5abf9087e2] fs/hfsplus/: remove the
hfsplus_inode_check() debug function
git-bisect bad 9979ead5d1eb23191a00453559927c5abf9087e2
# good: [2b4f2f4b0132afa9f441171285cca354377bf5d0] vesafb: Drop blank hook
git-bisect good 2b4f2f4b0132afa9f441171285cca354377bf5d0
# good: [740f14ba5335d1e25b9f3e80643be801f653cd32] s3c2410fb: cleanup and fix
git-bisect good 740f14ba5335d1e25b9f3e80643be801f653cd32
# good: [3af13763d696468d31f71a798155b33f681f221f] fs/ext3/: small cleanups
git-bisect good 3af13763d696468d31f71a798155b33f681f221f
# bad: [e65c1db19fe8177fa2da53e3e0bddffe585b2d47] char/isicom: Firmware loading
git-bisect bad e65c1db19fe8177fa2da53e3e0bddffe585b2d47
# bad: [d9e39538ce7c52e45e653e777d73ed373189c20d] clean up computone remaining
cli use
git-bisect bad d9e39538ce7c52e45e653e777d73ed373189c20d
# bad: [6ed80991a2dce4afc113be35089c564d62fa1f11] tty-layer-buffering-revamp:
jsm is broken
git-bisect bad 6ed80991a2dce4afc113be35089c564d62fa1f11
# good: [7e91c55b32a469d9dda845a90038c015a70838e3] Serial: disable jsm in ppc64
defconfig
git-bisect good 7e91c55b32a469d9dda845a90038c015a70838e3
# good: [7e91c55b32a469d9dda845a90038c015a70838e3] Serial: disable jsm in ppc64
defconfig
git-bisect good 7e91c55b32a469d9dda845a90038c015a70838e3
# good: [7e91c55b32a469d9dda845a90038c015a70838e3] Serial: disable jsm in ppc64
defconfig
git-bisect good 7e91c55b32a469d9dda845a90038c015a70838e3
# good: [7e91c55b32a469d9dda845a90038c015a70838e3] Serial: disable jsm in ppc64
defconfig
git-bisect good 7e91c55b32a469d9dda845a90038c015a70838e3


This i say BAD becouse if start connect - computer is freeze. CTRL+ALT+DEL not work.
# bad: [d9e39538ce7c52e45e653e777d73ed373189c20d] clean up computone remaining
cli use
Comment 7 Badalian Slava 2006-04-26 07:01:38 UTC
2006-01-10 	Alan Cox 	[PATCH] clean up computone remaining cli use 	commit |
commitdiff
2006-01-10 	Grant Coady 	[PATCH] n_hdlc.c: remove unused declaration 	commit |
commitdiff
2006-01-10 	Alan Cox 	[PATCH] TTY layer buffering revamp 	commit | commitdiff
2006-01-10 	Andrew Morton 	[PATCH] tty-layer-buffering-revamp: jsm is broken 
commit | commitdiff
2006-01-10 	Paul Jackson 	[PATCH] Serial: disable jsm in ppc64 defconfig 	commit
| commitdiff
2006-01-10 	Adrian Bunk 	[PATCH] lib/zlib*: cleanups 	commit | commitdiff
2006-01-10 	Adrian Bunk 	[PATCH] fs/ext3/: small cleanups 	commit | commitdiff

Bug is near that paches... i think bug in TTY channel between pptp and pppd
Comment 8 Russell King 2006-04-26 10:53:11 UTC
NAK.  Not my problem.  Please don't randomly reassign bugs to people because
you can't find the real person - it's unhelpful, annoying and discurteous.
Comment 9 Stephen Hemminger 2006-04-26 11:40:50 UTC
Russell says tty is not serial
Comment 10 Badalian Slava 2006-04-27 13:05:24 UTC
Its good. But problem have many providers who use VPN (PPTPD+PPPD).

I can't update 6 VPN servers (over 30k clients) to new kernel becouse its not
work how it must work. 2.6.15.x have trubles in my scsi controllers. 2.6.16.x -
ok but have trouble in pppd =)  its funny but maybe rollback changes or fix it?

"Drivers -> Other" is very popular category. But PPP_TTY is Other? =)
Please check again and get good chooise =)

P.S. i think bug (or not full tranlate to new TTY algoritms/technology) get in
http://www.kernel.org/git/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=33f0f88f1c51ae5c2d593d26960c760ea154c2e2
maybe author (Alan Cox) look to this trouble?

Thanks.
Comment 11 Daniel Drake 2006-04-29 04:22:32 UTC
Badalian,

The problem with the computone patch appears to have confused the bisection
process, however you were down to a few patches only.

Alan's tty reworking is an obvious suspect here. Can you try applying the
following patch to 2.6.15, and confirming that 2.6.15 breaks after doing that?

http://www.kernel.org/git/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff_plain;h=33f0f88f1c51ae5c2d593d26960c760ea154c2e2;hp=6ed80991a2dce4afc113be35089c564d62fa1f11

For future reference, here is a list of patches between the good/bad points
before the computone point was tested:

	[PATCH] char/isicom: Firmware loading <-- BAD
	[PATCH] char/isicom: Pci probing added
	[PATCH] char/isicom: Other little changes
	[PATCH] char/isicom: Type conversion and variables ...
	[PATCH] char/isicom: Whitespace cleanup
	[PATCH] clean up computone remaining cli use
	[PATCH] n_hdlc.c: remove unused declaration
	[PATCH] TTY layer buffering revamp
	[PATCH] tty-layer-buffering-revamp: jsm is broken
	[PATCH] Serial: disable jsm in ppc64 defconfig <-- GOOD
Comment 12 Daniel Drake 2006-04-29 04:39:17 UTC
Created attachment 7980 [details]
tty rework for 2.6.15

Here is Alan's tty rework fixed to apply against 2.6.15
Comment 13 Badalian Slava 2006-04-29 11:50:33 UTC
ok... i try in few hours... +)
Comment 14 Badalian Slava 2006-05-02 04:21:47 UTC
Sorry for wait.

After applay this patch to 2.6.15.7 kernel have problems discribe upper.

1. try ping... ping ok...
2. try download
ftp://ftp.altlinux.ru/pub/distributions/ALTLinux/ISO/Master-2.4-install-cd.iso
Download started.
3. On 5-15 mb (any time randomly) its freeze.
4. Ping is packet lost
Comment 15 Daniel Drake 2006-05-02 05:00:53 UTC
Alan,

Your TTY layer buffering revamp appears to be the cause of this bug.

This report is a bit long and confusing, so here's a summary:

2.6.15 works fine, but in 2.6.16, the ppp connection stops working after 5-10mb
of data transfer. Everything appears to be up and running, but you cant
transmit/receive anything:

slavon ~ # ping 192.168.0.2
PING 192.168.0.2 (192.168.0.2) 56(84) bytes of data.
ping: sendmsg: No buffer space available

git-bisect more-or-less narrowed this down to the TTY revamp, and we confirmed
this by applying that patch to 2.6.15 and seeing that the bug starts appearing
there too.

What other info can we provide to help debug this?
Comment 16 Alan 2006-05-02 05:25:59 UTC
"PING 192.168.0.2 (192.168.0.2) 56(84) bytes of data.
ping: sendmsg: No buffer space available
ping: sendmsg: No buffer space available"

This is transmit side lockup. The tty revamp is receive side so this is
interesting in itself but could be caused by lost RX stuff. The tty revamp patch
itself will certainly show this on SMP as ages old SMP races suddenly turned
from scribbles into the wrong buffer (mostly harmess) to real problems, but the
follow on patches by Paul Fulghum then fixed all the locking. As such the git
bisect is not useful either.

A good starting point would be to know
- What hardware
- What serial port driver
- What platform
- What speed
- What PPP options
- What the PPP and tcp traces look like
Comment 17 Badalian Slava 2006-05-02 05:46:31 UTC
- What hardware

First PC:

0000:00:00.0 Host bridge: Intel Corporation E7501 Memory Controller Hub (rev 01)
0000:00:00.1 Class ff00: Intel Corporation E7500/E7501 Host RASUM Controller
(rev 01)
0000:00:03.0 PCI bridge: Intel Corporation E7500/E7501 Hub Interface C
PCI-to-PCI Bridge (rev 01)
0000:00:03.1 Class ff00: Intel Corporation E7500/E7501 Hub Interface C RASUM
Controller (rev 01)
0000:00:1d.0 USB Controller: Intel Corporation 82801CA/CAM USB (Hub #1) (rev 02)
0000:00:1d.1 USB Controller: Intel Corporation 82801CA/CAM USB (Hub #2) (rev 02)
0000:00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 42)
0000:00:1f.0 ISA bridge: Intel Corporation 82801CA LPC Interface Controller (rev 02)
0000:00:1f.1 IDE interface: Intel Corporation 82801CA Ultra ATA Storage
Controller (rev 02)
0000:00:1f.3 SMBus: Intel Corporation 82801CA/CAM SMBus Controller (rev 02)
0000:01:0c.0 VGA compatible controller: ATI Technologies Inc Rage XL (rev 27)
0000:02:1c.0 PIC: Intel Corporation 82870P2 P64H2 I/OxAPIC (rev 04)
0000:02:1d.0 PCI bridge: Intel Corporation 82870P2 P64H2 Hub PCI Bridge (rev 04)
0000:02:1e.0 PIC: Intel Corporation 82870P2 P64H2 I/OxAPIC (rev 04)
0000:02:1f.0 PCI bridge: Intel Corporation 82870P2 P64H2 Hub PCI Bridge (rev 04)
0000:03:07.0 Ethernet controller: Intel Corporation 82546EB Gigabit Ethernet
Controller (Copper) (rev 01)
0000:03:07.1 Ethernet controller: Intel Corporation 82546EB Gigabit Ethernet
Controller (Copper) (rev 01)
0000:04:07.0 SCSI storage controller: Adaptec AIC-7902 U320 (rev 03)
0000:04:07.1 SCSI storage controller: Adaptec AIC-7902 U320 (rev 03)

#cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Intel(R) Xeon(TM) CPU 2.40GHz
stepping        : 5
cpu MHz         : 2392.218
cache size      : 512 KB
physical id     : 0
siblings        : 1
core id         : 0
cpu cores       : 1
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe cid xtpr
bogomips        : 4789.60

processor       : 1
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Intel(R) Xeon(TM) CPU 2.40GHz
stepping        : 5
cpu MHz         : 2392.218
cache size      : 512 KB
physical id     : 3
siblings        : 1
core id         : 0
cpu cores       : 1
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe cid xtpr
bogomips        : 4783.94

Second PC: 
00:00.0 Host bridge: Intel Corporation 915G/P/GV/GL/PL/910GL Express Memory
Controller Hub (rev 0e)
00:02.0 VGA compatible controller: Intel Corporation 82915G/GV/910GL Express
Chipset Family Graphics Controller (rev 0e)
00:02.1 Display controller: Intel Corporation 82915G Express Chipset Family
Graphics Controller (rev 0e)
00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High
Definition Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI
Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI
Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI
Express Port 3 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI
Express Port 4 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #3 (rev 03)
00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #4 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB2 EHCI Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev d3)
00:1f.0 ISA bridge: Intel Corporation 82801FB/FR (ICH6/ICH6R) LPC Interface
Bridge (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) IDE
Controller (rev 03)
00:1f.2 IDE interface: Intel Corporation 82801FB/FW (ICH6/ICH6W) SATA Controller
(rev 03)
00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus
Controller (rev 03)
01:03.0 Mass storage controller: Integrated Technology Express, Inc. ITE 8211F
Single Channel UDMA 133 (ASUS 8211 (ITE IT8212 ATA RAID Controller)) (rev 11)
01:08.0 Ethernet controller: Intel Corporation 82562ET/EZ/GT/GZ - PRO/100 VE
(LOM) Ethernet Controller (rev 03)
01:0a.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL-8139/8139C/8139C+ (rev 10)

# cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 15
model           : 4
model name      : Intel(R) Celeron(R) CPU 2.93GHz
stepping        : 1
cpu MHz         : 2926.616
cache size      : 256 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 5
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe lm constant_tsc pni
monitor ds_cpl tm2 cid cx16 xtpr
bogomips        : 5860.88

- What serial port driver
serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
But i use pptpd (poptop) + ppp for VPN.. i don't think that use serial =)

- What platform
Gentoo i686

- What speed
100mbs =)

- What PPP options

name pptpd
refuse-pap
refuse-chap
refuse-mschap
require-mschap-v2
require-mppe-128
ms-dns 10.10.250.250
ms-dns 10.10.140.250
proxyarp
lock
nobsdcomp
novj
novjccomp
nologfd

- What the PPP and tcp traces look like

Don't understand =(
Comment 18 Badalian Slava 2006-05-10 04:00:49 UTC
kernel 2.6.16-r7 (2.6.16.14)
pppd 2.4.3
pptpd v1.2.3


Bug still here =((((
Comment 19 Erik Smit 2006-05-17 08:26:54 UTC
I seem to have the same problem. I recently upgraded my Debian Sarge machine to
2.6.16.11 when I noticed I was getting random lockups in my ppp connection. 

If I start an upload on my windows machine behind my linux debian sarge 'router'
the connection will randomly 'lock up' and a ping will give:
ping: sendmsg: No buffer space available

If I look with tcpdump on the ppp0 when it is happening I notice there is still
incoming traffic, but no more outgoing traffic.

I just downgraded back to 2.6.15.7 and this fixes the problem.

I use pptp to connect to my Alcatel Speedtouch 510.

- What hardware
Celeron 2.4GHz on cheap MSI motherboard, not sure which type, Intel chipset.
- What serial port driver
serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
serial8250: ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
- What platform
Linux/x86, Debian Sarge
- What speed
Speed of what? The ADSL connection of my Alcatel Speedtouch 510 is trained at
6144/768. The PPTP connection is over a 100BaseTX connection.
- What PPP options
armatron:~# cat /etc/ppp/peers/xs4all
pty "pptp 10.0.0.138 --nolaunchpppd --nobuffer"
name username@xs4all-basic-adsl
remotename PPTP
file /etc/ppp/options.pptp
ipparam xs4all
persist
maxfail 0
defaultroute
armatron:~# cat /etc/ppp/options.pptp
lock noauth nobsdcomp nodeflate
armatron:~# cat /etc/ppp/options
asyncmap 0
auth
crtscts
lock
hide-password
modem
proxyarp
lcp-echo-interval 30
lcp-echo-failure 4
noipx
- What the PPP and tcp traces look like

tcpdump only shows incoming traffic during the lockup. It will start working
again after a few (5-30) seconds.

pppd doesn't seem to give any problems.
Comment 20 Alan 2006-05-17 08:54:29 UTC
All useful to know as it means the serial layer is not being used at all in
these cases, but might point to a bug in PPTP handling or perhaps in the tty/pty
code 
Comment 21 Badalian Slava 2006-05-17 11:29:48 UTC
Maybe rollback changes on
http://www.kernel.org/git/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff_plain;h=33f0f88f1c51ae5c2d593d26960c760ea154c2e2;hp=6ed80991a2dce4afc113be35089c564d62fa1f11
or anyone debug and find bug? I not so prof to debug drivers. =(

After this patch pptpd have troubles. 
Comment 22 Badalian Slava 2006-05-31 10:26:55 UTC
Hello. Have progress ?
Comment 23 David Boreham 2006-06-02 10:37:58 UTC
It would appear that we have the same bug here.
A router running FC4 began exhibiting trouble with the pptp server it runs
a while ago. After much head-scratching, packet traces, logging and so on,
I ran into a reference to this bug on the poptop mailing list.
Booted the machine with an older kernel (2.6.14-1.1656_FC4smp) and
hey presto the pptp problems went away. The 'broken' kernel it 
was running previously was kernel-2.6.16-1.2111_FC4smp.

Symptoms were similar to those reported by others : tunnel appears to
quit passing traffic after some reasonably short period of time (a minute or
two), which I suppose could easily correspond to a few megs of data.



Comment 24 Badalian Slava 2006-06-05 23:03:52 UTC
Anyone... I try but i can't find where bug in patch =( 
PPl... Please help... =(
Comment 25 Daniel Drake 2006-06-12 00:53:43 UTC
Paul Mackerras posted a patch which looks promising:
http://marc.theaimsgroup.com/?l=linux-kernel&m=115007881906465&q=raw
Comment 26 Badalian Slava 2006-06-13 23:15:19 UTC
Fixed +) Patch work.
Also make this bug duplicate of http://bugzilla.kernel.org/show_bug.cgi?id=6530

All thanks )
Comment 27 Miernik 2007-06-08 21:46:23 UTC
Is this bug patch already applied to the main kernel, or not? If so, in which
version? If not, can it please be applied? I think I am getting similar problems
with 2.6.21, read here: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=426440

Note You need to log in before you can comment on or make changes to this bug.