Bug 63811 - Backlight keys do not work on Lenovo Yoga
Summary: Backlight keys do not work on Lenovo Yoga
Status: CLOSED DUPLICATE of bug 51231
Alias: None
Product: ACPI
Classification: Unclassified
Component: Power-Video (show other bugs)
Hardware: x86-64 Linux
: P1 normal
Assignee: acpi_power-video
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-26 21:13 UTC by Kevin Smith
Modified: 2014-10-28 05:06 UTC (History)
2 users (show)

See Also:
Kernel Version: 3.12.0-rc5
Tree: Mainline
Regression: No


Attachments
Lenovo Yoga 13 ACPI dump (258.54 KB, application/octet-stream)
2013-10-26 21:13 UTC, Kevin Smith
Details

Description Kevin Smith 2013-10-26 21:13:03 UTC
Created attachment 112341 [details]
Lenovo Yoga 13 ACPI dump

I have a problem very similar to bug 51231, but on a Lenovo Yoga 13.  The brightness keys in X do not change the backlight.  Booting with normal kernel options results in two entries in /sys/class/backlight: acpi_video0 and intel_backlight.  acpi_video0 has no effect on the brightness, but intel_backlight does.  When the brightness keys are pressed, X is changing the acpi_video0 brightness.

Booting with acpi_osi="!Windows 2012" does not seem to make a difference.  Booting with acpi_backlight=vendor creates:
ideapad -> ../../devices/platform/ideapad/backlight/ideapad
intel_backlight -> ../../devices/pci0000:00/0000:00:02.0/drm/card0/card0-LVDS-1/intel_backlight
instead of acpi_video0.  This one does not work either.  (intel_backlight still works).

ACPI dump output is attached.  I am glad to try patches, boot options, etc.
Comment 1 Kevin Smith 2013-10-27 18:11:10 UTC
I tried v5 of the patch series attached to bug 51231 on 3.12.0-rc5 on my Yoga, and can verify that booting with video.use_native_backlight=1 corrects the problem.  (At first glance, I thought the patch series only fixed the problem for models using the thinkpad driver, so didn't look into it.)  acpi_video0 does not appear, and so X uses intel_backlight instead.

This is good enough for me to consider the issue resolved, but I'm still glad to test out any changes.
Comment 2 Aaron Lu 2013-10-28 02:18:24 UTC
I'll add Yoga 13 into a quirk table to skip register ACPI video's backlight interface for it, so no cmdline option is needed.

*** This bug has been marked as a duplicate of bug 51231 ***

Note You need to log in before you can comment on or make changes to this bug.