Bug 6376 - cpufreq wrongly reports "frequency should be within 600 MHz and 600 MHz"
cpufreq wrongly reports "frequency should be within 600 MHz and 600 MHz"
Status: REJECTED DUPLICATE of bug 6331
Product: Power Management
Classification: Unclassified
Component: cpufreq
i386 Linux
: P2 high
Assigned To: Thomas Renninger
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-11 11:14 UTC by Stijn Van Nieuwenhuyse
Modified: 2006-04-13 03:50 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.16
Tree: Mainline
Regression: ---


Attachments

Description Stijn Van Nieuwenhuyse 2006-04-11 11:14:54 UTC
Most recent kernel where this bug did not occur: Any 2.6.x kernel
Distribution: Gentoo Linux
Hardware Environment: Dell Latitude D800 Pentium M 1.70 GHz (Dothan)
Software Environment:
Problem Description:
Every time I unplug the ac adapter, cpufreq want go up to 1.70 GHz.
cpufreq-info reports wrongly "frequency should be within 600 MHz and 600 MHz"
If I plugin the ac adapter again and wait a couple of seconds, speedstepping 
works correct again. I have tried both with acpi-cpufreq and speedstep-centrino 
driver. It also happens with every governor.


Steps to reproduce:
1. unplug ac adapter
2. cpufreq-info displays wrong maximum frequency.
Comment 1 Stijn Van Nieuwenhuyse 2006-04-11 11:19:14 UTC
I made a mistake in the first line and could not find the edit button:
Every time I unplug the ac adapter, cpufreq DOES NOT want TO go up to 1.70 GHz.
Comment 2 Stijn Van Nieuwenhuyse 2006-04-11 11:41:56 UTC
I think this problem could be related with bug #6370
Comment 3 Thomas Renninger 2006-04-13 03:50:04 UTC

*** This bug has been marked as a duplicate of 6331 ***

Note You need to log in before you can comment on or make changes to this bug.