Bug 6370 - cpufreq problems on Pentium-M
cpufreq problems on Pentium-M
Status: REJECTED DUPLICATE of bug 6331
Product: Power Management
Classification: Unclassified
Component: cpufreq
i386 Linux
: P2 normal
Assigned To: Thomas Renninger
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-10 06:52 UTC by Jean-Marc Valin
Modified: 2006-04-13 03:45 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.15.5
Tree: Mainline
Regression: ---


Attachments

Description Jean-Marc Valin 2006-04-10 06:52:46 UTC
Most recent kernel where this bug did not occur:
2.6.12-rc5

Distribution:
Ubuntu 5.10

Hardware Environment:
Dell Latitude D600 laptop
Pentium-M 1.6 GHz
1 GB RAM

Software Environment:
Default Ubuntu environment, except for stock kernel

Problem Description:
A while (could be minutes, hours, days) after I boot my laptop, the speedstep
control stops working correctly. I usually set the governor to ondemand, but
after a while, the speed gets stuck to 600 MHz (instead of 1.6 GHz) and does not
increase when necessary. Even if I then switch to "performance", the speed stays
at 600 MHz. Both /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq and
/proc/cpuinfo indicate 600 MHz, although the gnome cpufreq applet indicates
(wrongly) 1.6 GHz.

Steps to reproduce:
Boot my machine, set policy to "ondemand", wait for a while. I indicated
2.6.12-rc5 as the last kernel where cpufreq worked. While I haven't done much
testing for that (it's an intermittent problem), this version corresponds to the
last time the kernel worked properly with my laptop. Since 2.6.12-rc6, I've been
having the problems described in bugs 6166 and 6266.
Comment 1 Adrian Bunk 2006-04-10 11:17:59 UTC
Is this problem stll present in kernel 2.6.16.2?
Comment 2 Thomas Renninger 2006-04-13 03:45:00 UTC
Someone asked me whether the patches are save for backporting to a stable     
kernel. Not sure whether this had happened. Be sure all 4 patches (stated in     
bug #6331) get added.   
I fixed that on a DELL 600. I am quite sure this also fixes other DELL   
models(DELL 660 - this one, bug #6266 and bug #6166, Dell inspiron 9300 - bug 
#6331, Dell Latitude D800 - bug #6376). 
See bug #6331 for further description. 
I can't mark the bugs as a duplicates, so I will close them all with a note to 
verify the fix for recent kernels. 
Comment 3 Thomas Renninger 2006-04-13 03:45:49 UTC
Ok, I need to assign it to set it as a duplicate ... 

*** This bug has been marked as a duplicate of 6331 ***

Note You need to log in before you can comment on or make changes to this bug.