Bug 6360 - alim15x3.c driver need to update
Summary: alim15x3.c driver need to update
Status: REJECTED DUPLICATE of bug 6358
Alias: None
Product: IO/Storage
Classification: Unclassified
Component: IDE (show other bugs)
Hardware: i386 Linux
: P2 normal
Assignee: Bartlomiej Zolnierkiewicz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-04-09 03:04 UTC by KAI.HSU
Modified: 2006-04-09 04:27 UTC (History)
0 users

See Also:
Kernel Version: ALL Linux 2.4.x & 2.6.x
Tree: Mainline
Regression: ---


Attachments

Description KAI.HSU 2006-04-09 03:04:44 UTC
Most recent kernel where this bug did not occur:
Distribution: ALL Linux kernel
Hardware Environment: ULI M-1573 south Bridge chip
Software Environment: Standard Linux Kenrel
Problem Description: 
The alim15x3.c havn't been update for 3 years.
Recently when we use this "ULI M1573" south bridge chip found that can't mount 
CDROM(VCD) smoothly, must waiting for a long time.
After I check the "ULI M1573" south bridge datasheet, I found the reason.
The reason is the "ULI M1573" version in the Linux is "0xC7" not "0xC4" anymore
So I was modified the source than it was successed.

Steps to reproduce:
Origianl kerenl source as below:
================================
        if(m5229_revision <= 0x20)
                tmpbyte = (tmpbyte & (~0x02)) | 0x01;
        else
                tmpbyte |= 0x01;

Below is modify source:
=================================
        if(m5229_revision <= 0x20)
                tmpbyte = (tmpbyte & (~0x02)) | 0x01;
        else if(m5229_revision == 0xC7)
                tmpbyte |= 0x03;
        else
                tmpbyte |= 0x01;
Comment 1 Adrian Bunk 2006-04-09 04:27:27 UTC

*** This bug has been marked as a duplicate of 6358 ***

Note You need to log in before you can comment on or make changes to this bug.