Bug 6352 - usbnet does not create a usb0 device
usbnet does not create a usb0 device
Status: RESOLVED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: USB
i386 Linux
: P2 high
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks: USB
  Show dependency treegraph
 
Reported: 2006-04-07 23:50 UTC by Eugenia Loli-Queru
Modified: 2006-04-08 08:09 UTC (History)
0 users

See Also:
Kernel Version: 2.6.16.1
Tree: Mainline
Regression: ---


Attachments

Description Eugenia Loli-Queru 2006-04-07 23:50:07 UTC
Most recent kernel where this bug did not occur: 2.6.16
Distribution: Arch Linux and Fedora Core 5
Hardware Environment: a laptop (info:
http://www.linuxcertified.com/test-reports/lc2430-report/debian-info.epl.html )

Software Environment: udev-only. No devfs or hotplug (removed by Arch Linux as
"legacy").

Problem Description:
I need to telnet inside my Linux phone (Motorola A780) and my Zaurus. I put the
phone to "modem mode", I connect the usb cable, and the system can see the
device on /dev/ttyACM0 just fine. I load the "usbnet" module, and next I need to
ifconfig the usb0 interface. Well, that's the problem, there is no usb0 device
to be found. Ifconfig says it doesn't exist, but users of older kernels are
having that interface created. With more recent kernels on both my distros, this
interface is not created automatically for me, so I can't continue with ifocnfig
usb0 and then telnet in the phone. I also tried plugging and unpluggin the phone
and I also tried: echo 'AT+MODE=99' > /dev/ttyACM0
which disconnected and connected back the device, but no luck. Usb0 (or
equivelant) is nowhere to be found.
Comment 1 Eugenia Loli-Queru 2006-04-08 02:10:22 UTC
Never mind, it worked after loading the  cdc-acm module...

Note You need to log in before you can comment on or make changes to this bug.