Bug 6326 - S3 resume: IDE fails to resume - Abit NF7 nForce2
S3 resume: IDE fails to resume - Abit NF7 nForce2
Status: REJECTED INSUFFICIENT_DATA
Product: IO/Storage
Classification: Unclassified
Component: IDE
i386 Linux
: P2 normal
Assigned To: Bartlomiej Zolnierkiewicz
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-04 01:12 UTC by Andreas Saur
Modified: 2006-12-03 09:42 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.16-rc6-mm2
Tree: Mainline
Regression: ---


Attachments
Additional Information for bugreport #6326 (lshw, acpidump, dmesg ... ) (343.40 KB, text/plain)
2006-04-04 15:57 UTC, Andreas Saur
Details
supplemental: dmidecode (10.59 KB, text/plain)
2006-04-05 04:32 UTC, Andreas Saur
Details
supplemental: dmesg -s40000 (15.10 KB, text/plain)
2006-04-05 04:34 UTC, Andreas Saur
Details
minimal .config for NF7 (3.93 KB, text/plain)
2006-04-11 02:01 UTC, Andreas Saur
Details
dmesg/lspci (pnp: Failed to activate device 00:09) (15.19 KB, text/plain)
2006-04-12 22:50 UTC, Andreas Saur
Details
Got it working. (see .config) (40.38 KB, text/plain)
2006-08-10 12:48 UTC, Andreas Saur
Details

Description Andreas Saur 2006-04-04 01:12:35 UTC
Most recent kernel where this bug did not occur:N/A
Distribution: Debian Sid
Hardware Environment:Abit NF7 Rev V2.0 + Radeon 9550 SE (lspci -vvv to come)
Software Environment: Debian Sid standard. (ver_linux to come)
Problem Description: after "echo -n mem > /sys/power/state" the box doesn't come
back anymore.

Steps to reproduce:
1) boot in sigle-user-mode with kernel-switch "init=/bin/sh"  and mount proc and sys
2) #echo -n mem > /sys/power/state

vanilla kernels I've already tried:
- 2.6.13-? (to come)
- 2.6.14-? (to come)
- 2.6.15-rc5
- 2.6.16-rc3
- 2.6.16-rc6
- 2.6.16-rc6-mm2

workarounds I've tried:
- compiled a new DSDT for initrd (old had one return-value warning)
- kernel-switch: acpi_sleep=s3_bios
- kernel-switch: acpi_sleep=s3_mode
- kernel-switch: acpi_sleep=s3_bios,s3_mode
- kernel w/o framebuffers at all
- kernel w/o usb at all
- w/ xorg-6.8.2 and xfree86 4.3.0: ati/radeon/vesa
- no X11 at all
- turned off all Motherboard-BIOS-switches but S3
- #hibernate -F /etc/hibernate/ram.conf
- vbetool
- radeontool

Detailed Problem Description:
-----------------------------
After invoking #echo -n mem > /sys/power/state
the system powers off. Pressing a key, lets the system turn on CPU-Fan and HDD
und CD-Rom. The keyboard-LED "NUM" turns on. No keypresses (Capslock etc.) are
doing anything with the keyboard-LEDs. Both Monitors (TFT-Screens) stay black.
Can't also ping the box. Needless to say: Windows works.
Comment 1 Andreas Saur 2006-04-04 01:20:19 UTC
to come (when at home):

-#dmesg #after boot
-#cat /proc/cpuinfo
-#cat /usr/src/linux/.config
Comment 2 Andreas Saur 2006-04-04 15:57:28 UTC
Created attachment 7762 [details]
Additional Information for bugreport #6326 (lshw, acpidump, dmesg ... )

Here comes the additional information about my system (see attachment):

## OVERVIEW ##
--------------

##(1)## uname -a

##(2)## lshw

##(3)## ver_linux

##(4)## cat /proc/cpuinfo

##(5)## cat /proc/modules

##(6)## cat /proc/ioports

##(7)## cat /proc/iomem

##(8)## cat lspci -vvv

##(9)## cat /usr/src/linux/.config

##(10)## dmesg

##(11)## acpidump

##(12)## cat /root/dsdt.dsl

-----------------
 Unfortunaly I cannot send anything from the logs after the crash, because the
system isn't available. If anybody has an idea how to manage to gather
information (serial console or so) from the system shortly after the crash, so
please let me know.

Thanks in advance for help.
Comment 3 Andreas Saur 2006-04-05 04:32:58 UTC
Created attachment 7767 [details]
supplemental: dmidecode
Comment 4 Andreas Saur 2006-04-05 04:34:59 UTC
Created attachment 7768 [details]
supplemental: dmesg -s40000

the last dmesg was kind of cut. here is a complete one.
Comment 5 Andreas Saur 2006-04-05 05:01:34 UTC
Comment on attachment 7767 [details]
supplemental: dmidecode

oops! wrong kernel. I've booted the box with 2.6.15.6-kanotix-1. Will correct
this later.
Comment 6 Andreas Saur 2006-04-05 05:02:08 UTC
Comment on attachment 7768 [details]
supplemental: dmesg -s40000

oops! wrong kernel. I've booted the box with 2.6.15.6-kanotix-1. Will correct
this later.
Comment 7 Andreas Saur 2006-04-05 16:16:22 UTC
Just tried kernel 2.6.17-rc1-mm1, still no luck. System doesn't boot. Keyboard
is dead. Despairingly started some Voodoo stuff with the Motherboard's BIOS
switches. I know it's nonesense, Windows XP works with the standard settings.
I've read in some forums (few/some/many) nForce2 boards seems to be affected.
I've also tried one old PCI-based Matrox Mystique (mga) and an nVidia TI4200
(nv) Adapter, but stil no dice.
Any additional information needed?
Comment 8 Shaohua 2006-04-10 19:01:04 UTC
Does shutdown/resboot work on the system?
Also please try to remove as many modules as you can, and try if this helps s3.
Comment 9 Andreas Saur 2006-04-11 02:01:08 UTC
Created attachment 7834 [details]
minimal .config for NF7

The system reboot/shutdown fine. Suspend2 suspend2disk works also. My .config
is pretty minimal (see attachment). In the sigle-user-mode are no modules
loaded.
I've also tried the kernel without framefb, modules, usb and preemt.
But I remember one thing, and don't know whether this has anything to do with
this bug. Once I had enabled Kernel-Debugging with CONFIG_MUTEX_DEBUG on. With
this settings I couldn't shutdown or S3 at all. When I tried to shutdown or to
S3 the system, there was a message given something like that:

  Strange, rt-test-00 ??? not stoppted
  Strange, rt-test-01 ??? not stoppted
  Strange, rt-test-02 ??? not stoppted
  Strange, rt-test-03 ??? not stoppted
  .
  .
  .

Thanks for help in advance

p.s. tried yesterday an Abit AV8. This board DO the S3 thing with a stock
vanilla 2.6.15-6, damn!
Comment 10 Andreas Saur 2006-04-12 22:50:12 UTC
Created attachment 7852 [details]
dmesg/lspci (pnp: Failed to activate device 00:09)

I've finally manage to get a more or less usefull log from my box.
It seems that IDE (00:09) didn't like to resume. I guess that's why I'm getting
an instant freez after resume with a dead keyboard. Here the most interesting
(at least for me) lines of my dmesg:

hwsleep-0285 [11] enter_sleep_state	: Entering sleep state [S3]
Back to C!
PM: Finishing wakeup.
ACPI: PCI Interrupt 0000:00:04.0[A] -> Link [LMAC] -> GSI 11 (level, 
low) -> IRQ 11
PCI: Setting latency timer of device 0000:00:04.0 to 64
PCI: Setting latency timer of device 0000:00:08.0 to 64
pnp: Failed to activate device 00:09.
Restarting tasks... done
[ACPI Debug]  String: [0x15] "==== SST Working ===="
ACPI Error (evevent-0314): No installed handler for fixed event 
[00000002] [20060310]
[ACPI Debug]  String: [0x15] "==== SST Working ===="
Comment 11 Shaohua 2006-07-18 19:03:59 UTC
>It seems that IDE (00:09) didn't like to resume.
How did you get this? IDE indead is the root cause in many systems. you can 
try to build a test kernel without IDE support (so can't mount root fs) and in 
the initramfs you can write a script to do s3, see if it works.
Comment 12 Andreas Saur 2006-08-10 12:48:56 UTC
Created attachment 8748 [details]
Got it working. (see .config)

I finally got S3 to work here. Here are my three steps for the Kernel
2.6.17-rc5-mm1:

1) IDE-Patch: ( just for one IDE drive, if CD-ROM is present, it failed again)
--- drivers/ide/ide.c.orig 2006-05-29 20:12:37.000000000 +0000
+++ drivers/ide/ide.c	2006-05-29 20:14:04.000000000 +0000
@@ -1248,7 +1248,8 @@
   rqpm.pm_step = ide_pm_state_start_resume;
   rqpm.pm_state = PM_EVENT_ON;

-  return ide_do_drive_cmd(drive, &rq, ide_head_wait);
+  (void) ide_do_drive_cmd(drive, &rq, ide_head_wait);
+  return set_xfer_rate(drive, XFER_UDMA_6);

 }

2) nVidia graphics card needed + latest nVidia driver ( mine is 8762 )
 - Agpgart in Kernel is on
 - xorg.conf: 'Option "NvAGP" "1"'
I gave up to get my Radeon going with S3. Bought an nVidia.

3) Kernel prior 2.6.17-rc5 can't resume on WOL with forcedeth.

Comment: It took me more than 3 month of investigation to get this thing
working, unbelievable!!

Thanks to all, who helped me.

Regards,

Andreas
Comment 13 Andreas Saur 2006-08-10 12:52:30 UTC
Comment on attachment 8748 [details]
Got it working. (see .config)

See config file for Abit NF7 nForce2.
Usage: Media Center PC (mmsv2 + vdr), low voltage (1.1V).
Comment 14 Len Brown 2006-08-11 12:53:33 UTC
> drivers/ide/ide.c   
   
Moving this bug from ACPI to IDE.  
  
  
   
Comment 15 Pavel Machek 2006-09-29 04:20:12 UTC
Is the bug still present in 2.6.18?
Comment 16 Rafael J. Wysocki 2006-10-30 09:41:22 UTC
I think this bug should be closed.
Comment 17 Adrian Bunk 2006-12-03 09:42:06 UTC
Please reopen this bug if it's still present in kernel 2.6.19.

Note You need to log in before you can comment on or make changes to this bug.