Bug 6306 - kernel/built-in.o:(.data+0xd10): undefined reference to `uevent_helper'
kernel/built-in.o:(.data+0xd10): undefined reference to `uevent_helper'
Status: CLOSED CODE_FIX
Product: Other
Classification: Unclassified
Component: Other
i386 Linux
: P2 normal
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-30 04:22 UTC by Russell King
Modified: 2006-06-05 08:42 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.16-git6 onwards
Tree: Mainline
Regression: ---


Attachments
allow CONFIG_NET=n (2.01 KB, patch)
2006-04-03 15:41 UTC, Kay Sievers
Details | Diff

Description Russell King 2006-03-30 04:22:11 UTC
Most recent kernel where this bug did not occur: 2.6.16ish
Distribution:
Hardware Environment:
Software Environment:
Building an ARM kernel using h7201_defconfig configuration

Problem Description:

  LD      .tmp_vmlinux1
kernel/built-in.o:(.data+0xd1c): undefined reference to `uevent_helper'
make: *** [.tmp_vmlinux1] Error 1
make: Leaving directory `/var/tmp/kernel-orig'

Steps to reproduce:
Compile a kernel with CONFIG_HOTPLUG but without CONFIG_NET
Comment 1 Russell King 2006-03-30 04:28:38 UTC
Still present in 2.6.16-git18.  From my message on LKML:

which seems to be a reference from sysfs.c for ...proc.../sys/kernel/hotplug.
                                                                                
This brings up an interesting point - if CONFIG_NET is not set and
CONFIG_HOTPLUG is set, don't we want to call /sbin/hotplug?  If
...proc.../sys/kernel/hotplug isn't present then what?
Comment 2 Kay Sievers 2006-04-03 15:41:39 UTC
Created attachment 7754 [details]
allow CONFIG_NET=n

Michael, does this work for you?
Comment 3 Greg Kroah-Hartman 2006-05-08 14:59:26 UTC
This is now fixed in Linus's tree.
Comment 4 Russell King 2006-06-05 08:42:07 UTC
Confirmed as fixed.

Note You need to log in before you can comment on or make changes to this bug.