Bug 6260 - SATA hard disk with AHCI mode lost after S3
SATA hard disk with AHCI mode lost after S3
Status: REJECTED DUPLICATE of bug 6262
Product: ACPI
Classification: Unclassified
Component: Power-Sleep-Wake
i386 Linux
: P2 normal
Assigned To: Diego Calleja
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-21 00:51 UTC by Austin Yuan
Modified: 2006-03-21 02:36 UTC (History)
0 users

See Also:
Kernel Version: 2.6.16-rc6
Tree: Mainline
Regression: ---


Attachments

Description Austin Yuan 2006-03-21 00:51:35 UTC
Most recent kernel where this bug did not occur: N/A

Distribution: Redflag 5.0 with 2.6.16-rc6 kernel

Hardware Environment:
CPU: P4 3.6G
MB/Chipset: 945GNTR with on-board Gfx/Audio/Lan
(http://www.intel.com/products/motherboard/d945gnt/index.htm)
Hard-disk: ST3120026AS, 120G

Software Environment:
Redflag 5.0 and 2.6.16-rc6 kernel with an AHCI suspend/resume patch from
http://marc.theaimsgroup.com/?l=linux-kernel&m=114122220923417&w=2

Problem Description:
SATA hard disk with AHCI mode lost after resuming from S3


Steps to reproduce:
1. Set SATA mode in BIOS into AHCI (another two mode is "IDE" and "RAID")

2. Get latest 2.6.16-rc6 kernel and patch it with a patch from
http://marc.theaimsgroup.com/?l=linux-kernel&m=114122220923417&w=2

3. Configure the kernel with minimal components (removing module,USB,1394, audio
and other unnecessary components support, but including SATA/AHCI, ACPI and
network support), build and install it.

4. Boot with the new kernel into console mode (init 3)

5. log into the system from one remote machine by ssh

6. Enter S3 by "echo mem > /sys/power/state", and then press powerbutton to
resume (using vbetool to re-post the display)

7. Then display is normal, and ssh session is still living, but hard disk is
lost. (there are many error messages like "sd 0:0:0:0: SCSI error: return code =
0x40000")
Comment 1 Diego Calleja 2006-03-21 02:36:48 UTC

*** This bug has been marked as a duplicate of 6262 ***

Note You need to log in before you can comment on or make changes to this bug.